New Member
Posts: 6
Registered: ‎05-02-2014

PPTP Client DNS issues

Hello,

 

Currently I have a rather simple setup with a server, a printer, and several clients on a LAN.  I also have several users that connect using the USG's Remote Access VPN feature via PPTP.  VPN clients can connect to devices on the LAN fine by IP. Connecting to, or pinging, the host name is not working at all.  nslookup resolves the correct IP.

 

I am comfortable making CLI changes and exporting them to the controller...

  

Here's what I have in my config.gateway.json to try to get this going.  The eth1 IP is 10.10.1.1:

{
"service": {
"dns": {
"forwarding": {
"cache-size": "500",
"listen-on": [
"eth1",
"eth2"
],
"options": [
"host-record=host1,10.10.1.10",
"host-record=host1.domain.com,10.10.1.10",
"host-record=host2,10.10.2.10",
"host-record=host2.domain.com,10.10.2.10",
"listen-address=10.10.1.1"
]
}
}
},
"vpn": {
"pptp": {
"remote-access": {
"authentication": {
"mode": "radius",
"radius-server": {
"x.x.x.x": {
"key": "SuperSecretKey"
}
}
},
"client-ip-pool": {
"start": "10.10.101.1",
"stop": "10.10.101.254"
},
"dns-servers": {
"server-1": "10.10.1.1",
"server-2": "8.8.8.8"
},
"mtu": "1492"
}
}
}

}

 

New Member
Posts: 2
Registered: ‎05-12-2015

Re: PPTP Client DNS issues

I am having similar issue.

I just got a couple at work to test. So far not overly impressed but I can see potential if Ubiquity gets their act together and supports more CLI features in GUI.

 

I setup remote PPTP VPN.

 

Was trying to use the router IP for DNS and could not get it to resolve DNS when connecting via PPTP.

 

I am testing using my iPhone btw.

 

Try taking out the 10.10.1.1 and just using Google's 8.8.8.8

I found out that I cannot use Router as DNS in this case.

 

I don't understand why this is though since a PC on the local LAN uses the router as a DNS server. I can even connect to the USG webpage from my iPhone using its IP so it is not as if it is being blocked.

 

I have not yet tested using another DHCP server (eg. a domain controller) on the network but I don't see why that wouldn't work.

 

I am not using Radius but rather local authentication with modified  .json file. The files/instructions posted elsewhere don't work correctly (error in json) and some other firewall settings have to be added in order to get to work, but that's another post I will do shortly after I do some testing.

 

Emerging Member
Posts: 76
Registered: ‎06-18-2015
Kudos: 3
Solutions: 2

Re: PPTP Client DNS issues

How did you guys setup the PPTP VPN on the USG?  I would really appreciate it.

Highlighted
New Member
Posts: 2
Registered: ‎07-20-2015
Kudos: 1

Re: PPTP Client DNS issues

[ Edited ]

Any update on getting DNS to work over PPTP VPN?