New Member
Posts: 5
Registered: ‎06-20-2016

RMA Request

I have a switch that was not working out of the box and received an RMA approval, however that approval did not include a shipping label? I've tried to email the RMA dept with no response. I've also used the support chat line with the support specialist saying refer my case to the RMA dept. However I still have yet to receive a response. My question being is it the Ubiquiti's standard operating procedure that the customer is expected to pay for shipping and insurance to return a defective switch? This is actually pretty costly for a small company that doesn't do much shipping, especially when adding the insurance. This is especially inconvenient due to the small profit margin on this job.

Ubiquiti Employee
Posts: 529
Registered: ‎04-03-2017
Kudos: 199
Solutions: 9

Re: RMA Request

Hi @nexuscomm

 

Thanks for letting me know that. I will be contacting you via PM to gather some more information about the RMA number and more information about the switch.

 

Thanks,

David S

 


UBNT_Alternate_Logo.png

Ubiquiti Networks Enterprise Team

Check out our ever-evolving Help Center for answers to many common questions!

FREE UBWA Student Guide-Great RF Primer!

FREE UBRSS Student Guide-Great Intro to Routing & Switching!

Having connectivity issues? See: UniFi Debugging Intermittent Connectivity Issues on your UAP

Learn How to Establish a Connection Using SSH Here

Emerging Member
Posts: 47
Registered: ‎04-06-2015
Kudos: 3

Re: RMA Request

I have the same exact question. I received an RMA approval email, but no label. I replied back but haven't heard anything.