Deleted Account
Posts: 0

Second prefix (ULA) in Router Advertisement

[ Edited ]

Would someone share the config.gateway.json lines to announce a second (ULA) prefix in router advertisements? Or point me in the right direction to figure it out on my own.

 

I have a USG4P.

 

I think it would be something like this (not sure what would be appropriate for the name argument, certainly not eth0). Beyond that I'm clueless Man Wink

 

set interfaces eth0 eth0 ipv6 address eui64 fd00::/8

I think the above would set only the ULA on the interface, I would like to announce both the GUA and ULA.

 

So something would need to be added here (not from my gateway but from the manual ipv6 config support post):

 

"interfaces": {
                "ethernet": {
                        "eth2": {
                                "dhcpv6-pd": {
                                        "pd": {
                                                "0": {
                                                        "interface": {
                                                                "eth0": "''"
                                                        },
                                                        "prefix-length": "64"
                                                }
                                        },
                                        "rapid-commit": "enable"
                                },
                                "firewall": {
                                        "in": {
                                                "ipv6-name": "wan_in-6"
                                        },
                                        "local": {
                                                "ipv6-name": "wan_local-6"
                                        }
                                }
                        },
                        "eth0": {
                                "ipv6": {
                                        "dup-addr-detect-transmits": "1",
                                        "router-advert": {
                                                "cur-hop-limit": "64",
                                                "link-mtu": "0",
                                                "managed-flag": "true",
                                                "max-interval": "600",
                                                "other-config-flag": "false",
                                  ----->        "prefix": {
                                                        "::/64": {
                                                                "autonomous-flag": "true",
                                                                "on-link-flag": "true",
                                                                "valid-lifetime": "2592000"
                                                        }
                                                },
                                                "reachable-time": "0",
                                                "retrans-timer": "0",
                                                "send-advert": "true"
                                        }
                                }
                        }

 

 

Thanks! 

Deleted Account
Posts: 0

Re: Second prefix (ULA) in Router Advertisement

[ Edited ]

OK, so I did this and it looks like it works OK.

 

set interfaces ethernet eth0 ipv6 router-advert prefix fd12:3456:789a:bcde::/64
set interfaces ethernet eth0 ipv6 router-advert prefix fd12:3456:789a:bcde::/64 autonomous-flag true
set interfaces ethernet eth0 ipv6 router-advert prefix fd12:3456:789a:bcde::/64 on-link-flag true
set interfaces ethernet eth0 ipv6 router-advert prefix fd12:3456:789a:bcde::/64 preferred-lifetime 14400
set interfaces ethernet eth0 ipv6 router-advert prefix fd12:3456:789a:bcde::/64 valid-lifetime 86400

And it worked. I now get the deligated prefix from my ISP, the prefix from above and a link address on each client like this (I cut out my prefix from my isp, not sure why I need to, but I did):

 

ip -6 addr show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fd12:3456:789a:bcde:26f0:5441:8826:3502/64 scope global mngtmpaddr noprefixroute dynamic 
       valid_lft 86247sec preferred_lft 14247sec
    inet6 xxxx:xxxx:xxxx:xxxx:22b1:71a3:ec50:4744/64 scope global mngtmpaddr noprefixroute dynamic 
       valid_lft 86247sec preferred_lft 14247sec
    inet6 fe80::6f3a:60d:1df5:347/64 scope link 
       valid_lft forever preferred_lft forever

I'm not sure about the scope, should that be global for the fd:: address? But again, I'm not really sure about any of this, I'm just following along as best I can. I know exactly nothing about vyatta.

 

Any thoughts, is there a big huge mistake I have made? 

 

 

Highlighted
Deleted Account
Posts: 0

Re: Second prefix (ULA) in Router Advertisement

[ Edited ]

Ok, so I did this:

 

set interfaces ethernet eth0 ipv6 router-advert prefix fd12:3456:789a:bcde::/64
set interfaces ethernet eth0 ipv6 router-advert prefix fd12:3456:789a:bcde::/64 autonomous-flag true
set interfaces ethernet eth0 ipv6 router-advert prefix fd12:3456:789a:bcde::/64 on-link-flag true
set interfaces ethernet eth0 ipv6 router-advert prefix fd12:3456:789a:bcde::/64 preferred-lifetime 0
set interfaces ethernet eth0 ipv6 router-advert prefix fd12:3456:789a:bcde::/64 valid-lifetime 86400

and it workes.

 

made permanent with config.gateway.json:

 

{
        "interfaces": {
                "ethernet": {
                        "eth0": {
                               "ipv6": {
                                        "router-advert": {
                                                "prefix": {
                                                        "fd12:3456:789a:bcde::/64": {
                                                                "autonomous-flag": "true",
                                                                "on-link-flag": "true",
                                                                "preferred-lifetime": "0",
                                                                "valid-lifetime": "86400"
                                                        }
                                                }
                                        }
                                }
                         }
                }
        }
}

 

I can see on my clients this:

 

ip -6 addr show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fd12:3456:789a:bcde:26f0:5441:8826:3502/64 scope global mngtmpaddr noprefixroute dynamic 
       valid_lft 86247sec preferred_lft 0sec
    inet6 xxxx:xxxx:xxxx:xxxx:22b1:71a3:ec50:4744/64 scope global mngtmpaddr noprefixroute dynamic 
       valid_lft 86247sec preferred_lft 14247sec
    inet6 fe80::6f3a:60d:1df5:347/64 scope link 
       valid_lft forever preferred_lft forever

 

I did:

 

traceroute -6 -s fd12:3456:789a:bcde:26f0:5441:8826:3502 google.com

and it didn't work as expected. A traceroute with my deligated prefix address worked fine.

 

Anything obvously wrong? 

 

This is all very new to me, so please be gentle with me.

 

Thanks!

New Member
Posts: 4
Registered: ‎02-23-2018

Re: Second prefix (ULA) in Router Advertisement

I am obviously doing something wrong because I can't seem to get that to work for the life of me.