Reply
New Member
Posts: 14
Registered: ‎05-22-2015

USG DNS resolution and bandwidth throughput issues

I am having DNS resolution and bandwidth issues. I'm not sure if the two are related, or if it is just a coincidence they occurred out of nowhere together.
 
Until a few days ago, my home and home office networks were running smoothly.  Then 2 things happened on the same day.
  1. My internet provider (Spectrum) added TV service
  2. I was configuring an EdgeRouter-X to use in conjunction with a virtualization lab.  At one point I had the ERX eth0 plugged into my US-16-150W switch.
  3. [Bonus] I was also testing RADIUS and VPN a few weeks ago.
From a high-level, here is how I am configured:
            Cable Modem
                   || eth0
                USG   (4.4.29.5124210)
      eth1 /          \ eth2
            /              \
US-16-150W        NETGEAR switch
Home, DHCP       Lab, Static IP's
192.168.0.0/24    192.168.2.0/24
 
My 'Lab' network is just that. I use it for software development and virtualization tests. An Active Directory forest with DNS and DHCP are here.
 
With my desktop is plugged directly into the cable modem, I get 450Mbps down and 20Mbps up.
 
But after the two events listed above occurred, I am experiencing the following behavior:
  1. Windows machines on both networks have the yellow warning icon on the network in the system tray. But DNS seems to breifly go away on occasion. The warning icon will sometimes, breifly dissappear. When it is in a good state I'm getting the full 450Mbps down, 20Mbps up.
  2. Apple devices (iPad, iPad mini, iPhone 6 and iPhone 7) seem to be uneffected by the DNS issue.
  3. The fastest I can get on the 'Lab' network is 10Mpbs down. Upload speed is still the same at 20Mbps.
     
Troubleshooting steps:
  1. I have tried setting the Settings > Networks > 'DHCP Name Server' to Manual with 192.168.0.1 and 8.8.8.8
  2. Unplugged modem and USG for a period of several minutes.
  3. I have not done any customizations through config.gateway.json.
  4. Ensured IPS and DPI are both DISABLED.
  5. Ensured Hardware Offload is ENABLED.

What else should I try?

Regular Member
Posts: 387
Registered: ‎09-28-2017
Kudos: 99
Solutions: 29

Re: USG DNS resolution and bandwidth throughput issues

[ Edited ]

Make sure the "Gateway/Subnet" setting is 192.168.0.1/24 and 192.168.2.1/24 not 192.168.0.0/24 and 192.168.2.0/24

 

New Member
Posts: 14
Registered: ‎05-22-2015

Re: USG DNS resolution and bandwidth throughput issues

@nc2kft- Yes, I've got them set the way you said.

 

More info:

The Apple devices now seem to have trouble resolving DNS.  (CNN, FoxNews, Amazon, etc)

 

I also discovered that running a tracert from my Home subnet to the Lab subnet is inconsistent. On some machines it works, but works on others.

 

On the broken machines, I can't tracert to the Lab gateway, the USG eth0 ip address, or to 8.8.8.8. All I get are "Request timed out." messages.

 

 

Reply