Reply
Emerging Member
Posts: 70
Registered: ‎12-20-2016
Kudos: 7
Solutions: 3

Re: [USG] Firmware v4.4.29 now available

Running 4.4.29 on my USG 3P for a week now no issues:

Controller: 5.8.30 on remote cloudkey.

only a small json file, routing one VLAN down the S2S VPN and out at the other end.

{
  "firewall": {
    "modify": {
      "Riga-Rose-Lane": {
        "rule": {
          "20": {
            "action": "modify",
            "description": "Route Rose Lane to vti0",
            "modify": {
              "table": "20"
            },
            "source": {
              "address": "192.168.20.0/24"
            }
          }
        }
      }
    },
    "source-validation": "disable"
  },
  "interfaces": {
    "ethernet": {
      "eth1": {
        "vif": {
          "20": {
            "firewall": {
              "in": {
                "modify": "Riga-Rose-Lane"
              }
            }
          }
        }
      }
    }
  },
  "protocols": {
    "static": {
      "table": {
        "20": {
          "interface-route": {
            "0.0.0.0/0": {
              "next-hop-interface": {
                "vti0": "''"
              }
            }
          }
        }
      }
    }
  }

Not upgraded the other end as it is a USG Pro4 and there appears to be issues.  It will have to wait until I am at the site incase of problems.

 

New Member
Posts: 7
Registered: ‎04-08-2018

Re: [USG] Firmware v4.4.29 now available

2 days up and running. controller 5.8.30 and 4.4.29 upgrade went well and none of my vpn tunnels died remote access vpn is working now better, earlier it had some odd lag spikes so far none. All special jsons are also working good.

 

Will report if i run into any problems.

 

Emerging Member
Posts: 80
Registered: ‎04-16-2016
Kudos: 11

Re: [USG] Firmware v4.4.29 now available

Hi,

 

I had some hope and the upgrade was looking quite promising, but suddenly something failed yesterday evening.

 I was shuffling this firmware between 4.4.18, 4.4.22, 4.4.28 across couple of days, and I would say, it runs quite stable, with WAN failover, quite low CPU, memory consumption.

Due to evening yesterday, I was trying to run something on WiFi on my phone and the network just crashed. 

With bad feelings, I went to the controller, and I was not able to do anything, even login.

 I went for 4G, then probably, by some luck and maybe “lucky remote access window “, I was able to logon remotely to my Cloudkey, then downgraded to 4.4.22 and everything just works again: no more pppoe WAN switchovers etc.

Because, I have to leave the site for a while, I will ever never touch any remote upgrade until I am absolutely sure, I shortly coming back on a plane to my location...

4.4.22 sounds like the latest stable alternative for those days...

New Member
Posts: 1
Registered: ‎09-18-2018

Re: [USG] Firmware v4.4.29 now available

[ Edited ]

Hello,

 

Thanks UBNT for all you do.

 

Been running Ubiquiti appliances for about a year now, love them. Manage Cisco, Juniper, pfSense and Linux based appliances professionally at my day job - at home and for friends, I typically deploy a combination of Ubiquiti and pfSense.

 

That being said, on my USG I've noodled for a few days, numerous resets, upgrades, redo, resets, etc -  but have had to roll back to 4.4.22 for any sort of stable consistency at this point.

 

Controller - 5.8.30

USG - 4.4.22

UAP-AC-Pro - 3.9.42

Emerging Member
Posts: 78
Registered: ‎09-01-2016
Kudos: 5

Re: [USG] Firmware v4.4.29 now available

all 4 sites been up and running for about a week now, no crashes, no wan drops, nothing crazy with cpu and ram.  Looks good.  

Emerging Member
Posts: 82
Registered: ‎04-14-2018
Kudos: 17
Solutions: 1

Re: [USG] Firmware v4.4.29 now available

[ Edited ]

Updated my USG to  4.4.29 a few days ago. After 36 hours i got a heartbeat missed (Still had internet connection) and had to reboot the USG and my core switch to bring everything back.

 

Rebooted and have now been running for 48 hours without issues. 

 

BTW it seems that the UniFi Android App have been updated to show correct DPI stats. 

 

Running Controller 5.8.30 on CloudKey 0.11.12

 

Regards, 

 

Edit: Spelling and added controller and CK version

Michael Lund Milo

USG 3P - USW-8-60W - USW-8-150W - 2 x UAP-AC-Pro - Cloud Key
New Member
Posts: 14
Registered: ‎07-16-2018
Kudos: 6
Solutions: 1

Re: [USG] Firmware v4.4.29 now available

[ Edited ]

Same as @LundMilo, heartbeat missed - and at the time, I didn't have enough time to really troubleshoot - never actually lost connectivity (could still connect to the internet) - also, logging into the USG real quick - I saw some "alien packets" in the logs, and the "info" command spit out what I expected (correct inform host, no error reported).  As it was mission critical that day, downgraded back to .22 and everything is running fine.

 

Had an issue with .28 as well - but that included a mountain of decrypt errors in the logs

 

Controller is 5.8.30, CK 0.11.12

 

Device is USG3

 

Edit: IDS & IPS Off, DPI on w/o restrictions, speedtest enabled.

 

I can probably give it another shot, but not before closer to the end of the week so I don't upset the folks trying to actually work at this site Man Happy

 

 

New Member
Posts: 36
Registered: ‎08-30-2013
Kudos: 4
Solutions: 3

Re: [USG] Firmware v4.4.29 now available

Any idea on when the USG pro will support configuring multi public ip adresses from the GUI - Ive just got the USG pro to try and its a bit of a pain only able to assign one ip ! I see people have been requesting this for some time!

New Member
Posts: 16
Registered: ‎05-13-2018
Kudos: 4

Re: [USG] Firmware v4.4.29 now available

Upgraded from 4.4.22 usg is connected to a draytek 130 vdsl model. This firmware keeps disconnected the network and dashboard shows all red dials. Only way to get the network back up is by doing a hard reboot. Unstable build. Have to downgrade to 4.4.22.

New Member
Posts: 1
Registered: ‎07-22-2016
Kudos: 3

Re: [USG] Firmware v4.4.29 now available

My USG has also been unstable on 4.4.29 and had to revert back to 4.4.22.  Any idea when this will be fixed?

New Member
Posts: 1
Registered: ‎10-02-2018
Kudos: 1

Re: [USG] Firmware v4.4.29 now available

Same here... Frequent Gateway WAN disconnects. 3-5 times a day. Gateway is pingable but can't get to the web ui.

New Member
Posts: 12
Registered: ‎07-19-2017
Kudos: 1

Re: [USG] Firmware v4.4.29 now available

I manage 6 sites with cloud key, USG-PRO-4, all Ubiquity switches and all Ubiquity indoor and some external APs. This upgrade took all of the ones set with scheduled updates, or that were otherwise updated offline. The cause was many of the same symptoms described earlier. We had to dispatch people to all of them at great expense to us and even greater embarassment. In some cases they had to go back several times since the devices failed early attempts to upgrade and they remainded unstable util updated. 

 

With the exception of one site where I don't have easy access all are all now updated and 2 of those are unreasonably unstable.

 

The number of notifications I get about switches and APs disconnecting or being readopted is unsettling. At the worst one, which is a non profit animal shelter trying to monitor sick or pregnant animals over this network, I often cannot reach it online. For days their security gateway was stuck in adopting, disconnected, adopting. That seemed to stop after a cold restart, but it still drops remote connectivity to the portal. Oddly when they were disconnected I have often still been able to use ZoHo to remote terminal access devices on the LAN side. 

 

I have carefully checked that everything at all sites are running the latest version. This package of firmware upgrades is terrible. 

New Member
Posts: 25
Registered: ‎02-24-2018
Kudos: 11
Solutions: 1

Re: [USG] Firmware v4.4.29 now available

Good day everyone.

 

I also getting Heartbeat Missed on 4.4.29

 

Screen Shot 2018-10-03 at 14.31.56.png

 

I never get this message on USG before the update (couldn't remember the last version prior to update). This is what I change to the system: 

1. Install a new US-16-150W to replaced all other brand poe and non-poe switch

2. Upgraded to the latest firmware for cloud key, controller, switch and ap

All was working fine for 2-3 days then yesterday it start getting the Heartbeat Missed message on USG. During that time connection to internet still working but statistics stop logging for USG. Today it missed 3 times already and the longest one last more than 1 hour.

 

Any idea what might cause this and how to resolve it?

 

Thanks

New Member
Posts: 20
Registered: ‎11-16-2017
Kudos: 4

Re: [USG] Firmware v4.4.29 now available

@UBNT-cmb - when could we expect a fix ?! 

The "work around" (downgrad, or disable some stuff) isn´t the greatest thing since slicedbread... Sorry i don´t won´t to sound rude, but i am really dissatisfied with the performance from Ubiquiti this time.

New Member
Posts: 4
Registered: ‎07-14-2018
Kudos: 5

Re: [USG] Firmware v4.4.29 now available

The silence given the recent track record of bad releases is troubling. 

 

What I find equally alarming is that the software is still being pushed to the general public.

 

I can't imagine they need any more data points to indicate there is a problem.

 

Is UBNT unable to pull back a release if it is deemed generally unstable?

 

I would think they would have already done this to prevent additional support load and bad vibes from people that are just now upgrading or will in the near future.

 

 

New Member
Posts: 10
Registered: ‎02-23-2018
Kudos: 1

Re: [USG] Firmware v4.4.29 now available

I agree.

 

Luckily, I use this equipment in my own house and I can tolerate the problems.  I can only imagine how businesses are affected by this unstable upgrade.

 

New Member
Posts: 25
Registered: ‎02-24-2018
Kudos: 11
Solutions: 1

Re: [USG] Firmware v4.4.29 now available

Missing heartbeat again. This time it last more than 3 hours and still no sign when its going to come back. 

 

Screen Shot 2018-10-04 at 00.02.40.png

 

It have been missing 21:01, 22:01, 23:01, 00:01 check-in, last logged statistics was 20:55. It still connected to internet. How can it missed the heartbeat while it still function properly connecting LAN to WAN?

I have disable speedtest, disable DPI, disable IPS/IDS, no VPN, no custom routing, no other services expect default settings only. Please UBNT what else do I need to disable in order for my USG to work properly? Do I need to disable the WAN and LAN ports too? Or should I disable the USG too?

 

Please anyone can tell me what is the last stable firmware for USG that I can safely downgrade to while waiting UBNT to fix this issue?

Emerging Member
Posts: 80
Registered: ‎04-19-2016
Kudos: 15
Solutions: 2

Re: [USG] Firmware v4.4.29 now available

4.4.22 is the most stable, though I had no problems with 4.4.28 which I had to roll back to after 4.29 made a mess up of my PPPoe connection... annoyingly the frequent disconnects were enough for the DSLAM to lower my connection speeds! That said I’ve had 4.4.28 up for 5 days without fault
New Member
Posts: 9
Registered: ‎03-09-2018
Kudos: 1

Re: [USG] Firmware v4.4.29 now available

.29 has been working for me.
.28 was a disaster for me, many of the same problems others mentioned. I downgraded back to .22 eventually.
.22 worked well for me, and it seems to be what others have been downgrading to.
New Member
Posts: 16
Registered: ‎05-13-2018
Kudos: 4

Re: [USG] Firmware v4.4.29 now available

I have found 4.4.22 to be the most stable version I have found. 

Reply