Reply
Emerging Member
Posts: 55
Registered: ‎04-18-2016
Kudos: 49

Re: [USG] Firmware v4.4.29 now available

I still keep getting a missed heartbeat with no alert from the controller. I keep having to ssh into router and reboot.

I have attached a picture confirming that the router is still online and shows connected to controller.

 

I'd going to downgrade all my routers, i cant have this issue.

Do we know what version is most stable? Seems i see alot of mention of 4.4.22.

 

 

sbat-hearbeat-missed.JPG
New Member
Posts: 24
Registered: ‎11-16-2017
Kudos: 4

Re: [USG] Firmware v4.4.29 now available


@FaustoCruz wrote:

I still keep getting a missed heartbeat with no alert from the controller. I keep having to ssh into router and reboot.

I have attached a picture confirming that the router is still online and shows connected to controller.

 

I'd going to downgrade all my routers, i cant have this issue.

Do we know what version is most stable? Seems i see alot of mention of 4.4.22.

 

 


I was (and now I am again) running on 4.4.22 since the bebeginning without a proplem.

 

Will stick to it until thert is a security issue!

New Member
Posts: 5
Registered: ‎01-19-2018

Re: [USG] Firmware v4.4.29 now available

I upgraded my USG to 4.4.29 two days ago.  Today, I am having an issue where the USG seems to "Lock up".  The blue light is on, but i receive an alert that the USG is disconnected.  I am uanble to manage the device through the controller or ssh.

 

The device responds to ping, and the internet works until I try to obtain a new lease, so it is still routing but other functions are not working.  I notice that the device is pretty warm to the touch.  In the statistics graph, the CPU load spikes to 84% right before the disconnect.  

 

This has happened multipe times now.

 

How can I get more info to try to find out what is causing the issue?

 

USG Firmware:  4.4.29.5124210

Unifi AP/Switch version:  3.9.54.9373

Controller:  5.8.30 (Build: atag_5.8.30_11076)

Cloud Key firmware:  11.12

New Member
Posts: 24
Registered: ‎11-16-2017
Kudos: 4

Re: [USG] Firmware v4.4.29 now available


@mthumphrey wrote:

I upgraded my USG to 4.4.29 two days ago.  Today, I am having an issue where the USG seems to "Lock up".  The blue light is on, but i receive an alert that the USG is disconnected.  I am uanble to manage the device through the controller or ssh.

 

The device responds to ping, and the internet works until I try to obtain a new lease, so it is still routing but other functions are not working.  I notice that the device is pretty warm to the touch.  In the statistics graph, the CPU load spikes to 84% right before the disconnect.  

 

This has happened multipe times now.

 

How can I get more info to try to find out what is causing the issue?

 

USG Firmware:  4.4.29.5124210

Unifi AP/Switch version:  3.9.54.9373

Controller:  5.8.30 (Build: atag_5.8.30_11076)

Cloud Key firmware:  11.12



It seems (in my opinon) that this issue is caused by a bug in the firmeware.

 

The support offerd me and some other users, as written a view pages before, the following:

1. Disable dpi/ips/speedtest in controller

2. Hard reboot USG

3. Wait for adoption

4. Reenable dpi/ips/speedtest

 

In my case i dind´t help at all. I ended up (after hours on the machine) to revoke to the last stable firmeware. So if you have not had any troubles with the last firmeware, just roll back and wait till they finaly will fix it.

New Member
Posts: 25
Registered: ‎02-24-2018
Kudos: 11
Solutions: 1

Re: [USG] Firmware v4.4.29 now available

 

Still on 4.4.29.

Last night after my last post I did this:

1. Pull the power cord from USG, replug after 15 seconds (not sure needed to wait or no but that is what I did).

2. Wait for it to finish provisioning.

3. Re-enable speedtest, DPI, IPS.

 

The result:

1. No Heartbeat missed. Hurray

2. Lower memory usage. Before reboot it was 62-70%, after reboot and have been running with the same load for 20+ hours the memory usage is around 36-42% now. Hurray

 

I hope this state will hold.

New Member
Posts: 12
Registered: ‎03-09-2018
Kudos: 1

Re: [USG] Firmware v4.4.29 now available

I've been on .29 for a while already with no issues. No missed heartbeats and running DPI, Speedtest, and IPS, memory usage is around 45% on a USG-3P.

Maybe I will reboot it to see what happens regarding the memory usage.
Established Member
Posts: 1,570
Registered: ‎11-12-2015
Kudos: 433
Solutions: 45

Re: [USG] Firmware v4.4.29 now available

I'm still on 4.4.18. I know it was troublesome to a number of people, but it has been fine for me. I'm awaiting a version that sounds stable in real life before I move up.

 

New Member
Posts: 12
Registered: ‎03-09-2018
Kudos: 1

Re: [USG] Firmware v4.4.29 now available

.18 was bad for me, so I went back to .12 I think it was. I then skipped .18 and went to .22 and that seems to be working well for quite a few forum members... 

New Member
Posts: 12
Registered: ‎07-19-2017
Kudos: 1

Re: [USG] Firmware v4.4.29 now available

[ Edited ]

I downgraded 3 sites to 4.22 and the nearly constant alerts completely stopped. My frequent problems of not being able to launch a connection from the Internet portal plus switches and APs getting isolated or dropped went away.

New Member
Posts: 25
Registered: ‎02-24-2018
Kudos: 11
Solutions: 1

Re: [USG] Firmware v4.4.29 now available


@menk wrote:

 

Still on 4.4.29.

Last night after my last post I did this:

1. Pull the power cord from USG, replug after 15 seconds (not sure needed to wait or no but that is what I did).

2. Wait for it to finish provisioning.

3. Re-enable speedtest, DPI, IPS.

 

The result:

1. No Heartbeat missed. Hurray

2. Lower memory usage. Before reboot it was 62-70%, after reboot and have been running with the same load for 20+ hours the memory usage is around 36-42% now. Hurray

 

I hope this state will hold.


Too early celebration. Just had another 2 heartbeat missed. I rolled back to 4.4.22 last night hopefully with this one it will be stable. Now memory usage is at 32 - 40% with speedtest/dpi/ips enabled. 

Member
Posts: 139
Registered: ‎12-02-2017
Kudos: 96
Solutions: 1

Re: [USG] Firmware v4.4.29 now available

 

@menkwhat were your speedtest results with .29 and .22? 

New Member
Posts: 25
Registered: ‎02-24-2018
Kudos: 11
Solutions: 1

Re: [USG] Firmware v4.4.29 now available

@spacemonkey2

Same on both. Nothing strange. But of course I have just been running .22 for like 9+ hours so couldn't really say much but so far so good and no heartbeat missed too. FYI my speed is only 32 Mbps so couldn't say the same for those with more than 100 Mbps speed. 

 

Do you experiencing any speed drop with one of them?

Member
Posts: 139
Registered: ‎12-02-2017
Kudos: 96
Solutions: 1

Re: [USG] Firmware v4.4.29 now available

 

I am still running 4.4.12 and I have 293 days of uptime.  I do have a 100Mb/s+ connection, so running IDS, but not IPS.  I'm watching the updates, but it seems there are stability issues, so sticking with 4.4.12

New Member
Posts: 25
Registered: ‎02-24-2018
Kudos: 11
Solutions: 1

Re: [USG] Firmware v4.4.29 now available

I am new to this UBNT platform and I was so excited whenever I see a new updates but I have wasted many hours troubleshooting because of one simple firmware upgrade. So... Lesson learned!

I would stick to the one that has been running fine and wait for a really proven version before upgrading. Not worth the hassles to upgrade if you don't really need the new features/fixes that came with the new firmware unless you have time to be the bravest to test the new updates. I will test mine a few more days then I'll update here if its stable or not.

Ubiquiti Employee
Posts: 4,989
Registered: ‎08-08-2016
Kudos: 5367
Solutions: 344

Re: [USG] Firmware v4.4.29 now available

[ Edited ]

Those seeing issues with IDS/IPS, help verifying whether we've fixed the issue there would be much appreciated. 4.4.31dev posted here. Opt into beta at account.ubnt.com if you haven't already to access. 

https://community.ubnt.com/t5/UniFi-Routing-Switching-Beta/USG-Firmware-v4-4-31dev-available-for-tes...

 

 

New Member
Posts: 2
Registered: ‎12-30-2017
Kudos: 1

Re: [USG] Firmware v4.4.29 now available

I disabled IDS and hard booted my USG-3P running 4.4.29. 

Have had no issues after this, uptime 5 days, 2 hours

 

I'm not running speed tests, DPI is enabled, IPS not enabled

Controller running on a VM, version 5.8.30

New Member
Posts: 6
Registered: ‎08-10-2017

Re: [USG] Firmware v4.4.29 now available

Updated controller and CK to latest stable release which is now 5.9.29 and 0.12.0 in hopes that the USG would now been seen as Online again running 4.4.29. Unfortunately not. Still says Disconnected. However everything works just fine and in details "Last seen" it says "a couple of seconds ago". Even though it is Disconnected from Controller.

 

IDS and IPS disabled. Speedtest disabled.

DPI enabled. Radius and VPN enabled and works as expected.

New Member
Posts: 8
Registered: ‎05-25-2018

Re: [USG] Firmware v4.4.29 now available

How can we access the dev firmware?

New Member
Posts: 24
Registered: ‎11-16-2017
Kudos: 4

Re: [USG] Firmware v4.4.29 now available


@gator911 wrote:

How can we access the dev firmware?


Just click the link above (  https://community.ubnt.com/t5/UniFi-Routing-Switching-Beta/USG-Firmware-v4-4-31dev-available-for-tes... ) and that's it.

New Member
Posts: 8
Registered: ‎05-25-2018

Re: [USG] Firmware v4.4.29 now available

[ Edited ]

unifierror.PNGnot so easy for me I guess, you would think if Ubiquity messed up the firmware so bad, they would at least give us an accessible link to try the fix.  This has been an unbeleivable nightmare for me.  Even purchased a second USG because the problem persisted.

Reply