Reply
Emerging Member
Posts: 96
Registered: ‎10-09-2017
Kudos: 10

Re: [USG] Firmware v4.4.34 now available

Thank you sir.

Worked like a charm.

I just couldn't construct the URL for the access (didn't want to mess it up) so I was relieved to have it confirmed by you. Many thanks. The USG is working..
Emerging Member
Posts: 96
Registered: ‎10-09-2017
Kudos: 10

Re: [USG] Firmware v4.4.34 now available

At first glance I see the new "downgrade" button available in the controller. I think that is really cool. I assume that it will stay there till next version or will that "fade" away? I havent tried it out to see if it directs to the previous lower version or gives you a choice to pick one. Anyone tried it as yet and what was the result?

Member
Posts: 105
Registered: ‎09-17-2014
Kudos: 42
Solutions: 4

Re: [USG] Firmware v4.4.34 now available

Since the "Current" version the controller is aware of is 4.4.29, the Downgrade should go back to that version. Once the 4.4.34 version is pushed to the repositories, then the Downgrade button should go away.

Emerging Member
Posts: 96
Registered: ‎10-09-2017
Kudos: 10

Re: [USG] Firmware v4.4.34 now available

[ Edited ]

Thank you! Got it!

 

Though it is annoying to see that banner saying there is firmware update available for some devices. Though technically it would be a downgrade! Always something or the other Smiley Mad Just cavilling because I can! 

New Member
Posts: 14
Registered: ‎01-28-2016

Re: [USG] Firmware v4.4.34 now available

Are there any changes between this and the beta version?

New Member
Posts: 14
Registered: ‎06-16-2017

Re: [USG] Firmware v4.4.34 now available

upgraded this morning from 4.4.22 to 4.4.34... looks OK (lets see for how long)...

New Member
Posts: 13
Registered: ‎05-31-2017
Kudos: 9

Re: [USG] Firmware v4.4.34 now available


@lordvader wrote:

Are there any changes between this and the beta version?


Same build version .5140612.

Regular Member
Posts: 537
Registered: ‎04-01-2014
Kudos: 108
Solutions: 7

Re: [USG] Firmware v4.4.34 now available

Will this 4.4.34 be pushed to controller 5.9.x? @UBNT-cmb


UniFi solutions for everyone!
Ubiquiti Employee
Posts: 4,978
Registered: ‎08-08-2016
Kudos: 5334
Solutions: 344

Re: [USG] Firmware v4.4.34 now available


@sebehk wrote:

I’m not seeing the firmware update in the UniFi SDN Controller for my USG-3P. I refreshed several times under the Devices section and clicked on the button “Check Firmware Updates” in the Settings > Maintenance > Device Firmware Update.

 

Just curious...Is there a waiting period for an update to show up in the Controller? I do know about the Configuration tab > Manage Device > Custom Upgrade method.


There is always a delay between posting and it appearing in the controller. More so this time than usual, but it'll show up later today (plus up to 24 hours unless you do the manual firmware check). When things are first posted, you can use the custom upgrade. 

New Member
Posts: 3
Registered: ‎04-25-2018

Re: [USG] Firmware v4.4.34 now available

Upgraded (successfully) to v4.4.34 as I wanted to see if the randon 100% CPU spikes would be fixed, but sadly not.

 

I get random 100% CPU spikes which sometimes disconnect the USG and sometimes appear to cause a Missed Heartbeat. It seems to reconnect OK. 

 

Obviously would like to understand the spikes but have not been able to ssh during a "CPU spike episode" to do a TOP to see what processes are hogging the CPU. The memory usage apparently is affected. From the AP stats there is no indication of any abnormal traffic.

 

Anyone have any ideas or could advise how to capture CPU Process log when such a spike happens?

 

Thanks

 

USG / 3 Unifi AP's / Vigor 130 / D-Link 24 port switch / approx 30 clients

New Member
Posts: 3
Registered: ‎04-25-2018

Re: [USG] Firmware v4.4.34 now available

Correction to the above - the memory usage is apparently NOT affected during the 100% CPU spikes.

 

Apols

Ubiquiti Employee
Posts: 4,978
Registered: ‎08-08-2016
Kudos: 5334
Solutions: 344

Re: [USG] Firmware v4.4.34 now available


@lordvader wrote:

Are there any changes between this and the beta version?


No, just the version string. 

Ubiquiti Employee
Posts: 4,978
Registered: ‎08-08-2016
Kudos: 5334
Solutions: 344

Re: [USG] Firmware v4.4.34 now available


@edwarj3 wrote:

Upgraded (successfully) to v4.4.34 as I wanted to see if the randon 100% CPU spikes would be fixed, but sadly not.

 

I get random 100% CPU spikes which sometimes disconnect the USG and sometimes appear to cause a Missed Heartbeat. It seems to reconnect OK. 

 

Obviously would like to understand the spikes but have not been able to ssh during a "CPU spike episode" to do a TOP to see what processes are hogging the CPU. The memory usage apparently is affected. From the AP stats there is no indication of any abnormal traffic.

 

Anyone have any ideas or could advise how to capture CPU Process log when such a spike happens?

 

Thanks

 

USG / 3 Unifi AP's / Vigor 130 / D-Link 24 port switch / approx 30 clients


Running top when it happens is the best bet. You don't have to log in at the time necessarily, can keep it up and running . Though if it's brief that may be hard to catch. The usual culprits are speed test running, or a period of increased throughput with IDS/IPS enabled. 

New Member
Posts: 3
Registered: ‎04-25-2018

Re: [USG] Firmware v4.4.34 now available

[ Edited ]

Thanks - IDS/IPS is disabled and Speedtest is not running - however just to check I turned Speedtest on - reprovisioned, then turned it off and re-provisioned

 

The thing is, looking in the controller log I still get this :

 

2018-12-05 14:55:43,340] <inform_stat-9> DEBUG ugw - ugw[---Mac Addr of ugw---] speedtest - ping/down/up/summary: 2/2/2/2

 

Does this mean the speedtest is still running??

 

Thanks

New Member
Posts: 13
Registered: ‎08-23-2018
Kudos: 1

Re: [USG] Firmware v4.4.34 now available

I have this Firmware now running since Beta on my USG 3P but today, after around 1 week i have to reset the USG because no DNS Traffic is really passing the USG or only known DNS.

 

I tried using Default DNS from ISP oder OpenDNS, still the same, never had this behavor before.  I'm downgrading now to 4.4.29.

Member
Posts: 312
Registered: ‎05-26-2016
Kudos: 65
Solutions: 3

Re: [USG] Firmware v4.4.34 now available

@AndiSchrogl

 

Worth try setting DNS to Googles?

New Member
Posts: 13
Registered: ‎08-23-2018
Kudos: 1

Re: [USG] Firmware v4.4.34 now available

[ Edited ]

@Groong wrote:

@AndiSchrogl

 

Worth try setting DNS to Googles?


I run one week with google DNS then changed to ISP and after that to openDNS, no it's not the DNS Provider and not my Modem.

 

Everytime after rebooting the device. the connection came back and everything works fine until the next "crash".  As it seems it's DNS but not sure, all is slow, half of a website is not working correct, it simply not loading which worked just a minute before. (DNS Cache at localhost)

 

Ping external IP adresse ipv4 and ipv6 is also working.

 

Running a online game at the same time while the connection problems occure is no problem at all and it's still working.  So not the Line it self is down or a routing problem, so my suggestion is - something is wrong with the DNS System.

 

 

Emerging Member
Posts: 68
Registered: ‎04-09-2016
Kudos: 14
Solutions: 3

Re: [USG] Firmware v4.4.34 now available

[ Edited ]

The load balancing feature bug I encountered before in this version seem to have been fixed. However, it seems like a new one has been introduced.

 

When WAN1 fails over to WAN2 and WAN1 comes back up, the route forwarding table showed the default route to WAN1 and the load-balance status shows WAN1 as active, but, traffic is to the Internet is being forwarded over WAN2 by the USG. This is worse behavior than the previous release and I would not recommend upgrading to this version if you have a primary/failover multi-wan configuration. @UBNT-cmb, I would be happy to provide logs/details privately if it would help.

New Member
Posts: 14
Registered: ‎04-09-2016

Re: [USG] Firmware v4.4.34 now available

4.4.34 Portforwarding with Dualwan not working...downgrade to 29 and all is ok!

New Member
Posts: 12
Registered: ‎02-06-2017

Re: [USG] Firmware v4.4.34 now available

HelloEveryone,

 

Im just wondering why after the upgrade why is my cloudkey telling me to downgrade my USG Pro 4 is there a new update to fix this on the cloud key??

 

Reply