Reply
New Member
Posts: 2
Registered: ‎04-15-2016
Kudos: 2

Re: USG-Pro-4 Restarting every 2 days

There is an issue with some devices memory modules. Just open a ticket. I submitted a ticket and got transferred to Tier 3 almost immediately. I had a new one shipped to me and I shipped the old one back once I got the new one. It has been working fine for a few weeks now. No reboots.

New Member
Posts: 1
Registered: ‎03-22-2018

Re: USG-Pro-4 Restarting every 2 days


@dmb41wrote:

There is an issue with some devices memory modules. Just open a ticket. I submitted a ticket and got transferred to Tier 3 almost immediately. I had a new one shipped to me and I shipped the old one back once I got the new one. It has been working fine for a few weeks now. No reboots.


Did you get sent out a new USG unit or memory module? I've logged mine and just been informed the USGs are on backorder.

Regular Member
Posts: 478
Registered: ‎06-26-2016
Kudos: 143
Solutions: 16

Re: USG-Pro-4 Restarting every 2 days

I was provided a new USG.
New Member
Posts: 2
Registered: ‎04-15-2016
Kudos: 2

Re: USG-Pro-4 Restarting every 2 days

I was provided a new USG

New Member
Posts: 4
Registered: ‎02-19-2018
Kudos: 2

Re: USG-Pro-4 Restarting every 2 days

got my usg pro 4 in februar 2018

was produced in 50/2017 

 

had a lot of reboot's, and other troubles. 

replacing the ram to the 4g kingston an seem's to work fine. 

 

if i'm sure, the problem is solved, i will post here my syslog, just fur the unifi-team. maybe it will will help. 

Emerging Member
Posts: 96
Registered: ‎11-24-2017
Kudos: 27
Solutions: 3

Re: USG-Pro-4 Restarting every 2 days

[ Edited ]

Was the 4GB SO DIMM made in Taiwan or China? The chinese Kingston SO DIMM I purchased did not work at all KVR16S11S8/4. As in, no boot. The console output below is where it stops.

 

U-Boot 2012.04.01 (UBNT Build ID: 4785663-gaff5016) (Build time: Jun 30 2015 - 14:17:11)

Skipping PCIe port 0 BIST, in EP mode, can't tell if clocked.
Skipping PCIe port 1 BIST, reset not done. (port not configured)
BIST check passed.
UBNT_E220 r1:1, r2:14, serial #: FCECDA0387F1
MPR 13-02102-14
Core clock: 1000 MHz, IO clock: 600 MHz, DDR clock: 533 MHz (1066 Mhz DDR)
Base DRAM address used by u-boot: 0x10f800000, size: 0x800000
DRAM: 4 GiB
New Member
Posts: 1
Registered: ‎03-13-2016

Re: USG-Pro-4 Restarting every 2 days

[ Edited ]

@UBNT-DavidS - If you want, my Pro-4 is rebooting consistently every 2 hours when I have the periodic speed test enabled, I have gathered syslog and core dumps for the unit for the failures.

 

Also, it should be noted that it's a known hardware problem per my support conversation:

 

MYLES
My USG Pro-4 (brand new) keeps restarting with kernel panic every few hours. 

Debbie H. joined the chat

DEBBIE H.
Hi, Sorry to keep you waiting. 

MYLES
Hey Debbie 
No problem 
Did you see my initial problem description? 

DEBBIE H.
Yes 
What is the firmware on the USG? 

MYLES
Latest 
4.4.18.5052172 
I've read on this rather extensive thread that it's a RAM problem: https://community.ubnt.com/t5/UniFi-Routing-Switching/USG-Pro-4-Restarting-every-2-days/td-p/1563145/page/25 

DEBBIE H.
This is a known issue, I'd suggest you file an RMA. 
To request an RMA you can contact us directly. Alternatively, you could also go to your local reseller/distributor, we especially recommend this second option for users outside of the United States. To request an RMA directly with Ubiquiti, please read our Warranty Policy ( https://www.ubnt.com/support/warranty/ ) to verify applicability, and then visit http://www.ubnt.com/support/rma to fill out the RMA request form.

If you need help identifying your device's MAC Address or Date Code, this article will help: https://help.ubnt.com/hc/en-us/articles/115006745988-Where-is-my-MAC-ID-and-Date-Code-

Once the online RMA form has been submitted, you will receive an RMA Confirmation email with your submission number. You can use this number to reference your case if you need to contact the RMA team (rma@ubnt.com) at any point. 

When filing the RMA form, use this ticket number in the Support Ticket space: xxxxx

MYLES
Can you elaborate if this is actually a HW known problem? 

DEBBIE H.
Yes, it's a known hardware problem 
We are replacing the units, once you file an RMA revert back with the RMA no to same ticket that will be created once we end this chat 

MYLES
Okay, cool, thanks for your help - I will fill out the RMA then. 
New Member
Posts: 1
Registered: ‎09-14-2016

Re: USG-Pro-4 Restarting every 2 days

[ Edited ]

Upgraded from a USG to a USG Pro and got random reboots every 1 or 2 days.

 

Replaced the memory with a Kingston 4GB KVR16LS11/4

Uptime: 12 days and rolling! CoolgleamA

New Member
Posts: 28
Registered: ‎07-04-2017
Solutions: 1

Re: USG-Pro-4 Restarting every 2 days

I am having the same issue with my USG Pro rebooting about every 2 days. I have been hearing that is is possilbly bad memory. Can you tell me the exact make/kind of memory you replaced yours with? I have received an RMA from Ubiquiti to send the until back but if I can just replace the memory and it fixes is I would rather do that. 

 

Any help would be greatly appreciated! 

 

Thank you

New Member
Posts: 5
Registered: ‎08-07-2017

Re: USG-Pro-4 Restarting every 2 days

I have two USGP4 that are rebooting, Both have an active RMAs and I've been waiting for a repalcement device to be shipped since 4/13.  I've contacted support and RMA with no ETA on reaplcement devices or memory.  Whiel the support staff is polite telling me to wait is not an acceptable answer.  

 


Ubiquiti I need the replacement devices shipped ASAP.

Emerging Member
Posts: 97
Registered: ‎07-22-2017
Kudos: 37
Solutions: 6

Re: USG-Pro-4 Restarting every 2 days

[ Edited ]

Just to make your life less miserable, you could purchase a few Kingston 4GB KVR16LS11/4 and use while you wait, they are almost cheaper than freight for shipping the units back and forth.

New Member
Posts: 5
Registered: ‎08-07-2017

Re: USG-Pro-4 Restarting every 2 days

Thanks UlrikLunddahl.  So your saying there is a known work around?  Great!

 

 

Ubiquiti - Ship out Kingston a couple 4GB KVR16LS11/4 and I'll replace the RAM locally.  

Ubiquiti Employee
Posts: 782
Registered: ‎02-28-2017
Kudos: 231
Solutions: 79

Re: USG-Pro-4 Restarting every 2 days

@johnmenefee Sending you a PM.

Brandon Jaffe | UniFi Routing & Switching | Austin, TX
New Member
Posts: 1
Registered: ‎07-25-2017

Re: USG-Pro-4 Restarting every 2 days

Hei,

 

I have the same problems... today it (re)booted 2 times already, quite annoying.

However, I would replace the memory myself but I also like warranty a lot. Man Happy I bought my unit in January.

 

Should I open a ticket?

 

Best regards from Germany,

Niels

New Member
Posts: 5
Registered: ‎08-07-2017

Re: USG-Pro-4 Restarting every 2 days

I would get a support ticket open first.  If there is a RMA from the support ticket then the unit will be replaced when the backlog of units is available.  

 

Thanks,

John

New Member
Posts: 5
Registered: ‎08-07-2017

Re: USG-Pro-4 Restarting every 2 days

And another reboot, 4 today so far.

Emerging Member
Posts: 96
Registered: ‎11-24-2017
Kudos: 27
Solutions: 3

Re: USG-Pro-4 Restarting every 2 days

I keep the little USG as a backup. It actually performs perfectly while waiting for the RMA

Regular Member
Posts: 379
Registered: ‎10-21-2014
Kudos: 93
Solutions: 13

Re: USG-Pro-4 Restarting every 2 days

Hi

Now that the thread came alive I shall note that I rplaced myUSG-4 SODimm and hatd i running smoothly for nearly a year with this module https://www.aliexpress.com/item/Hynix-DDR3-4GB-8GB-Memoria-Ram-ddr3-1600-PC3-12800-laptop-computer-c... module)

Frank

New Member
Posts: 22
Registered: ‎11-08-2016
Kudos: 1

Re: USG-Pro-4 Restarting every 2 days

I guess we just keep posting these. Frustrated...

 

Unhandled kernel unaligned access[#1]:
CPU: 0 PID: 3434 Comm: mcad Tainted: P O 3.10.20-UBNT #1
task: 80000000895f4be0 ti: 800000008964c000 task.ti: 800000008964c000
$ 0 : 0000000000000000 0000000010109ce1 0000000000000000 ffffffffc04b3380
$ 4 : ffffffffc0080a20 ffffffffffff8100 8042000002af8038 0000000000000001
$ 8 : 0000000010109ce2 0000000000000000 0000000000000010 00000000ffffff01
$12 : 0000000000800010 0000000000000010 0000000000000000 0000000000000000
$16 : 8042000002af8028 800000008964f670 ffffffffdd100008 ffffffffc011d0fc
$20 : fffe000000000000 ffffffffc05df808 0000000000000037 0000000000000048
$24 : ffffffffdd100008 0000000000000000
$28 : 800000008964c000 800000008964f610 0000000000000288 8042000002af8030
Hi : 0000000000000005
Lo : 0000000000000000
epc : ffffffffc0080a38 do_ade+0x778/0xe10
Tainted: P O
ra : 8042000002af8030 0x8042000002af8030
Status: 10109ce2 KX SX UX KERNEL EXL
Cause : 00800010
BadVA : 8042000002af8028
PrId : 000d9301 (Cavium Octeon II)
Modules linked in: ip_set_hash_ipportip ip_set_hash_ip xfrm_user xfrm4_tunnel tunnel4 ipcomp xfrm_ipcomp esp4 ah4 l2tp_ppp l2tp_netlink l2tp_core xt_nat pppoe pppox ppp_generic slhc 8021q garp stp llc ipt_MASQUERADE xt_LOG xt_policy xt_set nf_conntrack_ipv6 nf_defrag_ipv6 xt_comment xt_conntrack ip_set_bitmap_port xt_TCPMSS xt_tcpudp ip6table_mangle ip6table_filter ip6table_raw ip6_tables iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 iptable_mangle xt_CT iptable_raw nf_nat_pptp nf_conntrack_pptp nf_conntrack_proto_gre nf_nat_h323 nf_conntrack_h323 nf_nat_sip nf_conntrack_sip nf_nat_proto_gre nf_nat_tftp nf_nat_ftp nf_nat nf_conntrack_tftp nf_conntrack_ftp nf_conntrack iptable_filter ip_tables x_tables ip_set_hash_net ip_set nfnetlink configfs unifigpio(PO) unifihal(PO) ipv6 imq cavium_ip_offload(PO) ubnt_nf_app(PO) tdts(PO) octeon_rng rng_core octeon_ethernet mdio_octeon of_mdio ethernet_mem octeon_common ubnt_platform(PO) libphy [last unloaded: cvm_ipsec_kame]
Process mcad (pid: 3434, threadinfo=800000008964c000, task=80000000895f4be0, tls=0000000076c88490)
Stack : 0000000000000000 0000000000000056 0000000000000000 0000000000000000
ffffffffc05df7c0 0000000000000000 0000000000000000 ffffffffffffffff
ffffffffc05df838 0000000000000200 0000000000000009 ffffffffc0078f20
0000000000000000 0000000010109ce1 0000000000000009 ffffffffc05df880
8042000002af8020 ffffffffc05df870 0000000000000010 0000000000000001
8042000002af8020 0000000000000001 ffffffffc05df880 00000000ffffff01
ffffffffc05df5e8 0000000000000001 ffffffffc05df580 0000000000000001
ffffffffc05df7c0 0000000000000000 0000000000000000 ffffffffffffffff
ffffffffc05df838 0000000000000200 0000000000000009 0000000000000048
00000000ffffff02 0000000000000240 ffffffffc0580000 ffffffffc0426138
...
Call Trace:
[<ffffffffc0080a38>] do_ade+0x778/0xe10
[<ffffffffc0078f20>] ret_from_exception+0x0/0xc
[<ffffffffc011d0fc>] __rmqueue+0x9c/0xae0
[<ffffffffc0122254>] __alloc_pages_nodemask+0x75c/0xe00
[<ffffffffc016e928>] cache_alloc_refill+0x5f8/0xa38
[<ffffffffc016e308>] kmem_cache_alloc+0xe8/0x110
[<ffffffffc02bcc64>] radix_tree_preload+0x5c/0xf8
[<ffffffffc0135788>] shmem_getpage_gfp.constprop.35+0x648/0x830
[<ffffffffc0116570>] generic_perform_write+0xb0/0x270
[<ffffffffc0117e44>] __generic_file_aio_write+0x38c/0x548
[<ffffffffc0118060>] generic_file_aio_write+0x60/0xc0
[<ffffffffc0176078>] do_sync_write+0x78/0xd8
[<ffffffffc0176f20>] vfs_write+0xb8/0x1c8
[<ffffffffc01773e4>] SyS_write+0x54/0xb8
[<ffffffffc008c4a0>] handle_sys+0x120/0x144


Code: 00d91024 1440ff40 00000000 <6a160000> 6e160007 24030000 1460ff78 00000000 0802023f
[sched_delayed] sched: RT throttling activated
---[ end trace cb3e763cf3f2ad6a ]---

*** NMI Watchdog interrupt on Core 0x01 ***
$0 0x0000000000000000 at 0x0000000010109ce1
v0 0x0000000000000001 v1 0x0000000000010000
a0 0xffffffffc05df5c8 a1 0x0000000000000000
a2 0x000000000000461f a3 0x0000000000000005
a4 0x0000000000000001 a5 0x0000000000000002
a6 0x0000000000000001 a7 0xffffffffc05df5c8
t0 0x0000000000000000 t1 0x000000000006833e
t2 0x0000000000000000 t3 0x0000000000000001
s0 0x0000000000000001 s1 0x0000000000000000
s2 0x0000000000000002 s3 0xffffffffc059a428
s4 0x0000000000000002 s5 0x0000000000000003
s6 0x0000000000000497 s7 0xffffffffc05df580
t8 0x0000000000000004 t9 0x0000000000000125
k0 0x000000007f902240 k1 0x800000008d6b3fe0
gp 0x800000008d6b0000 sp 0x800000008d6b3760
s8 0x0000000000000000 ra 0xffffffffc0122378
err_epc 0xffffffffc04a29c4 epc 0x00000000773a0558
status 0x0000000010589ce4 cause 0x0000000040808c20
sum0 0x0000000100000000 en0 0x0000000100000000
*** Chip soft reset soon ***
Jumping to start of image at address 0xbfca0000

New Member
Posts: 2
Registered: ‎02-23-2018

Re: USG-Pro-4 Restarting every 2 days

Just as an FYI...after continuing reboots - support recommendation was to upgrade to 4.4.22. Thank you to everyone here, found this forum, that spoke about the Kingston RAM being bad or having issues in the USG unit. So I took it upon myself and replaced the Kingston RAM with a new 4GB RAM chip matching the DDR3 1333 MT/s (PC3-10600) CL9 204-Pin 1.35V/1.5V SODIMM Memory and so far the unit has been running and staying up. Whether it is me or not, the unit seems to be performing better. I still have the DPI and IPS on. I will keep you up to date. I have version UGW4.v4.4.22.5086057 running on it.

Reply