Reply
New Member
Posts: 22
Registered: ‎11-21-2017
Kudos: 1

USG Slow Internet

I have seen a few threads on this and the most common answer seems to be RMA, but here goes.

 

Connect wired computer to cable modem = 400/25

Connect wired computer to USG to cable modem = 23/25

 

Tried all kinds of settings changes and nothing works. This was working perfectly fine and then I was out of town for a bout one and a half weeks and I came back to it not working.

 

So there was no configuration changes, etc between it working and not working.

 

Thoughts?

Established Member
Posts: 2,257
Registered: ‎03-20-2017
Kudos: 953
Solutions: 73

Re: USG Slow Internet

Upgrade to latest public firmware. If that does no work, try beta firmware. and if still you don't see improved results, open a chat session to support via controller.
New Member
Posts: 22
Registered: ‎11-21-2017
Kudos: 1

Re: USG Slow Internet

Already tried upgrading and downgrading to previous.

 

I will try and open the chat session.

Senior Member
Posts: 13,065
Registered: ‎08-04-2017
Kudos: 2218
Solutions: 641

Re: USG Slow Internet

Hello,

Have you tried rebooting the modem and USG?

Regards,
Glenn R.
Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation/Easy Update Scripts | UniFi-VoIP Installation Scripts
USG-4-PRO • USG
USW-48-500W • USW-24-POE-250W 2x • USW-16-POE-150W 3x • USW-24 • USW-8-150W • USW-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M
UCK-G2-PLUS • UCK-G2 • UCK
New Member
Posts: 22
Registered: ‎11-21-2017
Kudos: 1

Re: USG Slow Internet

Lol...

 

Yep I have. I even had spectrum out here to check. The bottleneck is definitely the USG.

Member
Posts: 217
Registered: ‎11-27-2017
Kudos: 80
Solutions: 16

Re: USG Slow Internet

Did you check to see if hardware offload has been disabled for some reason? A hit like that is a bit more than non-offload would cause, and there's been no config changes, but worth a look. Check in the USG's properties in the controller and/or SSH into it and enter "show ubnt offload"

 

Also, can you do an iperf test across two VLANs? Would help check if its an issue with the USG itself or its connection to your modem

 

And I'd always try a factory reset and then readopt as a last effort

New Member
Posts: 22
Registered: ‎11-21-2017
Kudos: 1

Re: USG Slow Internet

Everything is in a default state. I've done the reset and re-adopt multiple times.

 

IP offload module : loaded
IPv4
forwarding: enabled
vlan : enabled
pppoe : enabled
gre : enabled
IPv6
forwarding: enabled
vlan : enabled
pppoe : disabled

IPSec offload module: loaded

Traffic Analysis :
IPv4
forwarding: enabled
vlan : enabled
pppoe : enabled
gre : enabled
export : disabled
dpi : enabled
IPSec offload module: loaded

Established Member
Posts: 1,556
Registered: ‎01-29-2015
Kudos: 210
Solutions: 58

Re: USG Slow Internet

Did you happen to turn on IPS or IDS?

Senior Member
Posts: 13,065
Registered: ‎08-04-2017
Kudos: 2218
Solutions: 641

Re: USG Slow Internet

Hello,

 

Disable DPI just for the giggles, and run the speedtest against multiple different servers.

 

Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation/Easy Update Scripts | UniFi-VoIP Installation Scripts
USG-4-PRO • USG
USW-48-500W • USW-24-POE-250W 2x • USW-16-POE-150W 3x • USW-24 • USW-8-150W • USW-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M
UCK-G2-PLUS • UCK-G2 • UCK
New Member
Posts: 22
Registered: ‎11-21-2017
Kudos: 1

Re: USG Slow Internet

[ Edited ]

Its never been turned on and I use speedtest.net, google speedtest and spectrum speedtest. 

 

All the same result.

New Member
Posts: 22
Registered: ‎11-21-2017
Kudos: 1

Re: USG Slow Internet

DPI is off now and its the same.

Member
Posts: 217
Registered: ‎11-27-2017
Kudos: 80
Solutions: 16

Re: USG Slow Internet

That looks good; hardware offload is enabled. Can you do an iperf w/ wired clients across two VLANs?

New Member
Posts: 22
Registered: ‎11-21-2017
Kudos: 1

Re: USG Slow Internet

No because that would require me to install linux. Haha. More trouble than its worth.

 

I'll just buy another USG and see if that fixes the problem I guess.

Member
Posts: 217
Registered: ‎11-27-2017
Kudos: 80
Solutions: 16

Re: USG Slow Internet

FYI iperf has a Windows installer. And Windows 10 supports installing Linux as an app from the store

New Member
Posts: 22
Registered: ‎11-21-2017
Kudos: 1

Re: USG Slow Internet

Amazon says I'll have a new one on Sunday.

 

I'm running the full VMware stack in a 6 host cluster on all ubnt hardware. My edge router works fine when I sub it in.

 

The problem is the USG. Its 110$. Nbd.Banghead

New Member
Posts: 22
Registered: ‎11-21-2017
Kudos: 1

Re: USG Slow Internet

[ Edited ]

So of course the new firewall didn't work either. So its not a hardware problem. It has to be a config problem which is weird because nothing changed and it was OOTB default.

 

Connected directly to the modem I get 470-500 down. I'm including my boot config. If someone tells me what is wrong with my config, I will venmo them 50$ Haha.

 

As requested here are two iPerfs. One to the USG and one to another server on the same switch.

 

To the USG:

 

-----------------------------------------------------------
Server listening on 5201
-----------------------------------------------------------
Accepted connection from 192.168.1.1, port 49265
[ 5] local 192.168.1.20 port 5201 connected to 192.168.1.1 port 49266
[ ID] Interval Transfer Bandwidth
[ 5] 0.00-1.00 sec 16.0 MBytes 134 Mbits/sec
[ 5] 1.00-2.00 sec 20.3 MBytes 171 Mbits/sec
[ 5] 2.00-3.00 sec 20.7 MBytes 174 Mbits/sec
[ 5] 3.00-4.00 sec 25.4 MBytes 213 Mbits/sec
[ 5] 4.00-5.00 sec 24.1 MBytes 203 Mbits/sec
[ 5] 5.00-6.00 sec 22.8 MBytes 191 Mbits/sec
[ 5] 6.00-7.00 sec 22.7 MBytes 190 Mbits/sec
[ 5] 7.00-8.00 sec 22.2 MBytes 187 Mbits/sec
[ 5] 8.00-9.00 sec 22.5 MBytes 189 Mbits/sec
[ 5] 9.00-10.00 sec 22.0 MBytes 185 Mbits/sec
[ 5] 10.00-10.05 sec 1.14 MBytes 182 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval Transfer Bandwidth
[ 5] 0.00-10.05 sec 0.00 Bytes 0.00 bits/sec sender
[ 5] 0.00-10.05 sec 220 MBytes 183 Mbits/sec receiver
-----------------------------------------------------------

 

To another server on the same switch:

 

-----------------------------------------------------------
Server listening on 5201
-----------------------------------------------------------
Accepted connection from 192.168.60.11, port 54370
[ 5] local 192.168.1.20 port 5201 connected to 192.168.60.11 port 54371
[ ID] Interval Transfer Bandwidth
[ 5] 0.00-1.00 sec 0.00 Bytes 0.00 bits/sec
[ 5] 1.00-2.00 sec 72.2 MBytes 606 Mbits/sec
[ 5] 2.00-3.00 sec 95.5 MBytes 801 Mbits/sec
[ 5] 3.00-4.00 sec 104 MBytes 874 Mbits/sec
[ 5] 4.00-5.00 sec 99.7 MBytes 836 Mbits/sec
[ 5] 5.00-6.00 sec 98.5 MBytes 826 Mbits/sec
[ 5] 6.00-7.00 sec 97.2 MBytes 815 Mbits/sec
[ 5] 7.00-8.00 sec 88.7 MBytes 744 Mbits/sec
[ 5] 8.00-9.00 sec 97.7 MBytes 820 Mbits/sec
[ 5] 9.00-10.00 sec 94.9 MBytes 796 Mbits/sec
[ 5] 10.00-11.00 sec 101 MBytes 850 Mbits/sec
[ 5] 11.00-11.25 sec 26.3 MBytes 873 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval Transfer Bandwidth
[ 5] 0.00-11.25 sec 0.00 Bytes 0.00 bits/sec sender
[ 5] 0.00-11.25 sec 976 MBytes 728 Mbits/sec receiver

Established Member
Posts: 2,257
Registered: ‎03-20-2017
Kudos: 953
Solutions: 73

Re: USG Slow Internet

New Member
Posts: 22
Registered: ‎11-21-2017
Kudos: 1

Re: USG Slow Internet

Reboots don't fix the problem. I've done plenty.

Member
Posts: 217
Registered: ‎11-27-2017
Kudos: 80
Solutions: 16

Re: USG Slow Internet

Can you do the iperf between two clients (not any UniFi device) on two different VLANs? We want to see what the actual routing performance of the USG to help determine whether your issue is on the WAN side, LAN side, or both. An iperf test from the USG will not show that

New Member
Posts: 22
Registered: ‎11-21-2017
Kudos: 1

Re: USG Slow Internet

The second iperf is on a different VLAN on the same switch.

 

The first iperf is from my wired desktop to the USG.

 

I believe the second iperf satisfies what you are asking for.

Reply