Reply
Highlighted
Emerging Member
Posts: 79
Registered: ‎03-05-2015
Kudos: 4
Solutions: 2
Accepted Solution

USG restart by starting some video

Hello,

 

i have a unbeliveable Problem that the USG is restarting if you go to the Webpage: https://www.qnap.com/i/de/index.php too see the QTS 4.0 Demo Video

 

I have tried several times and the USG is restarting allways, if the film is going to start. This trouble is happening after the connection is established and it interrupts after 1 until 5 seconds.

 

Thanks for help.


Accepted Solutions
Ubiquiti Employee
Posts: 6,167
Registered: ‎01-28-2013
Kudos: 5590
Solutions: 552
Contributions: 20

Re: USG restart by starting some video

[ Edited ]

For anyone that reads this, the firmware with the fix for this is included in controller version 4.6.6. It provides stable operation while leaving hardware offload enabled.

 

Cheers,

Mike

 

EDIT: currently the controller is in soaking status (near stable), so it's only avilable in the beta section. If you can't access the above post please see THIS KB article.

UBNT_Alternate_Logo.png

View solution in original post


All Replies
Senior Member
Posts: 3,645
Registered: ‎09-26-2013
Kudos: 898
Solutions: 258

Re: USG restart by starting some video

How long do you have to leave it running?  I left it for a minute without the USG rebooting here.

 

What do you actually see on the USG to indicate it's restarting?

 

Cheers,
Andrew

Emerging Member
Posts: 79
Registered: ‎03-05-2015
Kudos: 4
Solutions: 2

Re: USG restart by starting some video

The usg is restarting after iM opening the video. Its quitting after the qnap logo is visable.

 

I have a nvr_controller pc, where the controller software 4.6.0  is installed. U can see there, that the usg is restarting. All routing connections are interrupted. If u take a look at the usg device, u can se,  its restarting all the time.

 

 My installation is: 5 ubiquiti acces points, 1 usg, 1 nvr, 4 uvc cam's and 2x switches us_24_250w.

 

The problem Is Like i am surfing in the internet (android tablet) through my wlan. Then i visit the page with the video included, i'd like to see and the descripted problem is all the time happening. I tried it 6 times.

Senior Member
Posts: 3,645
Registered: ‎09-26-2013
Kudos: 898
Solutions: 258

Re: USG restart by starting some video

Not seeing the problem with my Windows PC viewing that video.  I'll try with an Android tablet in a while (it's been unused for so long its run out of power, so it'll take a while charging!) and let you know what happens.

 

I'm on USG firmware version 4.2.4.4733350 - if you're on a lower one, make sure you upgrade.

 

Cheers,

Andrew

Senior Member
Posts: 3,645
Registered: ‎09-26-2013
Kudos: 898
Solutions: 258

Re: USG restart by starting some video

Just tried with an android tablet - still not able to get the USG to crash.   I'd update the firmware and if that doesn't work, reset to factory defaults and re-adopt.

 

Cheers,
Andrew

Emerging Member
Posts: 79
Registered: ‎03-05-2015
Kudos: 4
Solutions: 2

Re: USG restart by starting some video

Hello,

 

yesterday i tried it afer the reset in the evening again an the Problem was not here. All was Runnig perfect. So it seems too be an other Problem.

 

My USG was restart this Moring again. Why? Thanks for help

27-03-2015 08-12-11.jpg
Senior Member
Posts: 3,645
Registered: ‎09-26-2013
Kudos: 898
Solutions: 258

Re: USG restart by starting some video

Can you check that it is plugged in securely?   Also, is it plugged in using the original power supply, or something different?

 

Also, the USG has a log called /var/log/messages - have a look at this log to see if there are any obvious problems.

 

Cheers,

Andrew

Emerging Member
Posts: 79
Registered: ‎03-05-2015
Kudos: 4
Solutions: 2

Re: USG restart by starting some video

Yes it is all save and I am using the orginal power supply.

 

I did a show log but i can't find anything.

 

Please help me how i can get the messages??

Are the messages on the Controller PC or on the USG? I think i can't follow you and linux is a littele bit new for me.

I am working on an Windows Maschine and the Controller is installed on th Ubiquiti NVR PC.

 

Thanks again.

27-03-2015 11-55-11.jpg
Senior Member
Posts: 3,645
Registered: ‎09-26-2013
Kudos: 898
Solutions: 258

Re: USG restart by starting some video

To transfer the messages file to your PC you can do this using WinSCP (winscp.net) - it works like PuTTY but does file transfer instead of terminal emulation.

 

Cheers,

Andrew

Emerging Member
Posts: 79
Registered: ‎03-05-2015
Kudos: 4
Solutions: 2

Re: USG restart by starting some video

hello andrew,

 

lock there i also can't find nothing. hmmm ???

 

 

27-03-2015 13-26-05.jpg
Senior Member
Posts: 3,645
Registered: ‎09-26-2013
Kudos: 898
Solutions: 258

Re: USG restart by starting some video

I don't understand what you're saying - can you post the logs so I can have a look at them?  I can't see anything from the short section already posted.

 

Cheers,
Andrew

Emerging Member
Posts: 79
Registered: ‎03-05-2015
Kudos: 4
Solutions: 2

Re: USG restart by starting some video

yes, here is the fully log

 

https://www.dropbox.com/sh/x0dz7icbm12pul8/AACtXYBtDghh_dXkpZUsq54ya?dl=0

 

i'll hope thats all right. Thanks for help.

 

Cheers, Dieter

 

 

 

Senior Member
Posts: 3,645
Registered: ‎09-26-2013
Kudos: 898
Solutions: 258

Re: USG restart by starting some video

I'm sorry, I can't see anything in the log that would indicate the problem - the only thing I can think is that there is a fault on the power supply that is causing a restart when the USG is under load.   @UBNT-MikeD any ideas?

 

Cheers,

Andrew

Ubiquiti Employee
Posts: 6,167
Registered: ‎01-28-2013
Kudos: 5590
Solutions: 552
Contributions: 20

Re: USG restart by starting some video

[ Edited ]

andyc wrote:

I'm sorry, I can't see anything in the log that would indicate the problem - the only thing I can think is that there is a fault on the power supply that is causing a restart when the USG is under load.   @UBNT-MikeD any ideas?


I was able to cause a trigger panic when watching YouTube videos under certain scenarios before. In my case, and what looks to be yours, you won't see helpful info unless you connect via the console port and get the output that way. Attached is my log, showing the kernel panic.

 

Anyhow, my problem was solved in the upcoming release, 4.6.3 (USG fw 4.2.6.4751786). I cannot duplicate your issue with the firmware I'm on right now, so it should be resolved in the upcoming release. On that note, we hope to get that out this weekend.

 

In my case it appeared that it was related to the hardware offload. To test to see if that is the case with your issue, you can do the following via SSH:

configure
set system offload ipv4 pppoe disable
set system offload ipv4 vlan disable 
set system offload ipv4 forwarding disable
set system offload ipv6 vlan disable 
set system offload ipv6 forwarding disable
commit;save;exit

 If that works, you either have the choice of:

  1. Don't make any changes to USG provisioning until 4.6.3 is released Man Happy
  2. Use the config.gateway.json method, but make sure to revert that when the update is released (assuming you update at that time).

Let me know if the above helps with your issue.

 

Cheers,

Mike

UBNT_Alternate_Logo.png
Attachment
Emerging Member
Posts: 79
Registered: ‎03-05-2015
Kudos: 4
Solutions: 2

Re: USG restart by starting some video

Hello Mike,

 

I did this SSH. Now I'll see what the USG is doing.

 

What is "system offload", or what it realy do?

 

thanks for more Info.

Ubiquiti Employee
Posts: 6,167
Registered: ‎01-28-2013
Kudos: 5590
Solutions: 552
Contributions: 20

Re: USG restart by starting some video

[ Edited ]

oe7dkt wrote: What is "system offload", or what it realy do?

It's hardware accelerated packet processing. Essentially it should speed things up. There is a good chance you won't notice it being off, at least for the next couple days (but that depends on usage). 

 

Cheers,

Mike

UBNT_Alternate_Logo.png
Emerging Member
Posts: 79
Registered: ‎03-05-2015
Kudos: 4
Solutions: 2

Re: USG restart by starting some video

So now, all ist disabled. Let us see if the USG is restarting next morning.

I'll let you know.

 

Cheers,

Dieter

 

 

Ubiquiti Employee
Posts: 6,167
Registered: ‎01-28-2013
Kudos: 5590
Solutions: 552
Contributions: 20

Re: USG restart by starting some video


oe7dkt wrote:

So now, all ist disabled. Let us see if the USG is restarting next morning.

I'll let you know.

 

Cheers,

Dieter 


Hi Dieter,

 

Sounds good. I'm interested to see if it helps. Thanks!

 

Cheers,

Mike

UBNT_Alternate_Logo.png
Emerging Member
Posts: 79
Registered: ‎03-05-2015
Kudos: 4
Solutions: 2

Re: USG restart by starting some video

Hi Mike,

 

today the USG wasn't restarting until now. It seen's that the "system offload" is the cause of the troubles.

 

If I understand aright, this is fixed in the next version?

 

Cheers,

Dieter

 

PS: Do you know when the controller includes that you can confortable setup the rules between the vlan's or the firewall? Thanks for Info

Ubiquiti Employee
Posts: 6,167
Registered: ‎01-28-2013
Kudos: 5590
Solutions: 552
Contributions: 20

Re: USG restart by starting some video


oe7dkt wrote:

 

today the USG wasn't restarting until now. It seen's that the "system offload" is the cause of the troubles.

 

If I understand aright, this is fixed in the next version?

 

PS: Do you know when the controller includes that you can confortable setup the rules between the vlan's or the firewall? Thanks for Info


Hi Dieter,

 

Thanks for the confirmaiton. Yes, this is fixed in the upcoming release without disabling hardware offload.

 

I'm not sure exactly what plans there are in regards to more granular control of the USG/USW configuration, or where this is on the roadmap at the present, I will have to check on that Monday. I'll report back with what I find out.

 

Cheers,

Mike

UBNT_Alternate_Logo.png
Reply