Reply
Highlighted
New Member
Posts: 4
Registered: ‎04-17-2018
Solutions: 1
Accepted Solution

UniFi Security Gateway 4P, Windows explorer device visability

We have recentaly installed an entire new network based on the UniFi Security Gateway 4P.

All is working well including the site-to-site radio link.

However there is one thing I can not work out. All our machines are Windows 10. In explorer we can not see any devices on the network. For example to assess the NAS drives we have to type in the \\NAS-xxx into the file explorer address bar.

We also used remote desktop and used to be able to see all computers on the network and just right-click then connect. Again though we cant 'see' them.

 

Could somebody help me out with this is starting to cause upset with the users. I presume this is some Gateway setting I have not set correctly?

 

Any advice would be most appreciated.

 


Accepted Solutions
New Member
Posts: 4
Registered: ‎04-17-2018
Solutions: 1

Re: UniFi Security Gateway 4P, Windows explorer device visability

This is a windows 10 issue as I tested with a windows 7 machine and all ok.,

To solve in W10:-

Check network discovery is on for private network.

Check network is on public

Go to services,

Set all the following to auto-delayed:-

Fuction Discovery Provide Host

Function Discovery Resource Publication

SSDP Discovery

UPnP Device Host

And start them all.

This should work.

View solution in original post


All Replies
Emerging Member
Posts: 84
Registered: ‎09-23-2018
Kudos: 4
Solutions: 3

Re: UniFi Security Gateway 4P, Windows explorer device visability

[ Edited ]

In windows 10, do you have the network set as public or private?

 

image.png

 

If it is private, then ensure you have your machines' visibility on. If it is public, then change your network type to private, and this should resolve your issue.

 

 

https://tinkertry.com/how-to-change-windows-10-network-type-from-public-to-private

New Member
Posts: 4
Registered: ‎04-17-2018
Solutions: 1

Re: UniFi Security Gateway 4P, Windows explorer device visability

[ Edited ]

Thank you for your reply.

All machines are set to Private network. It is also the NAS drives not being seen. Also Visability is on, so if discoverable.

Emerging Member
Posts: 84
Registered: ‎09-23-2018
Kudos: 4
Solutions: 3

Re: UniFi Security Gateway 4P, Windows explorer device visability

Have you tried enabling uPNP?

New Member
Posts: 25
Registered: ‎10-11-2018

Re: UniFi Security Gateway 4P, Windows explorer device visability

Unfortunately you might be caught up in a network issues I've had for a while now and it relates to Windows 10 and SMB 1.0/CIFS support removal and other little quirks.

I too have a similar scenario as you, and it's been going like that for a while. Where I had to fight with a new install of Windows that doesn't have a lot of backwards support for SMB 1.0 and 'guest password' access to shares.

In my network I have a few devices that can see all network computers as default and they always show up. Then I have some Win10 machines where they see none or one, and have to type in \\networkname like you. I also have some that I have to randomly use the \\ip.address.

If you search, you'll find a lot of people with a similar issue with no, I'm yet to find, official fixes from Microsoft. On a re-imaged Surface Pro 2 I had to jump through so many hoops just to get it to connect to a share without guess password.

The changes to removal of SMB 1.0 was in the last few major updates and might have combined to make a larger issue. Solution for users might be to map static drives to those shares.
New Member
Posts: 4
Registered: ‎04-17-2018
Solutions: 1

Re: UniFi Security Gateway 4P, Windows explorer device visability

I will check if uPNP is enabled, I’m sure it is. I do feel this is an W10 issue as rumbaar suggests. 

It does appear somewhat random, some machines being worse than others.

Thank you both for your replies I will keep trying and keep you posted.

New Member
Posts: 4
Registered: ‎04-17-2018
Solutions: 1

Re: UniFi Security Gateway 4P, Windows explorer device visability

This is a windows 10 issue as I tested with a windows 7 machine and all ok.,

To solve in W10:-

Check network discovery is on for private network.

Check network is on public

Go to services,

Set all the following to auto-delayed:-

Fuction Discovery Provide Host

Function Discovery Resource Publication

SSDP Discovery

UPnP Device Host

And start them all.

This should work.

Reply