Highlighted
New Member
Posts: 15
Registered: ‎01-20-2014
Solutions: 1

UniFi - VLAN switch/router/controller configuration

[ Edited ]

Im a newbie so please bear with me.

 

I have 12 AP-LR connected to EdgeSwitch-24 ports 13 - 24.

I have Unifi Controller 4.6.6 connected to port 2 on EdgeSwitch24

I have EdgeRouterLite3 port ETH0 (10.0.0.254) connected to port 1 on EdgeSwitch24..

I have EdgeRouterLite3 port ETH1 (DHCP) connected to my local LAN. Port ETH2 is not used.

I have 3 Wife Networks: Office (No VLAN), Guest (VLAN 200) and Resident (VLAN 100).

I have DHCP on ETH0 10.0.0.x

I used Unifi Controller to create 3 Networks with appropriate DHCP for VLAN.

 

Both VLANS (100 and 200) are tagged on ports 1,13-24 in EdgeSwitch24.

VLAN 1 (Default) is untagged on ports 1-24.

 

As long as I dont assign a VLAN to Wifi Network units get 10.0.0.x from EdgeRouter and all works GREAT ! !

When I assign a VLAN to a Wifi Network (ie, Guest or Resident) units get appropriate DHCP address from Unifi Controller but NO INTERNET.

 

HELP! ! ! Not sure if I need to tweek NAT or FIREWALL or CONTROLLER or ? ?

Is there a newbie tutorial out there that I can follow? 

 

ALSO . . . EdgeRouterLite and EdgeSwitch24 do not show up on Unifi 4,6,6 controller.  ? ? 

 

 

 

New Member
Posts: 15
Registered: ‎01-20-2014
Solutions: 1

Re: UniFi - VLAN switch/router/controller configuration

UPDATE:

 

I changed ROUTER address on ERLite3  DHCP Servers to same as Controller-->Settings-->Networks-->Name-->Network IP/Subnet address .

 

Appears to work OK now.

 

Now I have DHCP servers running on both Controller and on EdgeRouter.

Appears DHCP on EdgeRouter is winning.

 

Only devices appearing in controller are APs.

How can I get Router and Switch to appear?

 

 

Regular Member
Posts: 405
Registered: ‎10-21-2013
Kudos: 121
Solutions: 23

Re: UniFi - VLAN switch/router/controller configuration

The EdgeRouter and EdgeSwitch are not controlled by the controller. The DHCP and Network settings in the controller are not doing anything currently.

 

You need to create your VLAN interfaces on the router. Add VLAN 100 and VLAN 200 to eth0. Next add DHCP scopes for the 2 new VLANs on the router.