Reply
New Member
Posts: 5
Registered: ‎12-31-2018

routing problem

hello,
i have the following setup installed just last week:
UniFi Security Gateway 3P
UniFi Switch 24 POE-250W
UniFi AP-AC-Pro
UniFi Switch 8 (remote switch)
 
i have the following problem:
i use a MQTT server for IoT, the MQTT uses port 1883
- when i connect to it wired from any switch, it works.
- when i connect to it using a 5g wifi device it works
- when i connect to it using a 2.4g wifi device i cant see the server.
i can connect to the 2.4g wifi device using a web server on the device, i can ping it, i can ping from the device to the lan devices and the MQTT server.
i have setup a diferent device, diferent programs, using 2.4g and get the same result.
 
Do i need to add more info to get this fixed?
 
Thanks in advance,
Matthieu
New Member
Posts: 5
Registered: ‎12-31-2018

Re: routing problem

i have now gone back to my old network to see if i have the same problem but on the old problem my mqqt works as it should.

is there something i need to open my router to get full connectivity between my lan and my wireless lan?

New Member
Posts: 5
Registered: ‎12-31-2018

Re: routing problem

after reading this article:

https://robpickering.com/working-around-incomplete-ubiquiti-unifi-security-gateway-dns-service/

i found out there is a problem with internal DNS

then i found out in this page:

https://community.ubnt.com/t5/UniFi-Routing-Switching/USG-DNS-server/td-p/2182469

that internal DNS only works if the client is set to DHCP and not static.

this is to bad, this server controls my heating system and i would like to keep this on static IP.

is there a way around this problem?

Highlighted
Member
Posts: 289
Registered: ‎05-06-2017
Kudos: 280
Solutions: 19

Re: routing problem

[ Edited ]

Use DHCP to give the device a static address and name.

 

From the Clients screen select the device in question.

On the properties panel switch to configuration.

Enter the desired name under Alias.

Open the Network tab and select "Use fixed IP address"

Fill in the IP address.

 

Edit: Not sure why those screenshots are so huge lol

 

network1.PNGnetwork2.PNG

UCK-G2-PLUS | USG-3P | USW-24P-250 | USW-8P-150 | UAP-AC-LR | UAP-HD-IW | UVC-G3-AF | UVC-G3-PRO | UVC-G3-FLEX
New Member
Posts: 5
Registered: ‎12-31-2018

Re: routing problem

Thanks Roland,

i found this feature before but this is not what i ment, also that wont fix my problem.

i restarted my gateway and the local dns cant be found again.

adding this rule to my router help :

set system static-host-mapping host-name controller inet 192.168.0.12

 

but it wont stick after provisioning or reboot

New Member
Posts: 5
Registered: ‎12-31-2018

Re: routing problem

in search for a solution i found out that if i add the domainname from my lan network i can connect to the mqtt server.

so instead of just controller i changed it to controller.lan (lan being the domain name of my lan network).

this seems to work as a workaround, unless its intended to be working like this?

Reply