UniFi Network Controller 5.6.42 Stable has been released

by Ubiquiti Employee 2 weeks ago - last edited Wednesday (10,215 Views)

Requirements:

  • (Recommended) - Create an up-to-date backup before upgrading your controller in the event any issues are encountered.
  • Existing UniFi controllers must be on one of the following versions in order to upgrade directly to this version:
    Spoiler
    • 5.6.41 and earlier 5.6.x versions.
    • Most earlier versions are also supported for direct upgrade, going back to 3.1.0.
  • Java 8 must be installed on the system hosting the controller software. Java 9 and later are not yet supported.
  • Minimum supported device firmware for most UAP/USW is 4.0.9, and for USG it's 4.4.34. The only supported firmware for UAP-AC, UAP-ACv2 and UAP-AC-Outdoor is 3.8.17.
  • Due to technical limitations, PicoM2 converted to UniFi will not be supported by this release. 
  • Microsoft Windows specific:
    Spoiler
    Users running 64-bit Windows should only have 64-bit Java installed. If you have 32-bit Java installed then we recommend uninstalling it.
  • Debian/Ubuntu specific:
    Spoiler
    • For Debian/Ubuntu users installing via our repo, please update your APT source (see HERE).
    • Currently we only support MongoDB 3.4. We're working on updating support before end of life this fall. We have instructions for Ubuntu users in our HC article HERE (see section 2.2).

 

Controller bug fixes/changes since 5.6.40:

  • Fix MitM SMTP vulnerability (disclosed HERE).
  • Improve security of device management (disclosed HERE).

 

Download:

*This release follows our usual release structure which means it will initially be available via this blog post only. It will be posted to the download site and official repos in the near future. If you aren't familiar with our release structure, please take a moment to read our post HERE. Thanks!