Reply
Highlighted
New Member
Posts: 4
Registered: Friday
Solutions: 1
Accepted Solution

Issue with Enabling RTSP on NVR

So here I am trying to get the RTSP streaming enabled on our NVR server and when I click save, I keep getting the following error message:


NVR-Error.JPG

I'm running version 3.9.8 on a Windows Server 2012R2. I haven't had any luck determining what the cause of this error is and where to go to fix it. This is preventing me from being able to save the setting with RTSP enabled. I've tried removing all settings regarding emails on the account such as turning off email alerts, unlinked from my ubiquiti account, and removing the email addresses from user accounts with no luck. There doesn't seem to be anyone else with this issue as far as I can tell. Let me know what you all think the issue is. Thanks!


Accepted Solutions
New Member
Posts: 4
Registered: Friday
Solutions: 1

Re: Issue with Enabling RTSP on NVR

I've played with the settings a bit and I seemed to have found the issue. I unlinked my NVR from the cloud and enabled the SMTP settings. There were email settings already in the SMTP section (which were the correct settings but the NVR wouldnt accept them) so I removed all of those settings and was finally able to save it. I was then able to enable the RTSP settings and save the system settings. The NVR has since been relinked to the cloud and everything seems to be working as it should. I really thought that if I was linked to the cloud, then Ubiquiti's settings would have resolved this problem but that was oddly not the case. Anyway, this issue is resolved. Thanks for helping me work through this problem.

View solution in original post


All Replies
New Member
Posts: 4
Registered: Friday
Solutions: 1

Re: Issue with Enabling RTSP on NVR

Any ideas on how to fix this error? Any input would be appreciated. Thanks.

Ancient Member
Posts: 31,885
Registered: ‎05-05-2012
Kudos: 10186
Solutions: 1573

Re: Issue with Enabling RTSP on NVR

How about filling in the SMTP fields with valid data?  If you join the NVR to the cloud, then the SMTP fields would not be there so maybe it would not try to validate those?

My Topics
Top Solution Authors Leaderboard
"The firings will continue until morale improves." Donald Trump (unconfirmed) 2017.
New Member
Posts: 4
Registered: Friday
Solutions: 1

Re: Issue with Enabling RTSP on NVR

I have it connected to the cloud. I was under the impression that when it's connected to the cloud, it uses Ubiquiti's SMTP settings to send out alerts?

 

As a test, I just disconnected it from my Ubiquiti account and I now have the SMTP/Email Server setting turned OFF. If I turn on RTSP and click save, I still get the same error. I've also enabled the SMTP/Email Server using valid credentials and have RSTP turned off and also get the same error. I have noticed that when I click "SEND TEST EMAIL" I do get a slightly different error:

 

NVR-Error1.JPG

 

The errors seem to related to the SMTP settings specifically instead of RSTP but its preventing me from enabling RSTP altogether.  I'm not sure why it keeps throwing these errors as my email is valid and the SMTP settings are correct. I've used these same credentials on many devices for SMTP. The only thing that I can think of is that where I'm using Office 365, they recommend using START TLS where Ubiquiti seems to only support SSL. Perhaps that is causing the authentication to fail, thus throwing the error?

New Member
Posts: 4
Registered: Friday
Solutions: 1

Re: Issue with Enabling RTSP on NVR

I've played with the settings a bit and I seemed to have found the issue. I unlinked my NVR from the cloud and enabled the SMTP settings. There were email settings already in the SMTP section (which were the correct settings but the NVR wouldnt accept them) so I removed all of those settings and was finally able to save it. I was then able to enable the RTSP settings and save the system settings. The NVR has since been relinked to the cloud and everything seems to be working as it should. I really thought that if I was linked to the cloud, then Ubiquiti's settings would have resolved this problem but that was oddly not the case. Anyway, this issue is resolved. Thanks for helping me work through this problem.

Reply