Emerging Member
Posts: 81
Registered: ‎07-09-2015
Kudos: 49
Solutions: 3
Accepted Solution

Unable to load UVC G3 live stream

I have a Unifi Video appliance model: UVC-NVR-2TB  Linux OS

My camera models are:

 - UVC G3  firmware 4.2.13

 - UVC G3 Dome firmware 4.2.13

 

Issue: When logged into the Unifi Video whether it's clicking on the "LIVE FEED" or navigating to "LIVE VIEW" I'm able to see the picture, but at the top of the box it always says "Unable to load UVC G3 live stream". What does this mean?

 

Googling the issue led me to here:

 

https://community.ubnt.com/t5/UniFi-Video/Unable-to-Load-Stream-Please-make-sure-port-7446/td-p/2114... -> https://community.ubnt.com/t5/UniFi-Video/UniFi-Video-3-8-4-What-to-do-Update-to-3-8-5/m-p/2116986#M... -> https://community.ubnt.com/t5/UniFi-Video-Blog/UniFi-Video-3-8-5-Release/ba-p/2119587

 

However, I've not been able to find a solution yet. Can someone help point me in the right direction?

@UBNT-Matt_B_

 

Kind regards,

penny01


Accepted Solutions
Emerging Member
Posts: 81
Registered: ‎07-09-2015
Kudos: 49
Solutions: 3

Re: Unable to load UVC G3 live stream

I found the following link https://community.ubnt.com/t5/UniFi-Video/Unable-to-Load-Stream-Port-7446-on-Firefox/td-p/2030526

Which said to add https://yourhostname:7446/ to the exception list. Once I did that the Unable to load UVC G3 live stream message has gone.

Now I've run into a different issue which is the recordings are not playing, but I'll see what I can find and post back here.

 

 

View solution in original post

Emerging Member
Posts: 81
Registered: ‎07-09-2015
Kudos: 49
Solutions: 3

Re: Unable to load UVC G3 live stream

[ Edited ]

It appears this is an issue in Firefox maybe, but I'm not sure.

I found the following thread from 3 weeks ago, but there's been no resolution that I've found yet.

https://community.ubnt.com/t5/UniFi-Video/issues-with-firefox-quantum/m-p/2263217#M98377

 

Installed chrome and the recordings playback just fine. So it is Firefox or may some setting I don't have tweaked just right in it.

Just FYI... the recordings playback on Safari as well (tested on the iPhone atleast).

 

View solution in original post


All Replies
Emerging Member
Posts: 118
Registered: ‎08-24-2016
Kudos: 14

Re: Unable to load UVC G3 live stream

What browser u using ? 

 

Emerging Member
Posts: 81
Registered: ‎07-09-2015
Kudos: 49
Solutions: 3

Re: Unable to load UVC G3 live stream

I am using Firefox version 58.0.2 64-bit.

Emerging Member
Posts: 81
Registered: ‎07-09-2015
Kudos: 49
Solutions: 3

Re: Unable to load UVC G3 live stream

I found the following link https://community.ubnt.com/t5/UniFi-Video/Unable-to-Load-Stream-Port-7446-on-Firefox/td-p/2030526

Which said to add https://yourhostname:7446/ to the exception list. Once I did that the Unable to load UVC G3 live stream message has gone.

Now I've run into a different issue which is the recordings are not playing, but I'll see what I can find and post back here.

 

 

Emerging Member
Posts: 81
Registered: ‎07-09-2015
Kudos: 49
Solutions: 3

Re: Unable to load UVC G3 live stream

[ Edited ]

It appears this is an issue in Firefox maybe, but I'm not sure.

I found the following thread from 3 weeks ago, but there's been no resolution that I've found yet.

https://community.ubnt.com/t5/UniFi-Video/issues-with-firefox-quantum/m-p/2263217#M98377

 

Installed chrome and the recordings playback just fine. So it is Firefox or may some setting I don't have tweaked just right in it.

Just FYI... the recordings playback on Safari as well (tested on the iPhone atleast).

 

Emerging Member
Posts: 118
Registered: ‎08-24-2016
Kudos: 14

Re: Unable to load UVC G3 live stream

Use chrome and turn of the hardware acceleration on chrome it does good job. as a backup solution. 

New Member
Posts: 1
Registered: ‎12-10-2015

Re: Unable to load UVC G3 live stream

After running in to the same issue, I think I nailed it down.

 

Overwrite your unifi controller software with 3.9.5

Observer the cameras have "firmware unsupported"

Log in to the cameras and flash them to a previous firmware (I used 4.4.6)

Log in to unifi controller and adopt cameras

Allow controller to update the firmare on the cameras

Worked fine with no issues

New Member
Posts: 12
Registered: ‎09-25-2015
Kudos: 1

Re: Unable to load UVC G3 live stream

If anyone else needs further assistance, follow the instructions below (Firefox v.64):

 

Open Firefox Options and scroll to the bottom of the Privacy and Security tab to reach "Certificates".

Firefox Privacy and Security Certs.PNGFirefox Privacy and Security Tab

Click "View Certificates"

 

Then in the Certificate Manager window, click the "Servers" tab and the "ubnt.com" drop down. Note your Ubiquiti Video Server address already shown for port 7443.

Firefox Cert Mgr Ubnt Video.PNGFirefox Certificate Manager

Click "Add Exception" button.

 

Type the address in the field: "https://your-server-ip:7446"

(If your video server is installed directly on the PC you are are using, then you should use the loopback "localhost" address 127.0.0.1)

Then click "Get Certificate" (you can further confirm the identity clicking "View".)

 

Firefox Cert Mgr Add Excep Ubnt Video.PNG

Then click "Confirm Security Exception".

 

It should now show the exception for the 7446 port in the certificate manager window & the live streaming should function; removing the "Unable to Load Stream" message.

 

New Member
Posts: 2
Registered: ‎12-26-2018

Re: Unable to load UVC G3 live stream

I'm having this problem now after waiting months for the Chrome upgrade to resolve the fullscreen issue on the NVR liveview. One thing resolved, another broken. I need to know how to rollback to the broken version as my cameras aren't recording since the update!!!!!!!!!!!!!!

New Member
Posts: 12
Registered: ‎11-13-2017
Kudos: 1

Re: Unable to load UVC G3 live stream

[ Edited ]

@jacompanyit  Your steps of manually adding the server exemption into Firefox solved my problem where the live stream would not load. Thanks!

 

However, a few days ago I upgraded to my UVR to 3.10.1 and immediately noticed that all of my live streams were broken again in Firefox.

 

In case anyone is dealing with the same problem: in order to get my live streams working again I had to go back into Firefox and delete all of the saved server exemptions which I had originally created. Then I re-added the exact same exemptions back into the same menu and immediately my live streams began working again. This included :7442 :7443 and :7446. It is beyond me why this had any effect but it did.