Scheduled maintenance: Community will be offline Monday June 17th, 1:00 AM - 6:00 AM (PT)
Reply
Emerging Member
Posts: 41
Registered: ‎12-23-2014
Kudos: 15
Solutions: 2

BUG [NanoHD|: broadcast and multicast leaking between VLANs

I'm using WPA Enterprise with RADIUS assigned VLAN with 18 Unifi APs.

For years everything was working as expected.

Since a couple of weeks, users have been reporting problems connecting to the network and regular disconnections.

 

After invesigation, the problem occured after I replaced 2 broken UAP-AC-PRO with 2 new UAP-nanoHD.

So I went with Wireshark to figure out what was happening with the DHCP:

I'm seeing broadcast and multicast packets from other VLANs and apparently my own broadcasts (DHCP, ARP) are blocked somewhere. 

Leaking VLANs are from other users connected on the same antenna, so the leak is in the antenna bridging layer.

 

If I move near a UAP-AC-PRO instead I get an address immediately and don't see any broadcast nor multicast from other VLANs. So it confirms it is a UAP-nanoHD problem.

 

In the early times (beta) of RADIUS assigned VLAN on UAP-AC-PRO there was the same problem.

 

Example traffic:

Legit assigned VLAN subnet: 10.10.83.0/24

Seen:

Src: 10.10.4.103. Dst: 10.10.4.255

Src: 10.10.3.101 Dst: 224.0.0.251

Plenty of ARP "Who has?" from other subnets

 

Captures available on request

 

UniFi AP-nanoHD firmware: 4.0.21.9965

Manager: 5.10.17 (Build: atag_5.10.17_11638)

 

Senior Member
Posts: 25,956
Registered: ‎08-04-2017
Kudos: 4870
Solutions: 1288

Re: BUG [NanoHD|: broadcast and multicast leaking between VLANs

Hello @scapal,

 

I believe @UBNT-AngusL  is already looking into this.

@UBNT-AngusL  could you confirm this?

 

 

Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation Scripts | UniFi-VoIP Installation Scripts
USG-XG-8 • USG-4-PRO • USG
US-XG-16 • US-48-500W • US-24-POE-250W 2x • US-16-POE-150W 3x • US-24 • US-8-150W • US-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD 2x • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M • UAP-AC-M-PRO 2x
UAS-XG • UCK-G2-PLUS • UCK-G2 • UCK
Emerging Member
Posts: 41
Registered: ‎12-23-2014
Kudos: 15
Solutions: 2

Re: BUG [NanoHD|: broadcast and multicast leaking between VLANs

[ Edited ]

I don't think it is the same problem as the other posts I saw were configuration related.

Here I have 16 UAP-AC-PRO working properly on that site, only the 2 UAP-NanoHD are exhibiting the problem.

 

@UBNT-FrankC corrected the very same problem for 2nd gen AC antennas:

https://community.ubnt.com/t5/UniFi-Wireless-Beta/2ND-GEN-AC-ONLY-RADIUS-controlled-VLAN-firmware/m-...

New Member
Posts: 3
Registered: ‎06-19-2018

Re: BUG [NanoHD|: broadcast and multicast leaking between VLANs

I have the exact symptoms you're describing with (unfortunately) 18 nanoHDs and RADIUS assigned VLANs. I'm seeing broadcast and multicast traffic from other VLANs and subnets, mDNS and ARP requests. If my capturing device is associated with a UAP-HD or a UAP-AC-M, the problem instantly dissapears. 

 

I'm having occasional DHCP failures also. I was having a large number until I set the ip helper-address for the DHCP server on the VLAN in which it operates, which isn't something I'd expect to have to do it appears to be it's compensating for the issue in some way.

 

Firmware: 4.0.21.9965, Controller: 5.10.17.1

Emerging Member
Posts: 41
Registered: ‎12-23-2014
Kudos: 15
Solutions: 2

Re: BUG [NanoHD|: broadcast and multicast leaking between VLANs

@UBNT-AngusL @UBNT-MikeD , could you take a look at this problem please?

 

Ubiquiti Employee
Posts: 9,632
Registered: ‎01-28-2013
Kudos: 17001
Solutions: 609
Contributions: 20

Re: BUG [NanoHD|: broadcast and multicast leaking between VLANs


@scapal wrote:could you take a look at this problem please?

This wasn't properly fixed until 4.0.21. That said it actually looks like these fixes were not ported for nano-HD/IW-HD (meaning this issue would still be present there). I actually don't know much beyond that right this moment, but I'll looko into that and follow up.

 

Cheers,

Mike

Emerging Member
Posts: 41
Registered: ‎12-23-2014
Kudos: 15
Solutions: 2

Re: BUG [NanoHD|: broadcast and multicast leaking between VLANs

Hi Mike,

 

Any news about this problem?

Is there a way I can help from my side?

 

Cheers,

Pascal

New Member
Posts: 38
Registered: ‎06-21-2013
Kudos: 2

Re: BUG [NanoHD|: broadcast and multicast leaking between VLANs

+1  Any news?  I was about to order a bunhc of nanoHD's but this bug would bite me so I am holding off until I hear if it has been resolved.

 

thx

mike

 

New Member
Posts: 3
Registered: ‎06-19-2018

Re: BUG [NanoHD|: broadcast and multicast leaking between VLANs

This issue is really hurting us still. I'd love to see a fix for this soon!

Senior Member
Posts: 25,956
Registered: ‎08-04-2017
Kudos: 4870
Solutions: 1288

Re: BUG [NanoHD|: broadcast and multicast leaking between VLANs

Hello @steve-2525,

 

Have you already tried the latest BETA Firmware? ( follow this article to sign up for BETA )

 

 

Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation Scripts | UniFi-VoIP Installation Scripts
USG-XG-8 • USG-4-PRO • USG
US-XG-16 • US-48-500W • US-24-POE-250W 2x • US-16-POE-150W 3x • US-24 • US-8-150W • US-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD 2x • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M • UAP-AC-M-PRO 2x
UAS-XG • UCK-G2-PLUS • UCK-G2 • UCK
New Member
Posts: 3
Registered: ‎06-19-2018

Re: BUG [NanoHD|: broadcast and multicast leaking between VLANs

Thanks for that. I gave the beta a shot on one of our devices, and also a device in a test site with minimal config, but unfortunately I'm still seeing the same behaviour Man Sad

Senior Member
Posts: 25,956
Registered: ‎08-04-2017
Kudos: 4870
Solutions: 1288

Re: BUG [NanoHD|: broadcast and multicast leaking between VLANs

Hello @steve-2525,

 

Than patiently wait for MikeD to come back with more information.

 

 

Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation Scripts | UniFi-VoIP Installation Scripts
USG-XG-8 • USG-4-PRO • USG
US-XG-16 • US-48-500W • US-24-POE-250W 2x • US-16-POE-150W 3x • US-24 • US-8-150W • US-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD 2x • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M • UAP-AC-M-PRO 2x
UAS-XG • UCK-G2-PLUS • UCK-G2 • UCK
New Member
Posts: 1
Registered: ‎04-28-2019

Re: BUG [NanoHD|: broadcast and multicast leaking between VLANs

I think I'm seeing a similar problem.  This is just at home and I'm statically assigning VLANs per SSID.

 

I have several VLANs on my network:

 

- VLAN:1 (default)- my lan

- VLAN 1001 - IOT network

- VLAN 1003 - Guest network

- VLAN 1005 - IPTV

 

VLAN 1005 is for IPTV network from my service provider.  They provide their own router which has dhcp for ipv4/ipv6.  On the NanoHD I get an IPv6 address, which seems to have leaked over from VLAN 1005.  This doesn't seem to happen on my lite/LR which I have in different parts of the house.

 

New Member
Posts: 4
Registered: ‎12-10-2015
Kudos: 5

Re: BUG [NanoHD|: broadcast and multicast leaking between VLANs

Has this problem been fixed in the meantime?

Is it only nanoHD specific or are the AC HD/ SHD also affected?

Thanks.

Ubiquiti Employee
Posts: 1,003
Registered: ‎07-04-2017
Kudos: 230
Solutions: 60

Re: BUG [NanoHD|: broadcast and multicast leaking between VLANs


@dempie wrote:

Has this problem been fixed in the meantime?

Is it only nanoHD specific or are the AC HD/ SHD also affected?

Thanks.


Have you tried 4.0.30?

 

Thanks,

Jeff

 

UBNT_Alternate_Logo.png
Ubiquiti Networks Enterprise Team
"I cannot teach anybody anything. I can only make them think." - Socrates

New Member
Posts: 4
Registered: ‎12-10-2015
Kudos: 5

Re: BUG [NanoHD|: broadcast and multicast leaking between VLANs


@UBNT-JaM wrote:

@dempie wrote:

Has this problem been fixed in the meantime?

Is it only nanoHD specific or are the AC HD/ SHD also affected?

Thanks.


Have you tried 4.0.30?

 

Thanks,

Jeff

 


 

Hi Jeff,

I haven't got any Ubiquiti wireless APs at the moment. I am thinking of buying nano HD or HD.

Has the problem been resolved? And does it also affect HD?

Thanks.

Best Regards,

dempie

Highlighted
Ubiquiti Employee
Posts: 4,054
Registered: ‎01-11-2016
Kudos: 1204
Solutions: 29

Re: BUG [NanoHD|: broadcast and multicast leaking between VLANs

[ Edited ]

This issue has been resolved in nanoHD firmware 4.0.43 and higher (currently in beta: https://ui.com/beta ).

Want to try out new features or fixes before they're released as Stable? Sign up for Beta here: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Signup-for-Beta-Access
Having connectivity issues? See: https://help.ubnt.com/hc/en-us/articles/221029967-UniFi-Debugging-Intermittent-Connectivity-Issues-on-your-UAP
Reply