Scheduled maintenance: Community will be offline Monday June 17th, 1:00 AM - 6:00 AM (PT)
Reply
Member
Posts: 233
Registered: ‎06-19-2015
Kudos: 42
Solutions: 6
Accepted Solution

Can not adopt previously adopted USG - Error Unknown[11]

So I have a the following devices on a site having issues:

 

USG3P 4.4.36.5146617
UniFi AP-AC-Pro 4.0.21.9965

 

This is Layer 3 adopting using a FQDN, DNS works, trace route works to controller, router has public facing WAN IP. Controller has been updated and restarted. 

 

The controller is Windows Based 64bit Java Unifi Version - 5.10.23

Controller has plenty of free ram. 4gb min for Unifi

52 sites

172 Devices

800 clients

0 guest portals

 

The ap is still connected to the site and the uptime on the router is 624731 seconds which is about a week since last power failure. But the router will not adopt to the controller. 

 

On a side note I do not see it mentioned that if you have a AP online you can SSH from the controller webpage by clicking the device IP, this uses ASH "built in ssh" to log you into the AP and then SSH into other devics from the first AP. This is how I am connected to the USG3p remotely. I had to log into the router with the default user name and password ubnt/ubnt, which means it was probably user defaulted. I issue the set-inform command 

 

set-inform "https://FQDN.gotdns.com:8080/inform"

Does it matter with HTTP or HTTPS on the inform since it really isnt HTTP traffic right?

 

and I get

 

Last login: Wed May 15 20:32:23 2019 from 192.168.1.15
ubnt@ubnt:~$ info

Model:       UniFi-Gateway-3
Version:     4.4.36.5146617
MAC Address: fc:ec:da:HA:VE:FUN
IP Address:  XXX.XXX.XXX.XXX public IP
Hostname:    ubnt
Uptime:      625344 seconds

Status:      Unknown[11] (https://ZZZZZ.gotdns.com:8080/inform)

 


Accepted Solutions
Member
Posts: 233
Registered: ‎06-19-2015
Kudos: 42
Solutions: 6

Re: Can not adopt previously adopted USG - Error Unknown[11]

[ Edited ]

It adopted after being restarted and using the HTTP in the inform command, with the " double quotes ". 

It would be nice if the set-inform command just needed a FQDN or IP and the inform port. Why do I need "/inform" at the end of the command, isnt that always going to be part of the inform command?

I know these seem petty questions, but I want to understand why they are needed as part of that command so that I can better understand the command itself and how it works. Maybe I am asking to see to much behind the Unifi curtain.

Let me phrase it another way. If the inform command is using HTTP is makes sense, in some strange world I guess, to have the "http" in the command, but if the set-inform command is using its own protocol to do information exchange and the encryption of the inform, provioning, and statistical data why does it what is at the beginning of URL. 


Heres is a more tangible example, IE sucks right? In Internet Explorer you have to type the http:// infront of an ip address, lets say an IP camera @ 10.0.0.10, and if that IP camera uses a custom port for HTTP traffic you add the port at the end to tell the web browser which port to request the HTTP traffic on. So in IE the address would be "Http://10.0.0.10" and you would get data from port 80. But in chrome (which is a smarter browser) if you just type 10.0.0.10 into the search bar, or url input box you would get the port 80 traffic, and sometimes it will even try the HTTPS port 443 at the same time to see if 10.0.0.10 has a HTTPS webserver. The difference between IE and Chrome is that chrome know that you want web traffic from an ip address, that is why you are using a web browser. The unifi devices on the other hand are not using a web browser to do the inform command (hoepfully), so once again why does in need HTTP infront if it is not webtraffic. 


Also just tried issuing the following command, which worked (while local to the controller, same lan), no port, no http, no double quotes "

set-inform FQDN.gotdns.com

 

 

I will try the following commands from a remote site with a defaulted device, and see how little is actually needed. 

 

set-inform FQDN.gotdns.com

set-inform FQDN.gotdns.com:8080 set-inform FQDN.gotdns.com:8080/inform

 

View solution in original post


All Replies
SuperUser
Posts: 16,855
Registered: ‎06-18-2010
Kudos: 5422
Solutions: 1803

Re: Can not adopt previously adopted USG - Error Unknown[11]

set-inform http://ZZZZZ.gotdns.com:8080/inform

Not https:

No double quotes on the URL
Set a Frequency! Don't leave it on Auto!
Disable Uplink Connectivity Monitor
Always set-inform a Second time after Adopting
Senior Member
Posts: 25,886
Registered: ‎08-04-2017
Kudos: 4857
Solutions: 1284

Re: Can not adopt previously adopted USG - Error Unknown[11]

[ Edited ]

Hello @ncscomm,


Use a HTTP URL instead of HTTPS, you can't use HTTPS for the inform URL.

 

 

Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation Scripts | UniFi-VoIP Installation Scripts
USG-XG-8 • USG-4-PRO • USG
US-XG-16 • US-48-500W • US-24-POE-250W 2x • US-16-POE-150W 3x • US-24 • US-8-150W • US-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD 2x • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M • UAP-AC-M-PRO 2x
UAS-XG • UCK-G2-PLUS • UCK-G2 • UCK
Member
Posts: 233
Registered: ‎06-19-2015
Kudos: 42
Solutions: 6

Re: Can not adopt previously adopted USG - Error Unknown[11]

[ Edited ]

Why does HTTPS vs HTTP matter when using a custom port and not HTTP traffic, I assume that the inform traffic is not an HTTP session, I haven't ever looked into it that closely. 

can i do "set-inform [FQDN:8080/inform]" with out the HTTPS:// prefix or the HTTP:// prefix why is that important to the inform address?

Senior Member
Posts: 25,886
Registered: ‎08-04-2017
Kudos: 4857
Solutions: 1284

Re: Can not adopt previously adopted USG - Error Unknown[11]

Hello @ncscomm,

 

Because thats the way it work?...

 

 

Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation Scripts | UniFi-VoIP Installation Scripts
USG-XG-8 • USG-4-PRO • USG
US-XG-16 • US-48-500W • US-24-POE-250W 2x • US-16-POE-150W 3x • US-24 • US-8-150W • US-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD 2x • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M • UAP-AC-M-PRO 2x
UAS-XG • UCK-G2-PLUS • UCK-G2 • UCK
Member
Posts: 233
Registered: ‎06-19-2015
Kudos: 42
Solutions: 6

Re: Can not adopt previously adopted USG - Error Unknown[11]

Why does the S in https break the inform command? That seems like poor input sanitation.
Regular Member
Posts: 402
Registered: ‎12-07-2017
Kudos: 51
Solutions: 19

Re: Can not adopt previously adopted USG - Error Unknown[11]

Becouse http is port 8080 and 80, https 443 witch is used by the controller so not usable

 

 

there for they have choosen to use 8080

Unifi products i own.                                                              Feel free to join me on Discord and add me on Steam
Senior Member
Posts: 25,886
Registered: ‎08-04-2017
Kudos: 4857
Solutions: 1284

Re: Can not adopt previously adopted USG - Error Unknown[11]

[ Edited ]

Hello @ncscomm,

 

Because the INFORM uses port 8080...

The data between the controller and the UAP/USW/USG is encrypted anyway Man Wink

 

 

Regards,
Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation Scripts | UniFi-VoIP Installation Scripts
USG-XG-8 • USG-4-PRO • USG
US-XG-16 • US-48-500W • US-24-POE-250W 2x • US-16-POE-150W 3x • US-24 • US-8-150W • US-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD 2x • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M • UAP-AC-M-PRO 2x
UAS-XG • UCK-G2-PLUS • UCK-G2 • UCK
Senior Member
Posts: 3,205
Registered: ‎04-26-2016
Kudos: 1312
Solutions: 327

Re: Can not adopt previously adopted USG - Error Unknown[11]


@ncscomm wrote:
Why does HTTPS vs HTTP matter when using a custom port and not HTTP traffic

can i do "set-inform [FQDN:8080/inform]" with out the HTTPS:// prefix or the HTTP:// prefix why is that important to the inform address?

Because that is the way it works.

 

To me it looks like the USG is not able to resolve the FQDN. Is its WAN connection set up properly? DNS?

 

Can you ping the FQDN when logged in to the USG?

 

 

Member
Posts: 233
Registered: ‎06-19-2015
Kudos: 42
Solutions: 6

Re: Can not adopt previously adopted USG - Error Unknown[11]

yes but port 8080 isn't specifically http traffic, and it could be any port that I want to define in the controller settings, so the port number isn't tied to the HTTP part. So once again what script is the unifi "set-inform" command running or why is it *required* to have HTTP in front?
Senior Member
Posts: 25,886
Registered: ‎08-04-2017
Kudos: 4857
Solutions: 1284

Re: Can not adopt previously adopted USG - Error Unknown[11]

Hello @ncscomm,

 

It's designed like that, use HTTP and get ur device informed the right way.

 

 

Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation Scripts | UniFi-VoIP Installation Scripts
USG-XG-8 • USG-4-PRO • USG
US-XG-16 • US-48-500W • US-24-POE-250W 2x • US-16-POE-150W 3x • US-24 • US-8-150W • US-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD 2x • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M • UAP-AC-M-PRO 2x
UAS-XG • UCK-G2-PLUS • UCK-G2 • UCK
Member
Posts: 233
Registered: ‎06-19-2015
Kudos: 42
Solutions: 6

Re: Can not adopt previously adopted USG - Error Unknown[11]

[ Edited ]

It adopted after being restarted and using the HTTP in the inform command, with the " double quotes ". 

It would be nice if the set-inform command just needed a FQDN or IP and the inform port. Why do I need "/inform" at the end of the command, isnt that always going to be part of the inform command?

I know these seem petty questions, but I want to understand why they are needed as part of that command so that I can better understand the command itself and how it works. Maybe I am asking to see to much behind the Unifi curtain.

Let me phrase it another way. If the inform command is using HTTP is makes sense, in some strange world I guess, to have the "http" in the command, but if the set-inform command is using its own protocol to do information exchange and the encryption of the inform, provioning, and statistical data why does it what is at the beginning of URL. 


Heres is a more tangible example, IE sucks right? In Internet Explorer you have to type the http:// infront of an ip address, lets say an IP camera @ 10.0.0.10, and if that IP camera uses a custom port for HTTP traffic you add the port at the end to tell the web browser which port to request the HTTP traffic on. So in IE the address would be "Http://10.0.0.10" and you would get data from port 80. But in chrome (which is a smarter browser) if you just type 10.0.0.10 into the search bar, or url input box you would get the port 80 traffic, and sometimes it will even try the HTTPS port 443 at the same time to see if 10.0.0.10 has a HTTPS webserver. The difference between IE and Chrome is that chrome know that you want web traffic from an ip address, that is why you are using a web browser. The unifi devices on the other hand are not using a web browser to do the inform command (hoepfully), so once again why does in need HTTP infront if it is not webtraffic. 


Also just tried issuing the following command, which worked (while local to the controller, same lan), no port, no http, no double quotes "

set-inform FQDN.gotdns.com

 

 

I will try the following commands from a remote site with a defaulted device, and see how little is actually needed. 

 

set-inform FQDN.gotdns.com

set-inform FQDN.gotdns.com:8080 set-inform FQDN.gotdns.com:8080/inform

 

Highlighted
Regular Member
Posts: 402
Registered: ‎12-07-2017
Kudos: 51
Solutions: 19

Re: Can not adopt previously adopted USG - Error Unknown[11]

Oh sweet  didnt know that   thanks Man Happy
@AmazedMender16 wrote:

Hello @ncscomm,

 

Because the INFORM uses port 8080...

The data between the controller and the UAP/USW/USG is encrypted anyway Man Wink

 

 

Regards,
Glenn R.


 

Unifi products i own.                                                              Feel free to join me on Discord and add me on Steam
Reply