Reply
New Member
Posts: 7
Registered: ‎10-27-2017

Can't adopt UniFi AP-AC-LR after first time

[ Edited ]

Hi,

 

I can't reconnect to the AP after the initial setup.

Every time i want to change settings, i have to reset the AP to factory settings and go through the initial setup, and it adopts and connects.

 

But if i close the controller, and launch it again, its stuck on adpoting/disconnected loop.

I can see it in the discovery tool and send commands to it, I have wifi access, i can ssh into the AP, but it just won't adopt.

 

no firewalls.

 

Tried ssh -> inform, doesn't help.

 

I can't factory reset it every time i want to see/change something.

what to do?

 

UniFi AP-AC-LR

Version3.9.3.7537
Board Revision17
 
Controller 5.6.19

 

SuperUser
Posts: 13,850
Registered: ‎10-06-2013
Kudos: 4640
Solutions: 1048

Re: Ca't adopt UniFi AP-AC-LR after first time

[ Edited ]

What is the controller on? A computer that is connected to the LAN with a cable is the ideal way. Don't use wifi to run controller.

UK Comms & Links Engineer.


Come on you lot, Feel free to 'Mark as Solution' At least click the Kudos button. Thanks.


Top Solution Authors Leaderboard
New Member
Posts: 7
Registered: ‎10-27-2017

Re: Ca't adopt UniFi AP-AC-LR after first time

[ Edited ]

PC & AP both connected to EdgeRouter via cable.

SuperUser
Posts: 13,850
Registered: ‎10-06-2013
Kudos: 4640
Solutions: 1048

Re: Can't adopt UniFi AP-AC-LR after first time

So an ER router with both the AP and PC in the same subnet?

UK Comms & Links Engineer.


Come on you lot, Feel free to 'Mark as Solution' At least click the Kudos button. Thanks.


Top Solution Authors Leaderboard
New Member
Posts: 7
Registered: ‎10-27-2017

Re: Can't adopt UniFi AP-AC-LR after first time

yes.

SuperUser
Posts: 20,402
Registered: ‎09-17-2013
Kudos: 5142
Solutions: 1458

Re: Can't adopt UniFi AP-AC-LR after first time

PC doesn't happen to have a WLAN card in it right?

also, if the IP address changes on the controller, things can get funny.
New Member
Posts: 7
Registered: ‎10-27-2017

Re: Can't adopt UniFi AP-AC-LR after first time

PC doesnt have wireless.

IP didnt change on any component, all I did was close the controller and immediately start the program again.

Leads me to believe something is wrong on the controller/AP side.

New Member
Posts: 7
Registered: ‎10-27-2017

Re: Can't adopt UniFi AP-AC-LR after first time

[ Edited ]

It seems that adopting from the controller dashboard doesn't work.

Even after factory reset to the AP, when it says the AP is pending, i click adopt but same results.

 

Only when i freshly install the controller, during initial setup when it asks to cofigure devices and setup their SSID is when it able to adopt the AP.

 

The problem is on the controller side as if i restart the AP it does reconnect, only if i restart the controller it cannot adopt anymore.

New Member
Posts: 3
Registered: ‎04-09-2016

Re: Can't adopt UniFi AP-AC-LR after first time

Did you find a solution.  I upgraded my controller to 5.9.22 yesterday,  Trying to adopt a brand new UAP-AC-Pro and I'm stuck in the same Adopting/Disconnected loop you saw.

 

Also found another issue.  I have an AP that from a remote site that is now plugged in on my local office network. In the controller, I then moved the AP from the remote site to my office (local) site and it shows "adoption failed".  Strange thing is it's still broadcasting the SSIDs of the original remote site and I can connect and get internet access on those SSIDs.  I just can't manage the AP at all.

 

Hope you found a solution.

New Member
Posts: 7
Registered: ‎10-27-2017

Re: Can't adopt UniFi AP-AC-LR after first time

[ Edited ]

I didn't find a solution to my problem.

I have to re-install the controller each time to adpot the AP.

 

But then again... the controller can't even be found on the ubiquiti UniFi download page, only in the blog posts.

 

I updated to 5.6.24 and after install it immediately connected, restarted the controller -> can't adopt again.

something is broken with that controller software.

Highlighted
New Member
Posts: 7
Registered: ‎10-30-2018

Re: Can't adopt UniFi AP-AC-LR after first time

[ Edited ]

Hi,

 

I'm having the same issue: The AP shows up on the Devices -list only after a fresh install of the controller (laptop) or when the AP connects to a controller which it has not been connected to before.  Without changing anything else, If I reboot the AP (before adopting) it wont show up on the Devices -list anymore. I can SSH into the AP.

 

Controller version: 5.9.29

I'm connected over VPN. My router has port forward: unifi -> <controller_ip> 

 

AP SSH, info:

info.jpg

 

If I manually run the set-inform command (after AP reboot) with a direct IP instead of "unifi:8080", the AP does not appear on the controller:

manual.JPG

 

Resetting the AP to factory settings does not have an effect.

 

Controller Server log:

 

 At [2018-12-13 12:58:00,550] you can see that the first time inform has reached the server but after this there is no infrom logs despite of running the set-inform command several times from the APs shell.

 

[2018-12-13 12:57:24,870] <launcher-ui> INFO  launcher - Initializing UniFi Controller ...
[2018-12-13 12:57:33,160] <launcher-monitor> INFO  launcher - Starting UniFi Controller ...
[2018-12-13 12:57:38,444] <launcher> INFO  system - ======================================================================
[2018-12-13 12:57:38,444] <launcher> INFO  system - UniFi 5.9.29 (build atag_5.9.29_11384 - release) is started
[2018-12-13 12:57:38,444] <launcher> INFO  system - ======================================================================
[2018-12-13 12:57:38,444] <launcher> INFO  system - BASE dir:C:\Users\mikael\Ubiquiti UniFi
[2018-12-13 12:57:38,757] <launcher> INFO  system - Current System IP: 192.168.10.141
[2018-12-13 12:57:38,757] <launcher> INFO  system - Hostname: smartcart-01
[2018-12-13 12:57:40,677] <launcher> INFO  db     - waiting for db connection...
[2018-12-13 12:57:41,192] <launcher> INFO  db     - Connecting to mongodb://127.0.0.1:27117
[2018-12-13 12:57:45,511] <launcher> INFO  db     - Connecting to mongodb://127.0.0.1:27117
[2018-12-13 12:57:48,098] <launcher> INFO  webrtc - WebRTC library version: EvoStream Media Server (www.evostream.com) build v2.0.12 - Gladiator - (built for Windows-7-x86_64 on 2018-06-03T09:50:40.000) OpenSSL version: 1.0.2n compiled on machine: Compatible Windows
[2018-12-13 12:57:48,594] <launcher-ui> INFO  launcher - UniFi Controller (5.9.29) started.
[2018-12-13 12:58:00,024] <webapi-59> INFO  event  - [event] Admin[mikael] log in from 0:0:0:0:0:0:0:1
[2018-12-13 12:58:00,550] <inform-39> INFO  event  - [event] AP[78:8a:20:f3:2f:a0] was discovered and waiting for adoption
[2018-12-13 12:58:34,153] <db-server> INFO  db     - DbServer stopped
[2018-12-13 12:59:14,208] <launcher-ui> INFO  launcher - Initializing UniFi Controller ...
[2018-12-13 12:59:22,488] <launcher-monitor> INFO  launcher - Starting UniFi Controller ...
[2018-12-13 12:59:27,874] <launcher> INFO  system - ======================================================================
[2018-12-13 12:59:27,874] <launcher> INFO  system - UniFi 5.9.29 (build atag_5.9.29_11384 - release) is started
[2018-12-13 12:59:27,874] <launcher> INFO  system - ======================================================================
[2018-12-13 12:59:27,874] <launcher> INFO  system - BASE dir:C:\Users\mikael\Ubiquiti UniFi
[2018-12-13 12:59:28,252] <launcher> INFO  system - Current System IP: 192.168.10.141
[2018-12-13 12:59:28,252] <launcher> INFO  system - Hostname: smartcart-01
[2018-12-13 12:59:29,886] <launcher> INFO  db     - waiting for db connection...
[2018-12-13 12:59:30,401] <launcher> INFO  db     - Connecting to mongodb://127.0.0.1:27117
[2018-12-13 12:59:34,186] <launcher> INFO  db     - Connecting to mongodb://127.0.0.1:27117
[2018-12-13 12:59:36,980] <launcher> INFO  webrtc - WebRTC library version: EvoStream Media Server (www.evostream.com) build v2.0.12 - Gladiator - (built for Windows-7-x86_64 on 2018-06-03T09:50:40.000) OpenSSL version: 1.0.2n compiled on machine: Compatible Windows
[2018-12-13 12:59:37,685] <launcher-ui> INFO  launcher - UniFi Controller (5.9.29) started.
[2018-12-13 13:00:29,565] <webapi-67> INFO  event  - [event] Admin[mikael] log in from 0:0:0:0:0:0:0:1
[2018-12-13 13:00:41,673] <autoupdate-check> INFO  system - update site - timeout
[2018-12-13 14:15:37,724] <check-network-interfaces> INFO  system - Interface changed. 4 found: [{ "ip" : "192.168.10.141" , "name" : "eth3"}, { "ip" : "192.168.56.1" , "name" : "eth5"}, { "ip" : "192.168.10.95" , "name" : "wlan0"}, { "ip" : "192.168.104.1" , "name" : "eth6"}]
[2018-12-13 14:46:37,714] <check-network-interfaces> INFO  system - Interface changed. 5 found: [{ "ip" : "192.168.10.141" , "name" : "eth3"}, { "ip" : "192.168.56.1" , "name" : "eth5"}, { "ip" : "192.168.10.95" , "name" : "wlan0"}, { "ip" : "192.168.104.1" , "name" : "eth6"}, { "ip" : "192.168.1.50" , "name" : "ppp2"}]

 

Any suggestions what to try to fix this?

Senior Member
Posts: 21,357
Registered: ‎08-04-2017
Kudos: 4028
Solutions: 1030

Re: Can't adopt UniFi AP-AC-LR after first time

Hello @mikaelhirn,

 

You forgot the port when doing set-inform, please run:

set-inform http://192.168.1.50:8080/inform

 

 

Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation Scripts | UniFi-VoIP Installation Scripts
USG-XG-8 • USG-4-PRO • USG
US-XG-16 • US-48-500W • US-24-POE-250W 2x • US-16-POE-150W 3x • US-24 • US-8-150W • US-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD 2x • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M • UAP-AC-M-PRO 2x
UAS-XG • UCK-G2-PLUS • UCK-G2 • UCK
New Member
Posts: 7
Registered: ‎10-30-2018

Re: Can't adopt UniFi AP-AC-LR after first time

hi @AmazedMender16,

 

Thanks! I had indeed forgotten the port. After adding the port the AP showed up on the controller:

[2018-12-14 08:54:36,007] <inform-112> INFO  event  - [event] AP[78:8a:20:f3:2f:a0] was discovered and waiting for adoption

 

 

Back to the original problem. Why doesn't the AP show up on the controller after the first inform? On the first time the controller shows up by default (inform sent to: http://unifi:8080/inform). I have hundreds of APs to configure and I'm not willing to SSH into each of those to run set-inform to get them to appear on the controller server.

Senior Member
Posts: 21,357
Registered: ‎08-04-2017
Kudos: 4028
Solutions: 1030

Re: Can't adopt UniFi AP-AC-LR after first time

Hello @mikaelhirn,

 

Make sure your firewall is turned off, have you tried restarting the UAPs to see if they showup?

You could create an A record for unifi to point to the server.

 

 

Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation Scripts | UniFi-VoIP Installation Scripts
USG-XG-8 • USG-4-PRO • USG
US-XG-16 • US-48-500W • US-24-POE-250W 2x • US-16-POE-150W 3x • US-24 • US-8-150W • US-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD 2x • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M • UAP-AC-M-PRO 2x
UAS-XG • UCK-G2-PLUS • UCK-G2 • UCK
New Member
Posts: 7
Registered: ‎10-30-2018

Re: Can't adopt UniFi AP-AC-LR after first time

[ Edited ]

@AmazedMender16

 

>> Make sure your firewall is turned off, have you tried restarting the UAPs to see if they showup?

 

The firewall is off and I have tried booting the UAP.

 

>> You could create an A record for unifi to point to the server.

 

 This also exists.

Senior Member
Posts: 21,357
Registered: ‎08-04-2017
Kudos: 4028
Solutions: 1030

Re: Can't adopt UniFi AP-AC-LR after first time

Hello @mikaelhirn,

 

Well the INFO command output says the UAP can't resolve the hostname...

 

 

Regardsm

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation Scripts | UniFi-VoIP Installation Scripts
USG-XG-8 • USG-4-PRO • USG
US-XG-16 • US-48-500W • US-24-POE-250W 2x • US-16-POE-150W 3x • US-24 • US-8-150W • US-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD 2x • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M • UAP-AC-M-PRO 2x
UAS-XG • UCK-G2-PLUS • UCK-G2 • UCK
New Member
Posts: 7
Registered: ‎10-30-2018

Re: Can't adopt UniFi AP-AC-LR after first time

[ Edited ]

Hi @AmazedMender16

 

really appreciate your help here!

 

>> Well the INFO command output says the UAP can't resolve the hostname...

 

Yes, and this is after the first time the UAP did appear on the controller.  When unable to resolve ping unifi works ok.

 

To give you the flow:

 

1) A fresh installation of controller on a laptop.

2) UAP with factory defaults powered up >> informs unifi:8080 

3) UAP shows up on controller. The UAP is NOT adopted at this point.

4) I boot up the UAP and it does not show up on the controller any more after this. None of the settings have been changed.

5) Re-install of the controller on a laptop.

6) UAP with factory defaults powered up >> informs unifi:8080 

7) UAP shows up on controller and is ready for adoption.

Senior Member
Posts: 21,357
Registered: ‎08-04-2017
Kudos: 4028
Solutions: 1030

Re: Can't adopt UniFi AP-AC-LR after first time

Hello @mikaelhirn,

 

So when you boot the UAP for a second time it doesn't showup anymore?

Why don't you adopt it at the first time?

 

 

Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation Scripts | UniFi-VoIP Installation Scripts
USG-XG-8 • USG-4-PRO • USG
US-XG-16 • US-48-500W • US-24-POE-250W 2x • US-16-POE-150W 3x • US-24 • US-8-150W • US-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD 2x • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M • UAP-AC-M-PRO 2x
UAS-XG • UCK-G2-PLUS • UCK-G2 • UCK
New Member
Posts: 7
Registered: ‎10-30-2018

Re: Can't adopt UniFi AP-AC-LR after first time

Hi, @AmazedMender16

 

>> Why don't you adopt it at the first time?

 

We usually do. I would just like to understand what is actually causing this behavior. Is the UAP actually sending any inform message to the controller after the first time? My feeling at the moment is that the UAP is not sending anything after the first time.

New Member
Posts: 7
Registered: ‎10-30-2018

Re: Can't adopt UniFi AP-AC-LR after first time

Any reason for this?

Reply