Reply
New Member
Posts: 8
Registered: ‎04-24-2016

Client connects to AP but no Internet, works fine with other APs on same LAN

I have USG 4.4.36.5146617

8 Port Managed Switch 4.0.21.9965

3 x AC Pro access point 4.0.21.9965

 

Everything is fine except one specific client (my Wife's iPad) won't connect to one of the AC Pro access points (or more accuratley it connects but cant communciatre on the network). It connects to the other two  APs just fine, and all other clients connect to all 3 AC pros without any issue. This is a new issue in the last two weeks, prior to this there was no issues at all.

 

When I look at the logs I am seeing a DHCP Timeout/Failure - which makes some sense because the iPad is not getting a DHCP lease. I have tried giving it a manual IP address in the same range, but that doesnt work. 

 

What can I try to try and resolve this?

Is there more detailed log files I can view to help?

 

Thanks,

 

Gary

Senior Member
Posts: 2,770
Registered: ‎01-29-2015
Kudos: 449
Solutions: 116

Re: Client connects to AP but no Internet, works fine with other APs on same LAN

You can SSH into the AP and watch the logs:

tail -f /var/log/messages

 

Can you please post a screenshot of this?
Settings > Maintenance > Show System Config

 

If you have turned on any advanced features such as bandwidth steering, fast roaming etc. on that AP, turn it off for now. If you have enabled Auto-Optimize Network, turn that off too.

New Member
Posts: 8
Registered: ‎04-24-2016

Re: Client connects to AP but no Internet, works fine with other APs on same LAN

Screenshot 2019-03-06 at 22.35.56.png

New Member
Posts: 8
Registered: ‎04-24-2016

Re: Client connects to AP but no Internet, works fine with other APs on same LAN

It is the Upstairs bedroom AP that is the one that the iPad cannot connect to.

Senior Member
Posts: 2,770
Registered: ‎01-29-2015
Kudos: 449
Solutions: 116

Re: Client connects to AP but no Internet, works fine with other APs on same LAN

When you have multiple APs, you should manually tune them to the most clear channels available after doing a scan of the RF environment with each AP. Once you know the clear channels, you need to set them to non-overlapping channels. For example, your 2.4 radios should be on 1, 6, or 11 and none of them on the same channel. Same for your 5ghz, they need to be on separate channels.

 

You can also turn off connectivity monitor in Settings > Site. That's only needed for wireless uplinks.

Senior Member
Posts: 21,509
Registered: ‎08-04-2017
Kudos: 4055
Solutions: 1044

Re: Client connects to AP but no Internet, works fine with other APs on same LAN

Hello @gscull,

 

Do you have the Auto-Optimize Network features enabled?

Settings > Site > Auto-Optimize Network

 

Have you tried swapping the UAPs?

Are you using any VLANs?

 

 

Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation Scripts | UniFi-VoIP Installation Scripts
USG-XG-8 • USG-4-PRO • USG
US-XG-16 • US-48-500W • US-24-POE-250W 2x • US-16-POE-150W 3x • US-24 • US-8-150W • US-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD 2x • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M • UAP-AC-M-PRO 2x
UAS-XG • UCK-G2-PLUS • UCK-G2 • UCK
New Member
Posts: 8
Registered: ‎04-24-2016

Re: Client connects to AP but no Internet, works fine with other APs on same LAN

Hi RobbieH, 

 

They are now maunally set to clear, non-overlapping chanels on both 2.4 and 5GHz radios.

 

Connectivity montior is off. 

 

I will check the logs tonight when I get home while trying to connect.

 

New Member
Posts: 8
Registered: ‎04-24-2016

Re: Client connects to AP but no Internet, works fine with other APs on same LAN

[ Edited ]

Hi Glenn,

 

Thanks for yuor input. Auto-Optimize Network was on, that is now off, per RobbieH's earlier suggestion. I havent tried swapping the APs yet, I can try that tonight. 

 

I am not using any VLANs

 

Thanks,

 

Gary

Senior Member
Posts: 21,509
Registered: ‎08-04-2017
Kudos: 4055
Solutions: 1044

Re: Client connects to AP but no Internet, works fine with other APs on same LAN

Hello @gscull,

 

Keep us posted!

 

 

Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation Scripts | UniFi-VoIP Installation Scripts
USG-XG-8 • USG-4-PRO • USG
US-XG-16 • US-48-500W • US-24-POE-250W 2x • US-16-POE-150W 3x • US-24 • US-8-150W • US-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD 2x • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M • UAP-AC-M-PRO 2x
UAS-XG • UCK-G2-PLUS • UCK-G2 • UCK
New Member
Posts: 8
Registered: ‎04-24-2016

Re: Client connects to AP but no Internet, works fine with other APs on same LAN

Screen shot of log while the ipad is trying to connect MAC address is 34:12:98:78:88:9B

It doesnt really shed any more light on the situation to me at least.

 

Screenshot 2019-03-07 at 21.28.50.png

Senior Member
Posts: 21,509
Registered: ‎08-04-2017
Kudos: 4055
Solutions: 1044

Re: Client connects to AP but no Internet, works fine with other APs on same LAN

Hello @gscull,

 

It does seem to get an IP address and then an APIPA address.

 

 

Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation Scripts | UniFi-VoIP Installation Scripts
USG-XG-8 • USG-4-PRO • USG
US-XG-16 • US-48-500W • US-24-POE-250W 2x • US-16-POE-150W 3x • US-24 • US-8-150W • US-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD 2x • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M • UAP-AC-M-PRO 2x
UAS-XG • UCK-G2-PLUS • UCK-G2 • UCK
New Member
Posts: 8
Registered: ‎04-24-2016

Re: Client connects to AP but no Internet, works fine with other APs on same LAN

Hi Glenn,

 

Yes, its weird! The question is why? Why only this client? Why only this specifc AP? Why did it work previously and not recently? The logs dont seem to provide any clues either. 

 

I am at the end of my knowledge here. I might try a factory reset and re-adopt the AP see if that helps.

 

Thanks,

 

Gary

Senior Member
Posts: 21,509
Registered: ‎08-04-2017
Kudos: 4055
Solutions: 1044

Re: Client connects to AP but no Internet, works fine with other APs on same LAN

Hello @gscull.

 

Give that a shot..

Also make sure your DHCP pool is not exhausted.

 

Did swapping the UAPs around do anything?

 


Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation Scripts | UniFi-VoIP Installation Scripts
USG-XG-8 • USG-4-PRO • USG
US-XG-16 • US-48-500W • US-24-POE-250W 2x • US-16-POE-150W 3x • US-24 • US-8-150W • US-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD 2x • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M • UAP-AC-M-PRO 2x
UAS-XG • UCK-G2-PLUS • UCK-G2 • UCK
New Member
Posts: 8
Registered: ‎04-24-2016

Re: Client connects to AP but no Internet, works fine with other APs on same LAN

HI,

 

Nothing I have tried has worked. Swapping APs gives me the same results. DHCP pool has plenty of leases.

 

I did a factory reset of the AP and re-adopted it, but I am still seeing the issue.

 

At a loss now!

Senior Member
Posts: 2,674
Registered: ‎04-21-2015
Kudos: 396
Solutions: 104

Re: Client connects to AP but no Internet, works fine with other APs on same LAN

[ Edited ]

@gscull wrote:

Why did it work previously and not recently? The logs dont seem to provide any clues either. 


The logs clearly indicate DHCP (DORA process) failury: ip_failures: 1

 

Get the tcpdump/PCAP while running the below command from your PC:

 

plink -batch -l ubnt -pw ubnt -P 22 192.168.1.12 /usr/sbin/tcpdump -i eth0 -w - not port 22 | "c:\Program Files\Wireshark\Wireshark.exe" -k -i -

 

Change username/password to the one that you use for the AP SSH access. The above command should start PCAP on your local PC, then attempt to connect with your device. After the failure save the PCAP and attach here.

Thanks,
Myky
CWNA
--------------------------------------------------------------------------------------------------------------------------------------------------
Don`t blame the device as it`s always doing what you have asked it to do, this is not always the same as what you want.
Highlighted
Senior Member
Posts: 21,509
Registered: ‎08-04-2017
Kudos: 4055
Solutions: 1044

Re: Client connects to AP but no Internet, works fine with other APs on same LAN

Hello @gscull,

 

So when swapping the UAPs the problems move?

 

 

Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation Scripts | UniFi-VoIP Installation Scripts
USG-XG-8 • USG-4-PRO • USG
US-XG-16 • US-48-500W • US-24-POE-250W 2x • US-16-POE-150W 3x • US-24 • US-8-150W • US-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD 2x • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M • UAP-AC-M-PRO 2x
UAS-XG • UCK-G2-PLUS • UCK-G2 • UCK
Reply