Reply
Ubiquiti Employee
Posts: 3,490
Registered: ‎01-11-2016
Kudos: 1064
Solutions: 26

Re: Connectivity Problems - UAP, UAP-LR, UAP-Pro, UAP-Outdoor5, UAP-Outdoor, UAP-Outdoor+

@MagicLink These improvements are not applicable to the UAP-AC v2, only the UAP, UAP-Pro, UAP-LR, UAP-Outdoor+, and the like (gen1 legacy devices).

Want to try out new features or fixes before they're released as Stable? Sign up for Beta here: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Signup-for-Beta-Access
Having connectivity issues? See: https://help.ubnt.com/hc/en-us/articles/221029967-UniFi-Debugging-Intermittent-Connectivity-Issues-on-your-UAP
New Member
Posts: 32
Registered: ‎05-19-2016
Kudos: 7

Re: Connectivity Problems - UAP, UAP-LR, UAP-Pro, UAP-Outdoor5, UAP-Outdoor, UAP-Outdoor+

@UBNT-jeff What do you mean with legacy devices? They are still listed on your website (https://www.ubnt.com/unifi/unifi-ap-outdoor/) and we are still buying them...

Ubiquiti Employee
Posts: 7,528
Registered: ‎03-17-2015
Kudos: 4818
Solutions: 197

Re: Connectivity Problems - UAP, UAP-LR, UAP-Pro, UAP-Outdoor5, UAP-Outdoor, UAP-Outdoor+


MagicLink wrote:

@UBNT-Brandon I let it soak and report here later if any troubles come back

I think the issue appear with the firmware bundled with 4.8.14 except if the 3.3.17 bundled with 4.8.12 i'm testing 'll tell me that's not the case Man Happy

 


Thanks, looking forward to the results.

Want to try out new features or fixes before they're released as Stable? Sign up for Beta here: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Signup-for-Beta-Access
Ubiquiti Employee
Posts: 3,490
Registered: ‎01-11-2016
Kudos: 1064
Solutions: 26

Re: Connectivity Problems - UAP, UAP-LR, UAP-Pro, UAP-Outdoor5, UAP-Outdoor, UAP-Outdoor+

@sahaja-it-team Sorry, probably the wrong terminology here. They are older 11n-only technology, but we still fully support them.

 

Want to try out new features or fixes before they're released as Stable? Sign up for Beta here: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Signup-for-Beta-Access
Having connectivity issues? See: https://help.ubnt.com/hc/en-us/articles/221029967-UniFi-Debugging-Intermittent-Connectivity-Issues-on-your-UAP
New Member
Posts: 32
Registered: ‎05-19-2016
Kudos: 7

Re: Connectivity Problems - UAP, UAP-LR, UAP-Pro, UAP-Outdoor5, UAP-Outdoor, UAP-Outdoor+

@UBNT-BenBuckley OK, I just installed the experimental FW on 2 Outdoor+ in an area where we experieneced internet but not wifi drops and missing SSIDs. I'll let them soak for a couple of days and let you know.

Ubiquiti Employee
Posts: 1,001
Registered: ‎12-16-2015
Kudos: 262
Solutions: 8

Re: Connectivity Problems - UAP, UAP-LR, UAP-Pro, UAP-Outdoor5, UAP-Outdoor, UAP-Outdoor+

@-EG-  yes you should use new-driver7

If you'd like to try our latest features, consider signing up for beta: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Sign-Up-for-Beta-Access

If you're trying to debug a network issue, take a look at this help article: https://help.ubnt.com/hc/en-us/articles/221029967-UniFi-Debugging-Intermittent-Connectivity-Issues-on-your-UAP
Regular Member
Posts: 439
Registered: ‎07-05-2012
Kudos: 71
Solutions: 9

Re: Connectivity Problems - UAP, UAP-LR, UAP-Pro, UAP-Outdoor5, UAP-Outdoor, UAP-Outdoor+

[ Edited ]

Little update;

I now have success with jeff-gen1-10.2.-1.-1.3 and with driver7 (feature-gen1-10.2.6) on two different PRO's. No memory leaks and no random disconnects. I haven't tested the difference between the versions, so this is all based on user feedback (and of course monitoring memory stability).

 

I do get these a lot on jeff-gen1-10.2.-1.-1.3

user.err syslog: libubnt.get_ieee80211req_sta_info(): IOCTL_STA_INFO2 failed: No such file or directory
Ubiquiti Employee
Posts: 7,528
Registered: ‎03-17-2015
Kudos: 4818
Solutions: 197

Re: Connectivity Problems - UAP, UAP-LR, UAP-Pro, UAP-Outdoor5, UAP-Outdoor, UAP-Outdoor+

Thanks for the feedback @jml !

Want to try out new features or fixes before they're released as Stable? Sign up for Beta here: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Signup-for-Beta-Access
New Member
Posts: 10
Registered: ‎05-21-2016
Kudos: 2

Re: Connectivity Problems - UAP, UAP-LR, UAP-Pro, UAP-Outdoor5, UAP-Outdoor, UAP-Outdoor+

I dont know if this help someone downgrade/costum upgrade. But in my own experience, straightly downgrade/using experimental firmware without forgeting/factory reset UAP, will not working, the firmware not changed.

Forget the UAP first, then it will reset to factory.
Adopt it back, then do "custom upgrade" to downgrade/flash experiment fw.

And for the report, using experimental firmware5 for 27 days now. But since wifi is only for backup connection, I cannot report much here. Some client still reporting no internet issue, but I told them to use cable connection. On the next day, wireless run normal again.

Since wifi is not a priority again, I can help with testing new firmware. Provide me with any command in ssh, or any log that I must seek. Maybe this can help others too.
New Member
Posts: 11
Registered: ‎05-09-2016

Re: Connectivity Problems - UAP, UAP-LR, UAP-Pro, UAP-Outdoor5, UAP-Outdoor, UAP-Outdoor+

[ Edited ]

@UBNT-BenBuckley @UBNT-jeff
Good news. I upgraded my UAP-LR with new-driver7 and no issue was observed in 40+ hours.

I can give you dmesg/messages logs if you need it, but at moment I'm unable to attach it, I get an error "The contents of the attachment doesn't match its file type."

New Member
Posts: 32
Registered: ‎05-19-2016
Kudos: 7

Re: Connectivity Problems - UAP, UAP-LR, UAP-Pro, UAP-Outdoor5, UAP-Outdoor, UAP-Outdoor+

I installed the driver7 FW on three Outdoor+ and and UAP-Pro now. On the Outdoor+ it looks fine so far. I will interview users later in the day. But on the AP-Pro something bad happened: Usually we were experiencing several internet drops during the day while wifi was connected. What happend today for the first time was that the UAP-Pro rebooted itself Man Sad I installed the update around 7:30am and around 9:30am we experienced the first reboot. I'll keep you posted.

New Member
Posts: 10
Registered: ‎05-21-2016
Kudos: 5
Solutions: 1

Re: Connectivity Problems - UAP, UAP-LR, UAP-Pro, UAP-Outdoor5, UAP-Outdoor, UAP-Outdoor+

I have a 3*UAP residential network (not ZHO, separate channels, same ssid, -75db min rssi) and had previously had the connected but not internet problem frequently with iOS devices. Having tested the various options and finding driver5 OK and 3.3.rates the best I upgraded to latest release 3.7.5 with 5.0.6 controller a couple of weeks ago and it has all been running fine with no sign of the issue.

 

In the interests of testing the latest I installed driver7 over the weekend to see whether it is better or worse.

 

One initial observation is that it adds about 10ms rtt to ping times on average using speedtest.net. Throughput seems OK. Quite consistently longer delays with iphone or mac. From average 20ms rtt to 30ms rtt, not bad but worse than 3.7.5.

 

I have not noticed the connected to wifi but not the internet problem with driver7, however I did notice a period of about 20 minutes where the client (iPhone 6+s, latest iOS 9.3.2) should have been connected to wifi but was in fact not, but instead was over mobile. Device was active and downloading some big files from iTunes.

 

No-one else was using the network actively at the time so I extracted the logs to see what might have happened.

 

Log from closer AP which I would have expected to be connected to seems to show the phone momentarily leave and then rejoin:-

 

Jun 18 08:08:05 Topfloorlanding daemon.info hostapd: ath0: STA 0c:d7:46:62:7a:f0 IEEE 802.11: sta_stats
Jun 18 08:08:05 Topfloorlanding daemon.info hostapd: ath0: STA 0c:d7:46:62:7a:f0 IEEE 802.11: disassociated
Jun 18 08:08:05 Topfloorlanding user.info syslog: wevent.ubnt_custom_event(): EVENT_STA_LEAVE ath0: 0c:d7:46:62:7a:f0 / 0
Jun 18 08:08:05 Topfloorlanding daemon.info hostapd: ath0: STA 0c:d7:46:62:7a:f0 IEEE 802.11: associated
Jun 18 08:08:05 Topfloorlanding user.info syslog: wevent.ubnt_custom_event(): EVENT_STA_JOIN ath0: 0c:d7:46:62:7a:f0 / 4
Jun 18 08:08:05 Topfloorlanding daemon.info hostapd: ath0: STA 0c:d7:46:62:7a:f0 RADIUS: starting accounting session 57641D91-00000059
Jun 18 08:08:05 Topfloorlanding daemon.info hostapd: ath0: STA 0c:d7:46:62:7a:f0 WPA: pairwise key handshake completed (RSN)

 

Further away AP, same iphone joins just before the events above, then is kicked off by min RSSI about 10 minutes later:-

 

Jun 18 08:07:59 LoungeRoom daemon.info hostapd: ath0: STA 0c:d7:46:62:7a:f0 IEEE 802.11: associated
Jun 18 08:07:59 LoungeRoom user.info syslog: wevent.ubnt_custom_event(): EVENT_STA_JOIN ath0: 0c:d7:46:62:7a:f0 / 4
Jun 18 08:07:59 LoungeRoom daemon.info hostapd: ath0: STA 0c:d7:46:62:7a:f0 RADIUS: starting accounting session 576419C7-00000083
Jun 18 08:07:59 LoungeRoom daemon.info hostapd: ath0: STA 0c:d7:46:62:7a:f0 WPA: pairwise key handshake completed (RSN)
Jun 18 08:17:49 LoungeRoom user.info syslog: stamgr.kick_sta(): kick-sta-on 0c:d7:46:62:7a:f0 ath0 (reason:1)
Jun 18 08:17:50 LoungeRoom user.warn kernel: [56377.074000] ieee80211_ioctl_kickmac[14744]
Jun 18 08:17:50 LoungeRoom daemon.info hostapd: ath0: STA 0c:d7:46:62:7a:f0 IEEE 802.11: disassociated
Jun 18 08:17:50 LoungeRoom user.info syslog: wevent.ubnt_custom_event(): EVENT_STA_LEAVE ath0: 0c:d7:46:62:7a:f0 / 0

 

During this time the phone which was seemingly connected to both APs was actually connected over mobile and downloaded GB of data, I only noticed this when getting the "you've used 80% of your monthly data" text.

 

This may be simply my misunderstanding of how the UAPs work together but net effect for the end user was no wifi connection for the iPhone. It could also have been iOS deciding that the WiFi was too bad and reverting to mobile as I have iOS WiFi assist option turned on, though the log for that claims only 74.4MB whereas this was >1GB so I don't think so.

 

I've now put the UAPs back to 3.7.5 for the working week.

 

I would be interested to know if this has been seen elsewhere or whether it is unrelated to driver7. I've certainly not noticed it on 3.7.5.

 

New Member
Posts: 32
Registered: ‎05-19-2016
Kudos: 7

Re: Connectivity Problems - UAP, UAP-LR, UAP-Pro, UAP-Outdoor5, UAP-Outdoor, UAP-Outdoor+

[ Edited ]

@UBNT-Brandon

 

AP-Pro rebootet again at 11:10am

 

History:

07:30am Installation of driver7 FW

09:30am Reboot

11:10am Reboot

 

Note: Before experimental FW there was no rebooting!

Emerging Member
Posts: 51
Registered: ‎02-02-2014
Kudos: 5
Solutions: 1

Re: Connectivity Problems - UAP, UAP-LR, UAP-Pro, UAP-Outdoor5, UAP-Outdoor, UAP-Outdoor+

@UBNT-Brandon

 

No users reports any troubles since Wednesday and i didn't have to reboot it. But there is not much people today too. I think the issue occurs when i have a lot of people connected to the UAPs but not sure. I'll be sure this Wednesday as there 'll be users in the classroom next to one of these UAP which had the problem.

Ubiquiti Employee
Posts: 1,001
Registered: ‎12-16-2015
Kudos: 262
Solutions: 8

Re: Connectivity Problems - UAP, UAP-LR, UAP-Pro, UAP-Outdoor5, UAP-Outdoor, UAP-Outdoor+

@sahaja-it-team Thanks for the feedback here.  In the lab, I've seen a couple of random reboots, although I have not been able to reproduce it reliably.

 

What features are you using, and how many clients do you typically have connected to the AP?

 

If you'd like to try our latest features, consider signing up for beta: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Sign-Up-for-Beta-Access

If you're trying to debug a network issue, take a look at this help article: https://help.ubnt.com/hc/en-us/articles/221029967-UniFi-Debugging-Intermittent-Connectivity-Issues-on-your-UAP
New Member
Posts: 32
Registered: ‎05-19-2016
Kudos: 7

Re: Connectivity Problems - UAP, UAP-LR, UAP-Pro, UAP-Outdoor5, UAP-Outdoor, UAP-Outdoor+

@UBNT-BenBuckley

 

Another reboot at 3:45pm.

 

Actually I don't know if it's a complete reboot as people are not complaining (yet, anymore?). But the uptime of the AP is reset.

 

We use 2.4 and 5 GHz band, 4 SSIDs, 1 is guest network with only internet access. No band steering, no min. RSSI, no airtime fairness. Average user load between 30 and 60 on the AP-Pro, at least half of them phones. But as they are only accessing the internet (no local servers here) the AP performance screen shows the AP as not very busy (maybe 10% orange bar).

New Member
Posts: 32
Registered: ‎05-19-2016
Kudos: 7

Re: Connectivity Problems - UAP, UAP-LR, UAP-Pro, UAP-Outdoor5, UAP-Outdoor, UAP-Outdoor+

Another reboot: 16:24pm. 

 

There might be intermittent reboots that I don't see.

Ubiquiti Employee
Posts: 7,528
Registered: ‎03-17-2015
Kudos: 4818
Solutions: 197

Re: Connectivity Problems - UAP, UAP-LR, UAP-Pro, UAP-Outdoor5, UAP-Outdoor, UAP-Outdoor+


sahaja-it-team wrote:

Another reboot: 16:24pm. 

 

There might be intermittent reboots that I don't see.


Can you monitor memory use over time?

Want to try out new features or fixes before they're released as Stable? Sign up for Beta here: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Signup-for-Beta-Access
Ubiquiti Employee
Posts: 1,001
Registered: ‎12-16-2015
Kudos: 262
Solutions: 8

Re: Connectivity Problems - UAP, UAP-LR, UAP-Pro, UAP-Outdoor5, UAP-Outdoor, UAP-Outdoor+

@sahaja-it-team, thanks for the feedback.  Have you enabled a remote logging on your system?  In the controller go to 'Settings -> Site -> Remote Logging' and check the 'Enable remote syslog server' box.  This should allow you to capture the logs when the AP reboots.  Please enable that feature and verify that you are getting some logs.

 

In the meantime, I am workign to reproduce here in the lab right now.  Hopefully these two efforts will be enough to reproduce and catch the error quickly.

 

 

If you'd like to try our latest features, consider signing up for beta: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Sign-Up-for-Beta-Access

If you're trying to debug a network issue, take a look at this help article: https://help.ubnt.com/hc/en-us/articles/221029967-UniFi-Debugging-Intermittent-Connectivity-Issues-on-your-UAP
New Member
Posts: 32
Registered: ‎05-19-2016
Kudos: 7

Re: Connectivity Problems - UAP, UAP-LR, UAP-Pro, UAP-Outdoor5, UAP-Outdoor, UAP-Outdoor+

@UBNT-BenBuckley Thanks, would love to. But we are in a serverless environment here, i.e. no syslog server running to collect the logs. The only server at the moment is a cloud key Man Happy

 

I see if I can setup something for my Mac but I don't have anything readly available. Any suggestions?

Reply