Reply
New Member
Posts: 7
Registered: ‎11-25-2018

ESP Smart Home Devices have high packet loss on Unifi AP / Power Save Problem?

Hi,

 

I have three UniFi AP-AC-Pro and two UniFi Switch 8 POE-150W, all running the latest release firmware 3.9.54.9373. Everything is running smoothly and I want to connect a bunch of Sonoff ESP8266 based smart home devices to the Network. My problem now is that those devices have a very high packet loss even though the RSSI is at 99% (-50dBm). I have four of those devices and all have the same behaviour. 

 

While investigating this, I stumbled accross the "power save" mode of single devices and found a strange indication: See the picture in the attachment: The device list shows the device in question TPSW2 without the green leaf ,while in the statistics details window on the right hand side, it says "Power Save Enabled".  This is strange and I cannot see as to why power save should be enabled for this device. I have checked the UAPSD setting for this network and it is disabled.

 

So: How can I disable the Power Saving from the Unifi side at all? I could not find any related setting in the AP settings or controller overall settings?

 

Any idea anyone?   

Thanks // Tom

power1.pngpower2.png

Senior Member
Posts: 23,749
Registered: ‎08-04-2017
Kudos: 4496
Solutions: 1168

Re: ESP Smart Home Devices have high packet loss on Unifi AP / Power Save Problem?

Hello @tomleitner,

 

Welcome to the community!

 

You will need to disable power saving on the devices itself.

Could you post your system config?

Settings > Maintenance > Suppot Info > Show System Config

 

 

Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation Scripts | UniFi-VoIP Installation Scripts
USG-XG-8 • USG-4-PRO • USG
US-XG-16 • US-48-500W • US-24-POE-250W 2x • US-16-POE-150W 3x • US-24 • US-8-150W • US-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD 2x • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M • UAP-AC-M-PRO 2x
UAS-XG • UCK-G2-PLUS • UCK-G2 • UCK
New Member
Posts: 7
Registered: ‎11-25-2018

Re: ESP Smart Home Devices have high packet loss on Unifi AP / Power Save Problem?

Hi Glenn,

Thanks for your reply. Below's my system config.  

 

As for disabling power saving on the clients: I don't have a setting for this on the clients. Any other ideas what could be the reason for the high packet loss?

 

Thanks // Tom

power3.png

 

Senior Member
Posts: 23,749
Registered: ‎08-04-2017
Kudos: 4496
Solutions: 1168

Re: ESP Smart Home Devices have high packet loss on Unifi AP / Power Save Problem?

Hello @tomleitner,

 

Please disable the Uplink Connectivity Monitor

Settings > Site > Uplink Connectivity Monitor

 

Also apply the following Radio Settings

Devices > UAP > Config > Radios

 

2.4 GHz
Channel width: HT20
Chanel: 1/6/11 | Choose one of these channels, a RF scan will help you choose the most clean one.
Transmit Power: Low/Medium

5GHz
Channel width: VHT40 | Optional VHT80 might decrease wireless stability
Chanel: 36/44 | Optional (149/157) Choose one of these channels, a RF scan will help you choose the most clean one. Avoid using DFS Channels
Transmit Power: Medium/High

 

 

 

Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation Scripts | UniFi-VoIP Installation Scripts
USG-XG-8 • USG-4-PRO • USG
US-XG-16 • US-48-500W • US-24-POE-250W 2x • US-16-POE-150W 3x • US-24 • US-8-150W • US-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD 2x • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M • UAP-AC-M-PRO 2x
UAS-XG • UCK-G2-PLUS • UCK-G2 • UCK
New Member
Posts: 7
Registered: ‎11-25-2018

Re: ESP Smart Home Devices have high packet loss on Unifi AP / Power Save Problem?

Hi Glenn,

 

I've set the channels to "auto" and the software automatically chose channel 1 for AP1, Channel 6 for AP2 and Channel 11 for AP3.

So I should be fine with this.

 

I already have HT20 for 2.5GHz and VHT80 for 5GHz. All new smart-home devices are 2.4GHz only anyway. 


So I stick with this.

 

I'll change the power settings and the Uplink Connectivity Monitor ... let's see what I get with this.

 

Thanks a lot // Tom

 

Senior Member
Posts: 2,741
Registered: ‎04-21-2015
Kudos: 405
Solutions: 108

Re: ESP Smart Home Devices have high packet loss on Unifi AP / Power Save Problem?

Hey,

 

I believe your device supports legacy 802.11 power save mode, not 802.11e U-APSD (never method). 

Below article will help you to get yourself familiarised with both methods:

https://mrncciew.com/2014/10/14/cwap-802-11-power-management

Thanks,
Myky
CWNA
--------------------------------------------------------------------------------------------------------------------------------------------------
Don`t blame the device as it`s always doing what you have asked it to do, this is not always the same as what you want.
New Member
Posts: 7
Registered: ‎11-25-2018

Re: ESP Smart Home Devices have high packet loss on Unifi AP / Power Save Problem?

Thanks Myky,  Looks interesting ... I'll have to dig deeper into that to understand the differences. I'll also get in touch with the Firmware guys for my device. 

 

In any case: turning off the "Uplink Connectivity Monitor" already helped a bit. The packet loss went down ...

Reply