Scheduled maintenance: Community will be offline Monday June 17th, 1:00 AM - 6:00 AM (PT)
Reply
New Member
Posts: 2
Registered: ‎10-29-2016

Error by upgrading from 5.5.24 - 9806 to 5.6.22 - 10206 raspberry pi

I can't upgrade i keep getting this message 

 

root@raspberrypi:/home/pi# apt-get dist-upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  libcwiid1 libjs-prettify libllvm3.7 libqscintilla2-11 libqscintilla2-l10n libqt4-network libqt4-xmlpatterns libqtwebkit4 libruby1.9.1 libruby1.9.1-dbg libtcl8.5 libtcltk-ruby1.9.1 libtk8.5 pix-icons pix-plym-splash pixel-wallpaper
  ri1.9.1 ruby1.9.1 ruby1.9.1-dev ruby1.9.1-examples ruby1.9.1-full ruby1.9.3 supercollider supercollider-common supercollider-ide supercollider-language supercollider-supernova tcl8.5 tk8.5
Verwenden Sie »apt-get autoremove«, um sie zu entfernen.
Fertig
Die folgenden Pakete werden aktualisiert (Upgrade):
  unifi
1 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
Es müssen 50,2 MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 131 MB Plattenplatz freigegeben.
Möchten Sie fortfahren? [J/n] j
Holen: 1 http://www.ubnt.com/downloads/unifi/debian/ unifi5/ubiquiti unifi all 5.6.22-10205 [50,2 MB]
Es wurden 50,2 MB in 14 s geholt (3.360 kB/s).
Lese Changelogs... Fertig
Vorkonfiguration der Pakete ...
(Lese Datenbank ... 137639 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../unifi_5.6.22-10205_all.deb ...
Previous setting (UniFi 5.5.24) is found.
Entpacken von unifi (5.6.22-10205) über (5.5.24-9806) ...
Trigger für systemd (215-17+deb8u7) werden verarbeitet ...
unifi (5.6.22-10205) wird eingerichtet ...
Job for unifi.service failed. See 'systemctl status unifi.service' and 'journalctl -xn' for details.
invoke-rc.d: initscript unifi, action "start" failed.
dpkg: Fehler beim Bearbeiten des Paketes unifi (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
Fehler traten auf beim Bearbeiten von:
 unifi
E: Sub-process /usr/bin/dpkg returned an error code (1)

when i read the details out i get this

root@raspberrypi:/home/pi# systemctl status unifi.service
● unifi.service - unifi
   Loaded: loaded (/lib/systemd/system/unifi.service; enabled)
   Active: failed (Result: exit-code) since Sa 2017-11-11 12:52:46 CET; 11s ago
  Process: 2456 ExecStart=/usr/lib/unifi/bin/unifi.init start (code=exited, status=2)
 Main PID: 666 (code=exited, status=0/SUCCESS)

Nov 11 12:52:46 raspberrypi unifi.init[2456]: /usr/lib/unifi/bin/unifi.init: Zeile 148: Syntaxfehler beim unerwarteten Wort `defined'
Nov 11 12:52:46 raspberrypi unifi.init[2456]: /usr/lib/unifi/bin/unifi.init: Zeile 148: `unless (defined &__INT_FAST8_MAX__) { sub __INT_FAST8_MAX__() { 127 } }'
Nov 11 12:52:46 raspberrypi systemd[1]: unifi.service: control process exited, code=exited status=2
Nov 11 12:52:46 raspberrypi systemd[1]: Failed to start unifi.
Nov 11 12:52:46 raspberrypi systemd[1]: Unit unifi.service entered failed state.
root@raspberrypi:/home/pi# journalctl -xn
-- Logs begin at Do 2017-10-19 22:17:01 CEST, end at Sa 2017-11-11 12:52:47 CET. --
Nov 11 12:52:40 raspberrypi sudo[2380]: pam_unix(sudo:session): session opened for user root by pi(uid=0)
Nov 11 12:52:43 raspberrypi systemd[1]: Reloading.
Nov 11 12:52:45 raspberrypi systemd[1]: Reloading.
Nov 11 12:52:46 raspberrypi systemd[1]: Starting unifi...
-- Subject: Unit unifi.service has begun with start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit unifi.service has begun starting up.
Nov 11 12:52:46 raspberrypi unifi.init[2456]: /usr/lib/unifi/bin/unifi.init: Zeile 148: Syntaxfehler beim unerwarteten Wort `defined'
Nov 11 12:52:46 raspberrypi unifi.init[2456]: /usr/lib/unifi/bin/unifi.init: Zeile 148: `unless (defined &__INT_FAST8_MAX__) { sub __INT_FAST8_MAX__() { 127 } }'
Nov 11 12:52:46 raspberrypi systemd[1]: unifi.service: control process exited, code=exited status=2
Nov 11 12:52:46 raspberrypi systemd[1]: Failed to start unifi.
-- Subject: Unit unifi.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit unifi.service has failed.
--
-- The result is failed.
Nov 11 12:52:46 raspberrypi systemd[1]: Unit unifi.service entered failed state.
Nov 11 12:52:47 raspberrypi sudo[2380]: pam_unix(sudo:session): session closed for user root

i don't know what to do now...

Established Member
Posts: 1,021
Registered: ‎09-24-2017
Kudos: 217
Solutions: 83

Re: Error by upgrading from 5.5.24 - 9806 to 5.6.22 - 10206 raspberry pi

See this thread for a potential solution. Seems to be working for many RPi users and also worked for my configuration on a BeagleBone Black.

Reply