Reply
New Member
Posts: 40
Registered: ‎10-08-2016
Kudos: 2

Re: [FIRMWARE] 3.9.3.7537 for UAP/USW has been released

[ Edited ]

@kuwi

About : https://community.ubnt.com/t5/UniFi-Wireless/FIRMWARE-3-9-3-7537-for-UAP-USW-has-been-released/m-p/2...

 

Another Zero Handoff fan here, so I would appreciate it if you could let me know what you did eventually Man Happy

I have 3 UAP with ZHO enabled and would like to keep it that way after the firmware upgrade!


Just installed the latest 5.5.x controller on a RPi3 for this so keeping the ZHO setup would be nice or at least beeing able te configure it again after the firmware upgrade is fine too.

 

 

/EDIT : It worked!

- Upgraded firmware.

(One UAP had some default route issues but after fixing it manually it all worked just fine via the 5.5.24 Controller firmware Update procedure!)

- Had to reconfigure all UAP's with ZHO enabled afterwards.

 

/HAPPY ZHO user again Man Happy

Senior Member
Posts: 3,236
Registered: ‎08-06-2015
Kudos: 1383
Solutions: 186

Re: [FIRMWARE] 3.9.3.7537 for UAP/USW has been released


@ccolotti wrote:

No update for the UAP-AC v2 in these bundles that I can tell.  Is one coming?


This announcement from last month may be helpful:  UAP-AC/UAP-AC-Outdoor LTS Announcement

 

As to whether the UAP-AC requires an update to address the KRACK vulnerabilities, the release announcement (referenced in the first post of this thread) specifically notes that the Gen 1 AC devices are not affected.  This  KB article may also be helpful:  Ubiquiti Devices & KRACK Vulnerability

 

 

 

Emerging Member
Posts: 108
Registered: ‎07-09-2016
Kudos: 35
Solutions: 4

Re: [FIRMWARE] 3.9.3.7537 for UAP/USW has been released


@UBNT-jeff wrote:

@0x4A6F If there is enough demand for this option, we can certainly pull it in, but we will definitely not be enabling it by default since, as it states, "This workaround might cause interoperability issues and reduced robustness of key negotiation especially in environments with heavy traffic load due to the number of attempts to perform the key exchange is reduced significantly."


@UBNT-jeff, I definitely see demand for this. Do we need to add an official feature request?

I guess having an option in config.properties to enable this would be good enough. At least I do not need a GUI option for this.

 

Cheers,

Alex

New Member
Posts: 14
Registered: ‎08-20-2013
Kudos: 1

Re: [FIRMWARE] 3.9.3.7537 for UAP/USW has been released

Have the same issue, with all of my switches, 4 Unifi 24 port and 6 Unifi 8 port, have gone from memory usage of 40% to 60%.

Member
Posts: 288
Registered: ‎05-17-2017
Kudos: 62
Solutions: 8

Re: [FIRMWARE] 3.9.3.7537 for UAP/USW has been released

[ Edited ]

 


brianj wrote:

Have the same issue, with all of my switches, 4 Unifi 24 port and 6 Unifi 8 port, have gone from memory usage of 40% to 60%.


That's due to the new code base for the USW iirc.

@UBNT-cmb

Controller: 5.10.12
Switch: US-24(4.0.22.9996)
Access Point: AC-LR(4.0.22.9996) | Nano HD(4.0.22.9996)
Emerging Member
Posts: 90
Registered: ‎02-06-2017
Kudos: 5

Re: [FIRMWARE] 3.9.3.7537 for UAP/USW has been released

@nero355 unfortunatelly, @UBNT-jeff havent answered yet and wasnt able to give me a timeline for fixing the existing zho bug. So I decided to disable alle wireless uplinks and therefore "workaround" the ap side of this attack. 

 

Iam still not happy that the bug is so long unfixed and I have to stay on this old firmware, especially as even support and @UBNT-jeff himselve were not able to provide an working alternative setup in my case.

 

But what should I do, I only can wait Man Sad

 

Br,

 

kuwi

Member
Posts: 246
Registered: ‎05-19-2015
Kudos: 451
Solutions: 2

Re: [FIRMWARE] 3.9.3.7537 for UAP/USW has been released

Guess that also means by 5.7 I need to upgrade all the AP-AC v2 I have.....figures :/ 

New Member
Posts: 14
Registered: ‎08-20-2013
Kudos: 1

Re: [FIRMWARE] 3.9.3.7537 for UAP/USW has been released


@machbot wrote:

 


@brianj wrote:

Have the same issue, with all of my switches, 4 Unifi 24 port and 6 Unifi 8 port, have gone from memory usage of 40% to 60%.


That's due to the new code base for the USW iirc.

@UBNT-cmb


Are you sure? I contacted support and they are unaware of any issues. Had to give the tech some links to the others complaining of the jump in memory usage.

Member
Posts: 288
Registered: ‎05-17-2017
Kudos: 62
Solutions: 8

Re: [FIRMWARE] 3.9.3.7537 for UAP/USW has been released


@brianj wrote:

@machbot wrote:

 


@brianj wrote:

Have the same issue, with all of my switches, 4 Unifi 24 port and 6 Unifi 8 port, have gone from memory usage of 40% to 60%.


That's due to the new code base for the USW iirc.

@UBNT-cmb


Are you sure? I contacted support and they are unaware of any issues. Had to give the tech some links to the others complaining of the jump in memory usage.



Yes, it is confirmed on at least 2 different posts by UBNT employees. the posts should be somewhere in the routing and switching section, could be in the beta section too.

Controller: 5.10.12
Switch: US-24(4.0.22.9996)
Access Point: AC-LR(4.0.22.9996) | Nano HD(4.0.22.9996)
Emerging Member
Posts: 90
Registered: ‎02-06-2017
Kudos: 5

Re: [FIRMWARE] 3.9.3.7537 for UAP/USW has been released

@nero355 thanks for your reply. In my experience the update always runs fine. Additional question: are you using wlan-schedules? I do and in this combination the problems begin after some days : wifi is there but not working, aps wenn to disconnected state and so on.

 

So ca you please keep an eye on this?

 

Br,

 

kuwi

 

New Member
Posts: 3
Registered: ‎08-08-2016

Re: [FIRMWARE] 3.9.3.7537 for UAP/USW has been released

I also have a Picostation M2hp and would like to know what is going on with a firmware release for this as well.

New Member
Posts: 40
Registered: ‎10-08-2016
Kudos: 2

Re: [FIRMWARE] 3.9.3.7537 for UAP/USW has been released

@kuwi : I don't use that feature so I can't tell you anything about that Man Sad

What I do have is that one of the UAP's isn't very stable :
- UAP-D : Uptime 21 hours (It's almost 24 hours ago since the update so that sounds about right)
- UAP-E : Only 9 hours uptime while it was updated at the same time... Man Sad

I am guessing there is a log somewhere with the reason for the reboot ?!


Before the firmware update both UAP's had a uptime of 67 days!
(And before that reboot about two years or so without any issues Man Wink )
Emerging Member
Posts: 90
Registered: ‎02-06-2017
Kudos: 5

Re: [FIRMWARE] 3.9.3.7537 for UAP/USW has been released

@nero355 

 

<I am guessing there is a log somewhere with the reason for the reboot ?!

Unfortunatelly not, yes there is a log, but if you haven`t a syslog server which got the logs, the logs on the UAP gets cleared while it is booting.

 

I dont know if the zho bug is related to wlan schedules, but reboots/disconnects were the symptoms I observed in this case. So maybe you hit the same bug, in my environment the symptoms where "hopping" between the UAPs so e.g. the first day it was AP1, the second day AP3 the third day AP2. Always different, and after a clean reboot it was working some time again...

 

Br,

kuwi

Ubiquiti Employee
Posts: 3,898
Registered: ‎01-11-2016
Kudos: 1160
Solutions: 29

Re: [FIRMWARE] 3.9.3.7537 for UAP/USW has been released

@kuwi I know that we will have builds with 11r and 11k enabled soon, which should be the long-term replacement for ZHO, and we'd love to get your feedback once it is in beta.
Want to try out new features or fixes before they're released as Stable? Sign up for Beta here: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Signup-for-Beta-Access
Having connectivity issues? See: https://help.ubnt.com/hc/en-us/articles/221029967-UniFi-Debugging-Intermittent-Connectivity-Issues-on-your-UAP
Highlighted
New Member
Posts: 7
Registered: ‎05-06-2016
Kudos: 1

Re: [FIRMWARE] 3.9.3.7537 no clients can connect!

[ Edited ]

After upgrading my Unifi AP-AC-LR to firmware 3.9.3.7537, no clients are able to connect to the AP.

 

When I connect to the AP via SSH, I see that the system load average is > 1. 

 

 /bin/hostapd /etc/aaa1.cfg is using 100% of CPU.

 

I've attached the log file.

 

Downgrading to the previous version of the firmware allows my devices to connect again.

 

New Member
Posts: 40
Registered: ‎10-08-2016
Kudos: 2

Re: [FIRMWARE] 3.9.3.7537 for UAP/USW has been released

@kuwi

Indeed : Both UAP's are showing the same symptoms but I double checked and I am really not using any kind of Scheduling for them so no idea what's going on.

There was one thing I remembered suddenly and that's the Uplink Connectivity monitoring which in the past sometimes had issues so I have disabled that now and hope things will get better...

This is very annoying since the UAP's were performing outstanding since the day I bought them and now because of this security flaw and the new firmware my WiFi has become less reliable Man Sad


@UBNT-jeff : What time frame are we talking about ? 1 month ? 2 months ? Q1 2018 ?
I am waiting for full 802.11r/k/v support since the release of the UAP-AC-Lite models so I can get some 5GHz sweetness Man Wink
Ubiquiti Employee
Posts: 3,898
Registered: ‎01-11-2016
Kudos: 1160
Solutions: 29

Re: [FIRMWARE] 3.9.3.7537 for UAP/USW has been released

@nero355 We are nearly complete with the code and the post text is nearly finalized, so "pretty soon." Total guess is within the week.
Want to try out new features or fixes before they're released as Stable? Sign up for Beta here: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Signup-for-Beta-Access
Having connectivity issues? See: https://help.ubnt.com/hc/en-us/articles/221029967-UniFi-Debugging-Intermittent-Connectivity-Issues-on-your-UAP
Ubiquiti Employee
Posts: 3,898
Registered: ‎01-11-2016
Kudos: 1160
Solutions: 29

Re: [FIRMWARE] 3.9.3.7537 no clients can connect!

@crazyk4952 Thank you for the log! I'm looking into the hostapd crash right now. btw you are the first to see this issue, but it should hopefully be straightforward to fix.
Want to try out new features or fixes before they're released as Stable? Sign up for Beta here: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Signup-for-Beta-Access
Having connectivity issues? See: https://help.ubnt.com/hc/en-us/articles/221029967-UniFi-Debugging-Intermittent-Connectivity-Issues-on-your-UAP
Ubiquiti Employee
Posts: 3,898
Registered: ‎01-11-2016
Kudos: 1160
Solutions: 29

Re: [FIRMWARE] 3.9.3.7537 no clients can connect!

@crazyk4952 Please try this firmware, and let us know if it fixes the crash for you, or if you have a new log to share Man Happy Thank you!

https://dl.ubnt-ut.com/uap2-fix-hostapd-crash3.bin
Want to try out new features or fixes before they're released as Stable? Sign up for Beta here: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Signup-for-Beta-Access
Having connectivity issues? See: https://help.ubnt.com/hc/en-us/articles/221029967-UniFi-Debugging-Intermittent-Connectivity-Issues-on-your-UAP
New Member
Posts: 7
Registered: ‎05-06-2016
Kudos: 1

Re: [FIRMWARE] 3.9.3.7537 no clients can connect!

@UBNT-jeff

Thanks for sending out the new firmware. I just installed it and it seems to have fixed the problem.

 

My clients are connected the system load on the AP is .07.

 

Thanks again!

Reply