Reply
New Member
Posts: 2
Registered: ‎11-07-2017
Kudos: 1

Getting Alert: "/sbin/ntpclient exited with code 256 and restarted by inittab" on 3 AP-AC-Pro's

Getting Alert: "/sbin/ntpclient exited with code 256 and restarted by inittab" on 3 AP-AC-Pro's a number of times a day after update v:3.9.54.9373 and updating Cloud Key Firmware to UCK.mtk7623.v0.12.0.29a26c9.181001.1444 & Controller to ver:5.9.29-11384-1.

 

I have the time zone set and tried the Naval NTP server.  The minutes are correct but the time being shown in Statistics is always in UTC -1 hour.  It is messing with my mind every time I have to do the transposition!!

 

Also we have the AP's on a Unifi 24p PoE 250Watt Switch.  We have been seeing the APs loosing connection to the Cloud Key and in one Alert we lost connection to the Switch.

 

We are putting in a UPS in case it is power.

 

The Cloud Key is on another Switch and Subnet.  And the Switch in question was manually connected to the Cloud Key.

 

David

 

 

Screen Shot 2018-10-14 at 1.02.32 PM.png
Senior Member
Posts: 10,068
Registered: ‎08-04-2017
Kudos: 1631
Solutions: 493

Re: Getting Alert: "/sbin/ntpclient exited with code 256 and restarted by inittab" on 3 AP

Hello @CPR-Unifi,

 

Have you tried the default NTP settings on the controller?

Have you tried to reset the devices?

 

 

Regards,

Glenn R.

 

CC @UBNT-BenBuckley

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation/Easy Update Scripts | UniFi-VoIP Installation Scripts
USG-4-PRO • USG
USW-48-500W • USW-24-POE-250W 2x • USW-16-POE-150W • USW-24 • USW-8-150W • USW-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M
UCK-G2 • UCK
Member
Posts: 112
Registered: ‎05-31-2018
Kudos: 15
Solutions: 2

Re: Getting Alert: "/sbin/ntpclient exited with code 256 and restarted by inittab" on 3 AP

For me this issue is a side-effect of the APs suffering from poor signal quality.

 

This was first diagnosed for me by @UBNT-BenBuckley and (if you ara a member of the beta community) you can find a long thread on the issue as it relates to the AP LR here

 

I have found that the problem goes away if I use 3.9.50 firmware. (It may also go away for .51, .52 and .53 but I did not yet have an opportunity to test extensively.) 

Ubiquiti Employee
Posts: 1,286
Registered: ‎12-16-2015
Kudos: 292
Solutions: 9

Re: Getting Alert: "/sbin/ntpclient exited with code 256 and restarted by inittab" on 3 AP

@CPR-Unifi are any of your AP's using wireless uplink?

If you'd like to try our latest features, consider signing up for beta: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Sign-Up-for-Beta-Access

If you're trying to debug a network issue, take a look at this help article: https://help.ubnt.com/hc/en-us/articles/221029967-UniFi-Debugging-Intermittent-Connectivity-Issues-on-your-UAP
Emerging Member
Posts: 42
Registered: ‎05-06-2018
Kudos: 5
Solutions: 1

Re: Getting Alert: "/sbin/ntpclient exited with code 256 and restarted by inittab" on 3 AP

I just this error pop up in my controller for an AP-AC-LR providing wireless uplink to an older AP-LR. Times still seem to be fine here though.

New Member
Posts: 2
Registered: ‎03-30-2016
Kudos: 1

Re: Getting Alert: "/sbin/ntpclient exited with code 256 and restarted by inittab" on 3 AP

I have the same problem at Version 5.9.29 with AP UAP-AC-LR and UAP-AC-Lite Version 3.9.54.9373.

 

/sbin/ntpclient exited with code 256 and restarted by inittab

 

The problem exist everytime I provide a new configuration to the APs.

 

Have anyone solve the problem ??

Ubiquiti Employee
Posts: 1,286
Registered: ‎12-16-2015
Kudos: 292
Solutions: 9

Re: Getting Alert: "/sbin/ntpclient exited with code 256 and restarted by inittab" on 3 AP

@TheWebWasher can you grab /var/log/messages from your AP and send me a private message with a dropbox link or something?

If you'd like to try our latest features, consider signing up for beta: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Sign-Up-for-Beta-Access

If you're trying to debug a network issue, take a look at this help article: https://help.ubnt.com/hc/en-us/articles/221029967-UniFi-Debugging-Intermittent-Connectivity-Issues-on-your-UAP
Emerging Member
Posts: 93
Registered: ‎02-03-2016
Kudos: 15

Re: Getting Alert: "/sbin/ntpclient exited with code 256 and restarted by inittab" on 3 AP

Still looking for debug info on this? I have a site where one AP has alerted on this message.

New Member
Posts: 3
Registered: ‎03-13-2016

Re: Getting Alert: "/sbin/ntpclient exited with code 256 and restarted by inittab" on 3 AP

 

 I had the same issue on one of four Acssess Points. This were feeding with stand alone PoE. When I upgraded eight channels PoE 48V 60W the alerts "/sbin/ntpclient exited with code 256 and restarted by inittab" and  voila the alert disappeared from the alert tab.

 It seems that is a lack of power. The eight  channels PoE is feeding four AP AC Pro plus the cloud key.

 

https://www.amazon.com/gp/aw/d/B01IODMBRY?psc=1&ref=yo_pop_mb_yo_pop_mb_pd_t2

New Member
Posts: 15
Registered: ‎10-10-2018

Re: Getting Alert: "/sbin/ntpclient exited with code 256 and restarted by inittab" on 3 AP

I also have the 2 Ap's plugged into my US-8-60W..latest software, but still the same messages... So maybe it fixed it in your case, but not in mine. 

New Member
Posts: 3
Registered: ‎03-13-2016

Re: Getting Alert: "/sbin/ntpclient exited with code 256 and restarted by inittab" on 3 AP

When I activated mine the only AP that I have the issue was I upgraded it to latest firmware before activate the access point but the issue it’s gone due to the PoE on the others I did activation first then I upgraded them. I remember that the AP I turn it off for about 30 min while I was making the cable path after I connected the cable path on the PoE side without LAN cable (data). So in order words the AP was powered for about  another 10 min  with no data  cable when  I restored the data.

Have you tried to telnet the AP and downgrade the firmware and reactivate it then re upgrade to the latest firmware after activation?

New Member
Posts: 3
Registered: ‎03-13-2016

Re: Getting Alert: "/sbin/ntpclient exited with code 256 and restarted by inittab" on 3 AP

P.S. or using an stand alone PoE
New Member
Posts: 2
Registered: a week ago

Re: Getting Alert: "/sbin/ntpclient exited with code 256 and restarted by inittab" on 3 AP

I've got the same issue

/sbin/ntpclient exited with code 256 and restarted by inittab

Every access point, every day. There is no GUI element to be able to change the NTP server.

I only have the UniFi controller installed and APs connected to PoE switch.
New Member
Posts: 4
Registered: a week ago

Re: Getting Alert: "/sbin/ntpclient exited with code 256 and restarted by inittab" on 3 AP

Same here. Anyone has solved this?

Ubiquiti Employee
Posts: 1,286
Registered: ‎12-16-2015
Kudos: 292
Solutions: 9

Re: Getting Alert: "/sbin/ntpclient exited with code 256 and restarted by inittab" on 3 AP

@drevilish @Krupps are your AP's getting new IP addresses when the alerts happen? The default DHCP timeout is 24 hours, so if the AP renews its lease 1 time a day, and gets a new IP each time, it would cause this alert every time.

If you'd like to try our latest features, consider signing up for beta: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Sign-Up-for-Beta-Access

If you're trying to debug a network issue, take a look at this help article: https://help.ubnt.com/hc/en-us/articles/221029967-UniFi-Debugging-Intermittent-Connectivity-Issues-on-your-UAP
New Member
Posts: 2
Registered: a week ago

Re: Getting Alert: "/sbin/ntpclient exited with code 256 and restarted by inittab" on 3 AP

My DHCP is set to a reserved IP on their MAC addresses.

 

5 APs each with an address. 

Renewal time for these is 24hrs.

Ubiquiti Employee
Posts: 1,286
Registered: ‎12-16-2015
Kudos: 292
Solutions: 9

Re: Getting Alert: "/sbin/ntpclient exited with code 256 and restarted by inittab" on 3 AP

@drevilish can you get /var/log/messages off of a couple AP's and send me the file?

If you'd like to try our latest features, consider signing up for beta: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Sign-Up-for-Beta-Access

If you're trying to debug a network issue, take a look at this help article: https://help.ubnt.com/hc/en-us/articles/221029967-UniFi-Debugging-Intermittent-Connectivity-Issues-on-your-UAP
Reply