Reply
New Member
Posts: 11
Registered: ‎08-24-2018
Kudos: 1
Solutions: 1
Accepted Solution

HTTPS Certificate on 5.9.29

On the pervious versions of the controller, I have put my own certificate on, from Lets Encrypt, but with the latest version it stopped working.

 

I am running the controller on Debian, and before I had a script, which put the certificate into /var/lib/unifi/keystore, followed by restarting the controller, and it has worked flawlessly. But at 5.9.29 it stopped using my certificate, even when I can see letsencrypt in keystore, and instead it use a UniFi certificate.

 

Instead of using my script to do the certificate, I tried to import it with ace, as the documentation suggest, but with that I get a message about it being unable to import it.

 

Anyone got any ideas to what could be wrong/changed?


Accepted Solutions
Regular Member
Posts: 411
Registered: ‎10-21-2014
Kudos: 107
Solutions: 16
New Member
Posts: 11
Registered: ‎08-24-2018
Kudos: 1
Solutions: 1

Re: HTTPS Certificate on 5.9.29

A reply a bit further down on that topic, fixed the problem for me.

Permalink to the topic with the script in: https://community.ubnt.com/t5/UniFi-Wireless/Lets-Encrypt-on-Hosted-Controller/m-p/2524498/highlight...

View solution in original post


All Replies
New Member
Posts: 12
Registered: ‎05-10-2012
Kudos: 1

Re: HTTPS Certificate on 5.9.29

Same here Man Sad
New Member
Posts: 1
Registered: a month ago

Re: HTTPS Certificate on 5.9.29

I am haveing exactly the same issue..

 

 

Regular Member
Posts: 411
Registered: ‎10-21-2014
Kudos: 107
Solutions: 16

Re: HTTPS Certificate on 5.9.29

Highlighted
Emerging Member
Posts: 65
Registered: ‎11-24-2017
Kudos: 18

Re: HTTPS Certificate on 5.9.29

[ Edited ]

I also use lets encrypt and have set it up and working like it is described on this page:

https://www.naschenweng.info/2017/01/06/securing-ubiquiti-unifi-cloud-key-encrypt-automatic-dns-01-c...

maybe all you need from there is the cloudkey-renew-hook.sh script to install your otherwise generated certificate.

New Member
Posts: 11
Registered: ‎08-24-2018
Kudos: 1
Solutions: 1

Re: HTTPS Certificate on 5.9.29

A reply a bit further down on that topic, fixed the problem for me.

Permalink to the topic with the script in: https://community.ubnt.com/t5/UniFi-Wireless/Lets-Encrypt-on-Hosted-Controller/m-p/2524498/highlight...
Ubiquiti Employee
Posts: 8,587
Registered: ‎01-28-2013
Kudos: 13691
Solutions: 593
Contributions: 20

Re: HTTPS Certificate on 5.9.29

[ Edited ]

Just so we're clear here, this "problem" is because of a combination of bad 3rd party instructions and a bug which allowed an invalid name/alias to work. I also mentioned that HERE.

 

Cheers,

Mike

Reply