Reply
New Member
Posts: 31
Registered: ‎11-12-2014
Kudos: 1

I can't adopt UAP-AC-Pro-Gen2. State=INFORM_ERROR

Hi all,

 

I've a simple network, with:

 

- 1 Mikrotik routerboard

- 1 UAP-Outdoor+

- 1 UAP-AC-Pro-Gen2

 

Two UAPs get IP address from routerboard via DHCP.

I've a remote Unifi Controller with public IP that actually manage many UAPs from different sites.

 

I've adopted UAP-Outdoor+ without problem but I can't adopt UAP-AC-Pro-Gen2.

 

This is the result of info command on UAP-AC-Pro-Gen2:

 

UBNT-BZ.v4.0.15# info

Model: UAP-AC-Pro-Gen2
Version: 4.0.15.9872
MAC Address: 44:d9:e7:fc:dc:82
IP Address: 192.168.10.249
Hostname: UBNT
Uptime: 73713 seconds

Status: Not Adopted (http://<Public_IP_of_my_Controller>:8080/inform)

 

In Unifi Controller I don't see the UAP-AC-Pro-Gen2.

 

In Unifi Controller logs/server file I've lines like this:

 

[2019-02-08 14:57:16,484] <inform-59> INFO inform - from [44:d9:e7:fc:dc:82](, U7PG2, 4.0.15.9872): state=INFORM_ERROR, ext_ip=<Public_IP_of_the_routerboard>, dev_ip=192.168.10.249, up=73653

 

So connection from UAP to Controller seems to be ok, it send the adoption request.

 

Any idea about this "state=INFORM_ERROR"?

 

Unifi Controller version is 5.4.16

 

Thanks.

Ubiquiti Employee
Posts: 118
Registered: ‎10-15-2018
Kudos: 14
Solutions: 9

Re: I can't adopt UAP-AC-Pro-Gen2. State=INFORM_ERROR

Hello @3m4x

 

Have you attempted to set-inform from the AP? 

 

Can you assign a static IP to the AC-Pro?

Jonathan See | UniFi Support Team
New Member
Posts: 31
Registered: ‎11-12-2014
Kudos: 1

Re: I can't adopt UAP-AC-Pro-Gen2. State=INFORM_ERROR

[ Edited ]

Hello @UBNT-JSee

 

I tried "set-inform http://<Public_IP_of_my_Controller>:8080/inform" but result is the same.

 

UAP gets always the same IP from DHCP. Is it enough or have I to manually set the IP?

Usually I let all UAP in DHCP.

 

Thanks.

Ubiquiti Employee
Posts: 118
Registered: ‎10-15-2018
Kudos: 14
Solutions: 9

Re: I can't adopt UAP-AC-Pro-Gen2. State=INFORM_ERROR

Have you issued the set-inform twice? From the AP, can you ping the public IP of the Controller?

 

If it's easily done, you can assign a static IP via your Microtik, though I don't see why DHCP would cause issues with adoption.

 

Have you set-default the AP? 

Jonathan See | UniFi Support Team
New Member
Posts: 31
Registered: ‎11-12-2014
Kudos: 1

Re: I can't adopt UAP-AC-Pro-Gen2. State=INFORM_ERROR

Yes.

 

I tried set-inform more than once.

I can ping Controller.

I've static lease in Mikrotik DHCP.

I've tried set-default.

 

Nothing changes. I still can't see AP in Controller and in logs I always see "state=INFORM_ERROR"

Ubiquiti Employee
Posts: 118
Registered: ‎10-15-2018
Kudos: 14
Solutions: 9

Re: I can't adopt UAP-AC-Pro-Gen2. State=INFORM_ERROR

@3m4x I'll DM you, would like to get access via Teamviewer to investigate a bit more.

Jonathan See | UniFi Support Team
Ubiquiti Employee
Posts: 118
Registered: ‎10-15-2018
Kudos: 14
Solutions: 9

Re: I can't adopt UAP-AC-Pro-Gen2. State=INFORM_ERROR

@3m4x Would you be able to upgrade your Controller to a more recent version and retest? 5.9.29 or newer would be preferred. 

 

Here are the release notes and download link for 5.10.12.

Jonathan See | UniFi Support Team
New Member
Posts: 31
Registered: ‎11-12-2014
Kudos: 1

Re: I can't adopt UAP-AC-Pro-Gen2. State=INFORM_ERROR

Hello @UBNT-JSee ,

 

I'm not sure.

 

My Controller actually manage following models:

 

UniFi AP
UniFi AP-Outdoor
UniFi AP-Outdoor+
UniFi AP-LR
UniFi AP-LR v2
UniFi AP-AC-Pro
UniFi AP-AC-Lite
UniFi AP-AC-Mesh
UniFi AP-AC-Mesh-Pro
UniFi Switch 16 POE-150W

 

and I don't want to lose them.

 

If UAP-AC-PRO-Gen2 is incompatible with Controller version 5.4.16, maybe it' simpler to change that AP.

Senior Member
Posts: 16,460
Registered: ‎08-04-2017
Kudos: 3006
Solutions: 810

Re: I can't adopt UAP-AC-Pro-Gen2. State=INFORM_ERROR

[ Edited ]

Hello @3m4x,

 

All these models are still supported in the latest controller version.

Only support for the UAP AC ( v2 ), UAP AC OUTDOOR and PicoM2 dropped after 5.6.x

 

I do recommend using my Easy Update Script if you're running the controller on a UCK/UAS or Linux machine.

 

 

Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-VoIP Installation Scripts
USG-4-PRO • USG
USW-48-500W • USW-24-POE-250W 2x • USW-16-POE-150W 3x • USW-24 • USW-8-150W • USW-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M
UCK-G2-PLUS • UCK-G2 • UCK
Ubiquiti Employee
Posts: 118
Registered: ‎10-15-2018
Kudos: 14
Solutions: 9

Re: I can't adopt UAP-AC-Pro-Gen2. State=INFORM_ERROR

@3m4x Those models are still supported in the latest Controller version.

Jonathan See | UniFi Support Team
New Member
Posts: 31
Registered: ‎11-12-2014
Kudos: 1

Re: I can't adopt UAP-AC-Pro-Gen2. State=INFORM_ERROR

I tried to upgrade Controller but something went wrong.

 

Installation went ok but Controller doesn't start.

 

In the window it says:

 

Initializing Unifi Controller...

Starting Unifi Controller...

Server taking too long to start...

Start-up failed.

 

 

In logs I have:

 

[2019-02-11 19:19:46,618] <launcher-ui> INFO launcher - Initializing UniFi Controller ...
[2019-02-11 19:19:55,171] <launcher-monitor> INFO launcher - Starting UniFi Controller ...
[2019-02-11 19:20:02,212] <launcher> INFO system - ======================================================================
[2019-02-11 19:20:02,213] <launcher> INFO system - UniFi 5.6.40 (build atag_5.6.40_10370 - release) is started
[2019-02-11 19:20:02,213] <launcher> INFO system - ======================================================================
[2019-02-11 19:20:02,247] <launcher> INFO system - BASE dir:C:\Users\principale\Ubiquiti UniFi
[2019-02-11 19:20:02,326] <launcher> INFO system - Current System IP: >Controller_IP>
[2019-02-11 19:20:02,328] <launcher> INFO system - Hostname: WiFi-Controller
[2019-02-11 19:20:07,389] <launcher> INFO db - waiting for db connection...
[2019-02-11 19:20:07,890] <launcher> INFO db - Connecting to mongodb://127.0.0.1:27117
[2019-02-11 19:23:45,774] <launcher> INFO db - DB version (5.4.16) different from Runtime Version(5.6.40), migrating...
[2019-02-11 19:23:45,805] <launcher> INFO system - [server backup] started
[2019-02-11 19:23:45,805] <launcher> INFO db - Connecting to mongodb://127.0.0.1:27117
[2019-02-11 19:24:08,722] <launcher> INFO db - Connecting to mongodb://127.0.0.1:27117
[2019-02-11 19:24:16,100] <launcher> INFO system - [server backup] end
[2019-02-11 19:26:57,685] <launcher-monitor> ERROR launcher - Server taking too long to start...
[2019-02-11 19:26:57,717] <launcher-ui> ERROR launcher - Start-up failed.

 

 

Is there any problem in migrating from 5.4.16 to 5.6.40?

Senior Member
Posts: 16,460
Registered: ‎08-04-2017
Kudos: 3006
Solutions: 810

Re: I can't adopt UAP-AC-Pro-Gen2. State=INFORM_ERROR

Hello @3m4x,


What JAVA version are you using?

 

 

Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-VoIP Installation Scripts
USG-4-PRO • USG
USW-48-500W • USW-24-POE-250W 2x • USW-16-POE-150W 3x • USW-24 • USW-8-150W • USW-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M
UCK-G2-PLUS • UCK-G2 • UCK
New Member
Posts: 31
Registered: ‎11-12-2014
Kudos: 1

Re: I can't adopt UAP-AC-Pro-Gen2. State=INFORM_ERROR

[ Edited ]

@AmazedMender16 

I did nothing and it seems it started after 11 hours.

Even if there was an error in startup, Controller was still working in backgroud to migrate database and after migration it started.

Only thing is that migration kept 11 hours to complete and there wasn't any suggestion that migration was in progress and it wasn't stuck.

 

@UBNT-JSee Anyway with version 5.6.40 UAP doesn't work. I tried to upgrade UAP to 4.0.21 but it doesn't work. In logs I have always "State=INFORM_ERROR".

 

I could also try to upgrade Controller to the last version but sincerely I'm not sure it could be the solution.

Ubiquiti Employee
Posts: 118
Registered: ‎10-15-2018
Kudos: 14
Solutions: 9

Re: I can't adopt UAP-AC-Pro-Gen2. State=INFORM_ERROR

@3m4x Are you logged in as the super admin? 

 

Are you still running 5.6.40? I would suggest downloading a backup from 5.6.40, and upgrading to a more recent Controller version to rule out any issues with the older version.

Jonathan See | UniFi Support Team
Reply