Reply
Highlighted
New Member
Posts: 32
Registered: ‎11-01-2015
Kudos: 5
Solutions: 1
Accepted Solution

Intermittent connectivity loss with UAP-AC-PRO

[ Edited ]

We have one USG (firmware version 4.2.11.4796630) and three UAP-AC-PRO (firmware version:3.4.18.3464) in a rectangular office space of 4,000 sqft. The 3 APs are mounted under the ceiling. The closest distance between the APs is about 20~25 feet (see attached floorplan). We have under 40 wifi clients connected at the peak time, about 20 of them are MacBooks, the rest are mobile/tablet devices. At any moment, there are no more than 17 devices per AP. The network controller (v4.7.5) is running on Debian 8.2 hosted by Rackspace. Both 2.4 Ghz and 5 Ghz broadcast the same SSID.

Floorplan

 

Since we deployed the UAPs, users have been experiencing intermittent connectivity loss from time to time. When this occurs, the user's computer is showing nothing abnormal. The wifi connection is showing still connected, and the RSSI is also showing a decent number (between -50 dBm and -70 dBm). However, there is no connectivity until the user turns off and turns on the wifi, bascially by reconnecting to the wifi network.

 

We have tried adjusting the Tx power levels and channels on 2.4G and 5G, as well as setting RSSI threshold on APs to facilitate roaming. Most of our devices seemed to be able to roam successfully among APs when users moved from a locatioin to another (e.g. from their desk to a boardroom). We have also tried to reboot APs; but all these measures did not help to resolve the intermittent connectivity loss issue. 

 

Any idea?


Accepted Solutions
New Member
Posts: 32
Registered: ‎11-01-2015
Kudos: 5
Solutions: 1

Re: Intermittent connectivity loss with UAP-AC-PRO

[ Edited ]

I am the OP. This thread has become very active with a lot of interactions. People seemed to reporting all kinds of issues that are not really relevant to the issue that I reported. 

 

Question is: Has this issue been fixed? 

 

The way that I worked around the problem was creating two WLAN groups, since we have two SSIDs (one for employees, the other for guests), I put the guest SSID to WLAN group 1, and the regular SSID to WLAN group 2. Then per each AP, I assign the group 1 to 2G, and the other to 5G. This way, employees who only connect to the regular SSID will all be on 5G, and the guest users on 2G. It has been a year now and the connectivity loss issue has disappeared as I no longer receive Wifi-related complaints. Currently my controller is still v4.8.14 on RackSpace; my USG firmware is v4.2.11.4796630 (I found it very stable); and APs are running v3.4.18.3464.

 

A member in this thread mentioned that Apple's machines (MacBook Air and Pro) had dual-band issues; the workaround seems to support that opinion. Is any one else still experiencing this problem?

View solution in original post


All Replies
Ubiquiti Employee
Posts: 7,528
Registered: ‎03-17-2015
Kudos: 4830
Solutions: 197

Re: Intermittent connectivity loss with UAP-AC-PRO

Hi @qiaohu,

 

Sorry for the trouble here.  We'd like to get to the bottom of this as soon as possible.

 

There are some known issues on 4.7.5 that may be causing this.  Would you be able to sign up for Beta and give our current release candidate a try?

 

How to sign up for Beta: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Signup-for-Beta-Access

Current release candidate (4.8.7 as of this writing): http://community.ubnt.com/t5/UniFi-Beta-Blog/bg-p/Blog_UniFi_Beta

 

Or if you'd prefer not to use a release candidate, could you alternatively try the latest stable release (4.7.6, as of this writing):
https://www.ubnt.com/download/unifi

 

Either way, after you upgrade the controller, please do update the AP firmware from the controller and see if the intermittent issues persist.  If the issues do persist, we'd like to establish a nutty.io session to each of the APs to look at their logs.

 

Sorry again for the trouble here.

 

Best Regards,

Brandon

Want to try out new features or fixes before they're released as Stable? Sign up for Beta here: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Signup-for-Beta-Access
New Member
Posts: 32
Registered: ‎11-01-2015
Kudos: 5
Solutions: 1

Re: Intermittent connectivity loss with UAP-AC-PRO

Thank you Brandon for responding so quickly!

 

I will try upgrading the controller and the firmware over this weekend to minimize the down time. A few questions regarding upgrade though:

 

  1. What's the best way to upgrade the controller (the controller is currently running on Debian 8.2 on RackSpace)?
  2. Would the controller settings be kept after upgrade? Or do I have to re-provision the USG and UAPs?
  3. What's the best way to roll back the controller to v4.7.5 if necessary?

 

Thanks again,

Qiao

Ubiquiti Employee
Posts: 7,528
Registered: ‎03-17-2015
Kudos: 4830
Solutions: 197

Re: Intermittent connectivity loss with UAP-AC-PRO

Hi @qiaohu,

 

You're very welcome.  Thanks for reporting the problem.  

 

First save a system backup: Settings -> Maintenance -> Download Backup

 

  1. For Alpha/Beta/RC I typically download the .deb wget and install using dpkg -i:
    wget http://www.ubnt.com/downloads/unifi/4.8.8-p2c99xp/unifi_sysvinit_all.deb
    sudo dpkg -i unifi_sysvinit_all.deb
  2. Yes, they're kept.  Always best to do a backup anyways.
  3. Since you'd be going back to stable (actually 4.7.6), you could simply do:
    sudo apt-get remove unifi
    sudo apt-get install unifi
    Then you can restore settings using: Settings -> Maintenance -> Restore

I hope that helps and sorry for the trouble here.

 

Best Regards,

Brandon

Want to try out new features or fixes before they're released as Stable? Sign up for Beta here: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Signup-for-Beta-Access
New Member
Posts: 24
Registered: ‎12-15-2015
Kudos: 3

Re: Intermittent connectivity loss with UAP-AC-PRO

I'm having the exact same issues with a very similar setup. Sadly I had to put our old Apple Airport Extremes back out until this is resolved.

I configured channels, signal strength, min RSSI, disabled Uplink Connectivity Monitor... tried about everything I could think of. People 10 feet away from the AP with clear line of sight are losing connectivity, signal is fine. Pretty much everyone has Late 2013 MBPs.

@UBNT-Brandon: I'm running the controller on a CloudKey. Is there any way to update that to the beta firmware?

Ubiquiti Employee
Posts: 7,528
Registered: ‎03-17-2015
Kudos: 4830
Solutions: 197

Re: Intermittent connectivity loss with UAP-AC-PRO

@croemmich  The Cloudkey actually runs Debian, so the process is the same.

 

What version are you currently running?

Want to try out new features or fixes before they're released as Stable? Sign up for Beta here: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Signup-for-Beta-Access
New Member
Posts: 24
Registered: ‎12-15-2015
Kudos: 3

Re: Intermittent connectivity loss with UAP-AC-PRO

CloudKey: v0.3.6

Controller: 4.8.5-7244

 

UniFi AP-AC-Pro: 3.4.9.3346

I'll try to update the controller on the CloudKey to see if todays RC helps.

 

Ubiquiti Employee
Posts: 7,528
Registered: ‎03-17-2015
Kudos: 4830
Solutions: 197

Re: Intermittent connectivity loss with UAP-AC-PRO

[ Edited ]

@croemmich  Edit: Could you post this information for the MBPs?  Also, do other clients experience the same problem?

 

Screen Shot 2015-12-17 at 11.30.12 AM.png

 

Also, what does your network diagram look like?

 

Thanks in advance,

Brandon

Want to try out new features or fixes before they're released as Stable? Sign up for Beta here: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Signup-for-Beta-Access
New Member
Posts: 24
Registered: ‎12-15-2015
Kudos: 3

Re: Intermittent connectivity loss with UAP-AC-PRO

[ Edited ]

@UBNT-Brandon, sorry for my terrible sketch, I don't have a blueprint handy. It's not quite to scale, but probably good enough. It's an open office environment, not much to get in the way. Placement is fairly ideal.

AP1: A couple reported issues a day, 25 devices
AP2: A couple reported issues a day, 15 devices
AP3: Room currently unused due to renovation
AP4: 50% of people in room have issues, 15 devices.

Waiting to get the OS version info from the people have issues. Other than that, they should all be:
MacBook Pro (Retina, 13-inch, Late 2013)

2.6 GHz Intel Core i5

8 GB 1600 MHz DDR3

I also noticed some issues with our Chromecasts, but it looks like you have fixed that in the RC.

EDIT:

OSX versions having issues:

10.11.2

10.11.1
10.11

IMG_20151217_131618.jpg
Ubiquiti Employee
Posts: 7,528
Registered: ‎03-17-2015
Kudos: 4830
Solutions: 197

Re: Intermittent connectivity loss with UAP-AC-PRO

Thanks @croemmich.  

 

We're investigating.  We just took down 4.8.8 for unrelated issues (problems w/ legacy APs upgrading).  Please give 4.8.7 a try.

Want to try out new features or fixes before they're released as Stable? Sign up for Beta here: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Signup-for-Beta-Access
New Member
Posts: 32
Registered: ‎11-01-2015
Kudos: 5
Solutions: 1

Re: Intermittent connectivity loss with UAP-AC-PRO

[ Edited ]

Now that v4.8.8 is removed, should I still go ahead to upgrade my controller to v4.8.7 to solve our connection problem? 

 

v4.8.7's release note says that we should avoid remotely upgrading any hardware with this release. I am a bit hesitated to upgrade the controller to this version. I would prefer to upgrade to a stable version, but not sure if 4.7.6 would fix our wifi connection issues.

Ubiquiti Employee
Posts: 7,528
Registered: ‎03-17-2015
Kudos: 4830
Solutions: 197

Re: Intermittent connectivity loss with UAP-AC-PRO

Please give 4.7.6 a go. My suspicion is it will solve the problem indeed.
Want to try out new features or fixes before they're released as Stable? Sign up for Beta here: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Signup-for-Beta-Access
New Member
Posts: 32
Registered: ‎11-01-2015
Kudos: 5
Solutions: 1

Re: Intermittent connectivity loss with UAP-AC-PRO

Thanks Brandon,

 

I just upgraded the controller to v4.7.6 and updated the APs' firmware to 3.4.8.3291. We will see whether our users still have issues next week. I will keep this thread updated.

New Member
Posts: 32
Registered: ‎11-01-2015
Kudos: 5
Solutions: 1

Re: Intermittent connectivity loss with UAP-AC-PRO

After the controller and AP firmware upgrade we still have one user reporting the issue once. I'll see how this is going in the new year and keep this thread updated.
New Member
Posts: 1
Registered: ‎12-19-2015

Re: Intermittent connectivity loss with UAP-AC-PRO

After we tried v4.7.6 and v4.8.7 on linode, still facing same issue here. Is it possible ubnt team could help us (e.g. looking into log files)? It's unacceptable to keep asking clients to restart their wifi function. Man Indifferent

Ubiquiti Employee
Posts: 7,528
Registered: ‎03-17-2015
Kudos: 4830
Solutions: 197

Re: Intermittent connectivity loss with UAP-AC-PRO

Thanks for reporting @qiaohu.  Could you please share the make/model and firmware/software versions of the client experiencing the problem?

 

Thanks in advance,

Brandon

Want to try out new features or fixes before they're released as Stable? Sign up for Beta here: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Signup-for-Beta-Access
Ubiquiti Employee
Posts: 7,528
Registered: ‎03-17-2015
Kudos: 4830
Solutions: 197

Re: Intermittent connectivity loss with UAP-AC-PRO

@ichien

 

Definitely.  Could you please PM me nutty.io links (don't post here) for the APs and also send me the support file for the controller?

 

Also, what are make/model of the clients experiencing the problems?

 

Thanks in advance,

Brandon

Want to try out new features or fixes before they're released as Stable? Sign up for Beta here: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Signup-for-Beta-Access
New Member
Posts: 8
Registered: ‎12-20-2015

Re: Intermittent connectivity loss with UAP-AC-PRO

I'm having the same problem. The clients with the problem are a MacBook Pro (Retina, 15-inch, Mid 2015), MacBook (Retina, 12-inch, Early 2015), and iPhone 6s.

Ubiquiti Employee
Posts: 7,528
Registered: ‎03-17-2015
Kudos: 4830
Solutions: 197

Re: Intermittent connectivity loss with UAP-AC-PRO

Thanks for reporting.  What UniFi version are you running?

Want to try out new features or fixes before they're released as Stable? Sign up for Beta here: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Signup-for-Beta-Access
New Member
Posts: 8
Registered: ‎12-20-2015

Re: Intermittent connectivity loss with UAP-AC-PRO

I've tried both 4.7.6 and 4.8.9 beta.

Reply