Reply
Regular Member
Posts: 438
Registered: ‎03-15-2012
Kudos: 123
Solutions: 7

Re: Intermittent connectivity loss with UAP-AC-PRO


UBNT-Brandon wrote:

Okay, thanks.  The latest RC should likely help in your case.  IIRC, you're still on the latest stable, which I think may have some problems in this regard.

 

We are hoping to have the latest RC into stable late next week.

 


When you say the "latest RC", you are talking about 4.8.10?

 

Ubiquiti Employee
Posts: 7,528
Registered: ‎03-17-2015
Kudos: 4815
Solutions: 197

Re: Intermittent connectivity loss with UAP-AC-PRO

Yes, that's correct, 4.8.10.  

 

And 4.8.10 w/ custom upgrade to 3.4.13 contains the most hot-fixes for Gen2 hardware (UAP-AC-Pro/UAP-AC-LR/UAP-AC-LITE). 

 

Thanks,

Brandon

 

 

Want to try out new features or fixes before they're released as Stable? Sign up for Beta here: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Signup-for-Beta-Access
Regular Member
Posts: 438
Registered: ‎03-15-2012
Kudos: 123
Solutions: 7

Re: Intermittent connectivity loss with UAP-AC-PRO


UBNT-Brandon wrote:

Yes, that's correct, 4.8.10.  

 

And 4.8.10 w/ custom upgrade to 3.4.13 contains the most hot-fixes for Gen2 hardware (UAP-AC-Pro/UAP-AC-LR/UAP-AC-LITE). 


I'm running 4.8.10, but not f/w 3.4.13 (with UAP-AC-PROs), should I do the custom upgrade? // does it address the connectivity issues (e.g. the ones that appear to be related to WLAN schedule?).

 

Thanks!

 

Ubiquiti Employee
Posts: 7,528
Registered: ‎03-17-2015
Kudos: 4815
Solutions: 197

Re: Intermittent connectivity loss with UAP-AC-PRO

@snowball  Unfortunately, no, the WLAN schedule bug is not fixed in 3.4.13 (we actually didn't see the bug until after 3.4.13 was complete).  We have reproduced that WLAN schedule problem and narrowed it problem down to several lines of code, though.  We will be releasing a fix for it once we have it (I'll do a post warning about it for now).

 

@kyled After you upgraded to the 'sriram' build you said the intermittent connectivity problems went away but connection from iPhones was not working.  Are the iPhone connections not working still?

 

Thanks,

Brandon

Want to try out new features or fixes before they're released as Stable? Sign up for Beta here: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Signup-for-Beta-Access
New Member
Posts: 8
Registered: ‎12-20-2015

Re: Intermittent connectivity loss with UAP-AC-PRO

No, the iPhones are connected now. After turning wifi off and on again on them they were able to connect. It happened twice on one phone and once on another

Ubiquiti Employee
Posts: 7,528
Registered: ‎03-17-2015
Kudos: 4815
Solutions: 197

Re: Intermittent connectivity loss with UAP-AC-PRO

@kyled Thanks for reporting.

 

Please do let us know if you experience any weird behavior going forward.

 

Thanks,

Brandon

Want to try out new features or fixes before they're released as Stable? Sign up for Beta here: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Signup-for-Beta-Access
New Member
Posts: 32
Registered: ‎11-01-2015
Kudos: 5
Solutions: 1

Re: Intermittent connectivity loss with UAP-AC-PRO

@UBNT-MikeD Thanks Mike. This firmware is for UAP-AC-PRO right?

 

BTW what's UAP-ACv2 ? Is it a hardware model? How can I tell if my UAP-AC-PRO's version?

Ubiquiti Employee
Posts: 7,528
Registered: ‎03-17-2015
Kudos: 4815
Solutions: 197

Re: Intermittent connectivity loss with UAP-AC-PRO

Yes, the UAP-AC-PRO, UAP-AC-LR, and UAP-AC-LITE.

 

The UAP-AC and UAP-ACv2 are older (square case) UniFi AC AP.

 

BR,

Brandon

Want to try out new features or fixes before they're released as Stable? Sign up for Beta here: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Signup-for-Beta-Access
New Member
Posts: 14
Registered: ‎01-18-2016

Re: Intermittent connectivity loss with UAP-AC-PRO

Hi there everyone,

 

Same problem here with controller 4.7.6 (prev 4.7.5) on windows 2003 and firmware provided by them (3.2.12.2920).

We have 4 APs PRO, 2 in one floor and other 2 in another floor in a Zero Handoff configuration on channels 1 (2.4 ghz) and 36 (5 ghz). Channel 1 on 2.4ghz spectrum was tested free for what I remember. There aren't other strong signals near. Using a Cisco RV042 router for DHCP, an disabled on the Ubiquiti controller. APs have static IP addresss out of the DHCP range. Having the same problem on Windows PCs, Mac and Iphones.

 

For what I've tested connected on wireless, the PC doesn't disconnect from the wireless net, but at simple view it's like loose IP connectivity. At that momento, I've made ping to the 4 APs and saw time out for 5 seconds and then recovering from 4000 ms to normal in the next 10 ICMP packets. So normally the interrumption happens for about 15 second each time, like 4 - 5 times a day.

 

So Brandon, can you tell me at today if using the controller beta version 4.8.10 and fw 3.4.13 will solve my problem?

We have this solution installed on a customer in a very sensitive situation, so we don't want to test to much on that network without having some certain on if this is going to fix the problem. What do you recommend?

I finished to install a win7 PC with a wifi usb card to leave on the network to monitor wifi connection. I can give you full access to this PC and the controller PC/APs if will be helpful to debug the problem.

 

Thanks in advance and I'll be waiting for your answer ASAP.

 

Regards,

Juan

 

ubi.JPG

 

 

New Member
Posts: 14
Registered: ‎01-18-2016

Re: Intermittent connectivity loss with UAP-AC-PRO

[ Edited ]

Just to add.

 

- 4 APs are wired to a switch by FE 100M.

- 4 APs radio using HT20.

- I've the opportunity to test at the same moment making ping to the 4 APs over wired LAN and latency was 1-2 ms, but at the same time with other laptop over wifi the ping to the 4 APs went time out, and then recovering from 4000 ms to normal 1-5 ms in the next 10 icmp packets (4000, 3500, 3000, 2000, 1000, 800, 500, 200, 10 ms, something like that). So obviously I dismiss a problem on the wired network or internet itself.

Ubiquiti Employee
Posts: 3,373
Registered: ‎01-11-2016
Kudos: 1049
Solutions: 25

Re: Intermittent connectivity loss with UAP-AC-PRO

@elkato, can you check to see if you have WLAN scheduling enabled? Please check each individual SSID.

 

Want to try out new features or fixes before they're released as Stable? Sign up for Beta here: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Signup-for-Beta-Access
Having connectivity issues? See: https://help.ubnt.com/hc/en-us/articles/221029967-UniFi-Debugging-Intermittent-Connectivity-Issues-on-your-UAP
New Member
Posts: 14
Registered: ‎01-18-2016

Re: Intermittent connectivity loss with UAP-AC-PRO

WLAN schedule DISABLED in all (two, corporate and guest) SSIDs.

Unscheduled Automatic Power Save Delivery DISABLED in all SSIDs too.

 

So, can you tell me about my questions on the message before please? or if you need more information please let me know.

 

Thanks

 

Ubiquiti Employee
Posts: 7,528
Registered: ‎03-17-2015
Kudos: 4815
Solutions: 197

Re: Intermittent connectivity loss with UAP-AC-PRO

@elkato UniFi Controler 4.8.10 w/ 3.4.13 will likely solve your problems.  

There are still bugs we are squashing and releasing to RC again this week, but 4.8.10 w/ 3.4.13 has much fewer known issues than 4.7.6 and its bundled FW (that's why we're pushing so hard to fix remaining bugs and get to GA).

 

BR,

Brandon

Want to try out new features or fixes before they're released as Stable? Sign up for Beta here: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Signup-for-Beta-Access
New Member
Posts: 14
Registered: ‎01-18-2016

Re: Intermittent connectivity loss with UAP-AC-PRO


UBNT-Brandon wrote:

@elkato UniFi Controler 4.8.10 w/ 3.4.13 will likely solve your problems.  

There are still bugs we are squashing and releasing to RC again this week, but 4.8.10 w/ 3.4.13 has much fewer known issues than 4.7.6 and its bundled FW (that's why we're pushing so hard to fix remaining bugs and get to GA).

 

BR,

Brandon


Ok Brandon. Good to know.

Last questions.

- I have 4.7.6 and fw bundled now. Can I upgrade firmware from controller after upgrading it first?

- Can I downgrade back to 4.7.6 and bundled firmware (3.2.12.xxxx) if I see something terrible wrong after upgrade? And how to do it?

 

I will go to the customer tomorrow, and I want to have all information if something go wrong.

thx

Ubiquiti Employee
Posts: 7,528
Registered: ‎03-17-2015
Kudos: 4815
Solutions: 197

Re: Intermittent connectivity loss with UAP-AC-PRO

@elkato

 

- I have 4.7.6 and fw bundled now. Can I upgrade firmware from controller after upgrading it first?

 

Yes.  You could alternatively use SSH to use 3.4.13 w/ the 4.7.6 controler.

Steps:

1. Turn off automatic upgrade in the controller.

2. Update the APs to 3.4.13 by using the steps here.  3.4.13 FW link is here

 

- Can I downgrade back to 4.7.6 and bundled firmware (3.2.12.xxxx) if I see something terrible wrong after upgrade? And how to do it?

 

Please wait for @UBNT-Amber to confirm the steps below:

 

Steps:

  1. Do backup of controller first.  Make sure saved in a safe place.
  2. Upgrade to the new controller.
  3. IF all goes awry, uninstall new controller.
  4. Install old controller and restore from backup.

 

Best Regards,

Brandon

Want to try out new features or fixes before they're released as Stable? Sign up for Beta here: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Signup-for-Beta-Access
Ubiquiti Employee
Posts: 679
Registered: ‎03-31-2015
Kudos: 122
Solutions: 57

Re: Intermittent connectivity loss with UAP-AC-PRO

Hi @elkato,

 

The steps provided by @UBNT-Brandon are the correct. Just remember to always back up your controller before installing a newer version Smiley Happy

New Member
Posts: 21
Registered: ‎01-21-2016
Kudos: 1

Re: Intermittent connectivity loss with UAP-AC-PRO

I recently got and installed a UAP-AC-Lite and I'm experiencing this.  Every rand(10, 45) minutes I lose between 1 and 5 ping responses on a 1 second interval ping.  It's enough to cause devices to drop TCP connections, etc.  I was running on 4.7.6, but after reading through this signed up for beta and installed 4.8.10RC and tried both the firmware in it and the 3.4.13.3400 firmware.  Problem seems to continue to exist regardless.  I don't have power saving or any schedules enabled.

 

While I see packet loss I do not see any indication of an actual disconnect of the client from the AP - it seems like the AP just ceases to forward traffic upstream for ~1-5 seconds at a time.

 

Any suggestions or is there any other diagnostics I can provide?

Ubiquiti Employee
Posts: 7,528
Registered: ‎03-17-2015
Kudos: 4815
Solutions: 197

Re: Intermittent connectivity loss with UAP-AC-PRO

Hi @shadowimg,

 

Sorry for the trouble here.  We found (and we think) fixed another two intermittent connectivity problems for 5GHz after the last posted Beta FW.

 

Could you give this latest FW a try and see if it fixes your issue?

 

https://dl.ubnt.com/unifi/custom/BZ.qca956x.v3.4.14.3413.160119.2258-uboot (1).bin

 

Also, this problem (if it's the one I'm thinking of) should only exist on 5GHz.  Could you confirm whether or not you are seeing this on 2.4GHz connectivity also?

 

Thanks in advance,

Brandon

Want to try out new features or fixes before they're released as Stable? Sign up for Beta here: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Signup-for-Beta-Access
New Member
Posts: 21
Registered: ‎01-21-2016
Kudos: 1

Re: Intermittent connectivity loss with UAP-AC-PRO

I am most definitely seeing this on 2.4Ghz still.  One of my troubleshooting steps was to entirely disable the 5GHz radio to make sure my problem wasn't from band hopping.

 

I will still try that firmware though, can't hurt!

Ubiquiti Employee
Posts: 7,528
Registered: ‎03-17-2015
Kudos: 4815
Solutions: 197

Re: Intermittent connectivity loss with UAP-AC-PRO

[ Edited ]

@shadowimg Thanks for confirming that this is occuring on 2.4GHz also.

 

  1. Do you have uplink connectivity monitor enabled in the controller?
  2. Do you have bandsteering enabled? 
  3. What is providing DHCP on the network?
  4. Could you draw your network diagram?
  5. What clients are experiencing the problem?

Thanks,

Brandon

Want to try out new features or fixes before they're released as Stable? Sign up for Beta here: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Signup-for-Beta-Access
Reply