Reply
New Member
Posts: 25
Registered: ‎02-03-2015
Kudos: 6

Macbook Pro Tx Rate with UAP-AC-Pro

[ Edited ]

Hi,

 

I have noticed that devices connected to our AC-Pro seem limited in their Tx rate to 878 Mbps rather than 1300 Mbps. When testing the AC-Lite, devices were able to connect at the max rate of 867 Mbps. Additionally, testing the devices with the Aiport Extreme AC saw a 1300 Mbps Tx rate.

 

I was wondering if anyone had any thoughts on if this issue can be fixed through any configuration changes that I can make or if this is expected behavior.

 

Relevant Device and Configuration Information:

Test Device: Late 2013 15" Macbook Pro and ThinkPad T540p

5 GHz channel: 36 (Also tested on 161)

Width: 80 MHz

WPA Mode: WPA2 Only – AES/CCMP Only

Number of SSID's being broadcast: 1

Uplink Connectivity Monitor: Disabled

DPI: Disabled

UAPSD: Disabled

Controller Version: 5.0.6

Device Firmware Version: 3.7.5.4969

 

Screen Shot 2016-05-31 at 15.53.22.png

 

Thanks!

UniFi AC Pro | UniFi AC Lite | EdgeRouter Lite | UniFi Switch 16 | UniFi Cloud Key
Senior Member
Posts: 3,481
Registered: ‎05-13-2015
Kudos: 965
Solutions: 93

Re: Macbook Pro Tx Rate with UAP-AC-Pro

This should actually be in the beta thread.

 

You don't happen to have guest on?

New Member
Posts: 25
Registered: ‎02-03-2015
Kudos: 6

Re: Macbook Pro Tx Rate with UAP-AC-Pro

[ Edited ]

Sango wrote:

This should actually be in the beta thread.

 

You don't happen to have guest on?


Apologies if this is in the wrong forum; if a moderator can move the thread, it would be appreciated. I have seen this behavior across past released and beta firmwares.

 

I do not have guest on.

UniFi AC Pro | UniFi AC Lite | EdgeRouter Lite | UniFi Switch 16 | UniFi Cloud Key
New Member
Posts: 25
Registered: ‎02-03-2015
Kudos: 6

Re: Macbook Pro Tx Rate with UAP-AC-Pro

[ Edited ]

With further testing, I have noticed that the Macbook Pro connects to the AC Pro initially with a Tx rate of 1170 Mbps; however, once the Mac receives an IP address from the router (ERLite3), the Tx rate drops to, and remains at, 878 Mbps.

UniFi AC Pro | UniFi AC Lite | EdgeRouter Lite | UniFi Switch 16 | UniFi Cloud Key
New Member
Posts: 4
Registered: ‎02-26-2017
Kudos: 1

Re: Macbook Pro Tx Rate with UAP-AC-Pro

[ Edited ]

Hi,

have you found a solution for this problem? I have the exact same issue.

 

I have a TX rate of around 260 Mbps and I'm around 3 meters away from the AP without any walls

 

Screen Shot 2017-02-26 at 17.48.40.png

I bought the Unify just for its pro perfomances but it appears that it's slower that a normal AC accesspoint

Senior Member
Posts: 2,936
Registered: ‎03-25-2014
Kudos: 910
Solutions: 40

Re: Macbook Pro Tx Rate with UAP-AC-Pro

Let's page @UBNT-Brandon so at least he is aware of this.

Thanks,
David S.
Ubiquiti Certified - UEWA / UCWA
Senior Member
Posts: 4,136
Registered: ‎01-04-2017
Kudos: 567
Solutions: 196

Re: Macbook Pro Tx Rate with UAP-AC-Pro


Tex-Twil wrote:

Hi,

have you found a solution for this problem? I have the exact same issue.

 

I have a TX rate of around 260 Mbps and I'm around 3 meters away from the AP without any walls

 

Screen Shot 2017-02-26 at 17.48.40.png

I bought the Unify just for its pro perfomances but it appears that it's slower that a normal AC accesspoint


Create your own thread.  you do not have the same problem as him.  Describe your problem in detail, including what settings your currently using.

Member
Posts: 235
Registered: ‎12-30-2014
Kudos: 71
Solutions: 9

Re: Macbook Pro Tx Rate with UAP-AC-Pro


-Brent- wrote:

Hi,

 

I have noticed that devices connected to our AC-Pro seem limited in their Tx rate to 878 Mbps rather than 1300 Mbps. When testing the AC-Lite, devices were able to connect at the max rate of 867 Mbps. Additionally, testing the devices with the Aiport Extreme AC saw a 1300 Mbps Tx rate.

 


 

I see something very similer. 2015 Macbook Pro and AC-Pro running latest firmware will normally connect at 878. Occasionally higher.

The AP is about 10ft away.

When I put a Sophos AP100 in the same place (UAP is disconnected), I connect at 1300 every time.

 

That said, when running iperf3 between the Macbook and a Linux host on wired gigabit (using the same wiring / switch) the Sophos AP100 will drop down to 878, but UAP won't change.

Actual throughput between them both is around 430mbits/sec on 5ghz. i.e. the initial connect speed doesnt seem to matter to throughput.

 

Perhaps worth doing the same with the Airport Extreme to see what the throughput is?

 

New Member
Posts: 4
Registered: ‎02-26-2017
Kudos: 1

Re: Macbook Pro Tx Rate with UAP-AC-Pro

[ Edited ]

goldlineIT wrote:
Create your own thread.  you do not have the same problem as him.  Describe your problem in detail, including what settings your currently using.

  To me it seems like a very similar problem (same hardware, same wireless client, same symptomps) so I though I'd ask here in case the OP found a solution. Sorry if it bothered you,  I will open a new topic 

 

 


snapper wrote:

I see something very similer. 2015 Macbook Pro and AC-Pro running latest firmware will normally connect at 878. Occasionally higher.

The AP is about 10ft away.

When I put a Sophos AP100 in the same place (UAP is disconnected), I connect at 1300 every time.

 

That said, when running iperf3 between the Macbook and a Linux host on wired gigabit (using the same wiring / switch) the Sophos AP100 will drop down to 878, but UAP won't change.

Actual throughput between them both is around 430mbits/sec on 5ghz. i.e. the initial connect speed doesnt seem to matter to throughput.

 

Perhaps worth doing the same with the Airport Extreme to see what the throughput is?

 


I measured the throughput with a (wired) macOS iperf3 server. With the Airport Etreme  I get around 430Mbps, using the Unify AP,  around 300 Mbps.

 

I think I will finally stick with the Airport Extreme as AP

 

Thanks for your help

Ubiquiti Employee
Posts: 7,528
Registered: ‎03-17-2015
Kudos: 4805
Solutions: 197

Re: Macbook Pro Tx Rate with UAP-AC-Pro

Can anyone experiencing this share the datecode of the AC-PRO (simply a picture of the back of the unit will suffice).

If an antenna or similar is damaged it could cause this behavior... will want to start by knowing when these were made, and audit our logs.

We may also want to swap these out so we can inspect them.

Thanks,
Brandon
Want to try out new features or fixes before they're released as Stable? Sign up for Beta here: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Signup-for-Beta-Access
Member
Posts: 235
Registered: ‎12-30-2014
Kudos: 71
Solutions: 9

Re: Macbook Pro Tx Rate with UAP-AC-Pro


UBNT-Brandon wrote:
Can anyone experiencing this share the datecode of the AC-PRO (simply a picture of the back of the unit will suffice).

If an antenna or similar is damaged it could cause this behavior... will want to start by knowing when these were made, and audit our logs.

We may also want to swap these out so we can inspect them.

Thanks,
Brandon

@UBNT-BrandonThis is one of mine, the other needs a ladder, but should be the same.

Both were brought at the same time and were from the first batch to hit the UK last year...

 

IMG_0823.jpg

 

New Member
Posts: 19
Registered: ‎11-26-2016
Kudos: 2

Re: Macbook Pro Tx Rate with UAP-AC-Pro

I'm seeing the same thing from my Macbook Pro 2013, except that I notice it reports a country code of DE.

Screen Shot 2017-02-27 at 11.14.51 pm.png

 

 

 

 

Ubiquiti Employee
Posts: 7,528
Registered: ‎03-17-2015
Kudos: 4805
Solutions: 197

Re: Macbook Pro Tx Rate with UAP-AC-Pro

@Howgol - what country is your controller set to? And where are you located?

And what distance is the device from the AP when you see this -62dBm reading?
Want to try out new features or fixes before they're released as Stable? Sign up for Beta here: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Signup-for-Beta-Access
New Member
Posts: 19
Registered: ‎11-26-2016
Kudos: 2

Re: Macbook Pro Tx Rate with UAP-AC-Pro

 

@UBNT-Brandon The controller is definately set to United Kingdom (as it should be) but seeing Country Code DE reported by the MacBook Pro. The TX rate shown below is about as good as it ever gets.  

 

I'm located around 2 or 3m away from the UAP when seeing these (slightly better) results:

 

Screen Shot 2017-02-28 at 8.34.24 pm.png

New Member
Posts: 19
Registered: ‎11-26-2016
Kudos: 2

Re: Macbook Pro Tx Rate with UAP-AC-Pro

Looking at the chart at mcsindex.com I assume that a reported MCS Index of 7 and TX rate of 878Mbps implies that the connection is only running at 64-QAM 5/6 modulation rather than achieving 256-QAM 5/6 and an SGI of 800ns rather than 400ns (not that I really understand all of that!)

Ubiquiti Employee
Posts: 7,528
Registered: ‎03-17-2015
Kudos: 4805
Solutions: 197

Re: Macbook Pro Tx Rate with UAP-AC-Pro

Thanks. Analyzing/investigating. Will probably reach out offline.
Want to try out new features or fixes before they're released as Stable? Sign up for Beta here: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Signup-for-Beta-Access
New Member
Posts: 19
Registered: ‎11-26-2016
Kudos: 2

Re: Macbook Pro Tx Rate with UAP-AC-Pro

Looking at this further it's clear that the MacBook and the Unifi controller have a different opinion about the connection speed of the MacBook. When I monitor the controller statistics and MacBook Wifi details side-by-side in real-time I can see that the controller is always reporting a higher connection speed - sometimes as high as 1300Mbps. Here are some examples:

Screen Shot 2017-02-28 at 10.43.11 pm.png

 

 

Screen Shot 2017-02-28 at 10.52.18 pm.png

 

 

The two systems weren't sampling at exactly the same time so some differences could be a question of timing variation, but the difference was always there. So, the question is, which reading is the correct one?

 

BTW, I'm running controller version 5.3.8 on a cloudkey and the UAP-AC-Pros are on firmware 3.7.29

Ubiquiti Employee
Posts: 7,528
Registered: ‎03-17-2015
Kudos: 4805
Solutions: 197

Re: Macbook Pro Tx Rate with UAP-AC-Pro

 

So the Macbook Pro as you can see only knows it's own Tx rate.

 

As you know when one thing is talking (Txing) the other thing needs to be listening (Rxing) from it's perspective.

 

So that is to say the Tx Rate as shown by the Macbook Pro is the Rx Rate as shown by the statistics for the UAP-AC-PRO.

 

Also, these are updated periodically to the controller, and there is of course delay.

 

The AP can send at a higher power than the Macbook Pro, so it makes sense that the Tx Rate of the AP will be higher than the Tx Rate of the Macbook Pro - as there is higher signal-to-noise in that direction.

 

Thanks,

Brandon

Want to try out new features or fixes before they're released as Stable? Sign up for Beta here: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Signup-for-Beta-Access
New Member
Posts: 25
Registered: ‎02-03-2015
Kudos: 6

Re: Macbook Pro Tx Rate with UAP-AC-Pro

Sorry for the delayed response – I was apparently not subscribed to my own thread! Unfortunately, even with all of the firmware and controller updates since I posted this thread, I have not found a solution.

 


Tex-Twil wrote:

Hi,

have you found a solution for this problem? I have the exact same issue.

 

I have a TX rate of around 260 Mbps and I'm around 3 meters away from the AP without any walls

 

UniFi AC Pro | UniFi AC Lite | EdgeRouter Lite | UniFi Switch 16 | UniFi Cloud Key
New Member
Posts: 25
Registered: ‎02-03-2015
Kudos: 6

Re: Macbook Pro Tx Rate with UAP-AC-Pro

[ Edited ]

UBNT-Brandon wrote:
Can anyone experiencing this share the datecode of the AC-PRO (simply a picture of the back of the unit will suffice).

If an antenna or similar is damaged it could cause this behavior... will want to start by knowing when these were made, and audit our logs.

We may also want to swap these out so we can inspect them.


@UBNT-Brandon Both of my AC-Pro units have test dates of 9/20/15. The codes from the labels on the box are (G) 0418D6C0B256 and (G) 0418D6C0B204.

 

I can get the codes from the back of the units if necessary.

UniFi AC Pro | UniFi AC Lite | EdgeRouter Lite | UniFi Switch 16 | UniFi Cloud Key
Reply