Reply
Emerging Member
Posts: 74
Registered: ‎02-25-2012
Kudos: 8
Solutions: 1

Reverse Picostation m2 from unifi to AirOs

Hello!
i know the side note told me:
- This process is one way. There's no plan to release a tool to reverse it
But i need to know if there is really NO way to do this?
It doesn't have to be simple.. But maybe via SSH? Ftpd? or something..

Edit:
Sorry for my quick post.. I found the answer.... Yes you can!!!
forum.ubnt.com/showthread.php?t=45073
New Member
Posts: 1
Registered: ‎03-28-2017
Kudos: 2

Re: Reverse Picostation m2 from unifi to AirOs

[ Edited ]

Good Day People,

 

First off, I appologize for resurrecting such an old post, but my hopes are that it will help someone and spare them the frustrasion I had over the last few weeks. 

 

My setup here is 81 Picostation M2HP's, all date coded the later versions with DC:9F MAC addresses. All AP's are installed in a Hotel, eye level between rooms in service panels. The placement worked better than mounting them anywhere else, as well as we wanted the AP's hidden out of the public eye

.

I was hoping to create a more manageble network by moving all my Picostation M2's over to UniFi firmware and have a controller at hand. In theory, it was great, I could see all AP's from a central point and have all the advantages of seeing in real time what happens to each AP. Upgrade them, change settings with ease. Only problem is, my signal quality took a serious knock, including the ability for a veriaty of devices to maintain a stable connection, 90% of them Apple products.

 

So, I have been looking for a solution to this hoping there was a fix while remaining on UniFi firmware, but sadly none that I could find. While working my way through the forums came accross many threads on how it can be done and/or should be done. In the end the result was clear, return to AirOS. 

 

My problem experienced was that no matter what I did, non of my Pico's would go into TFTP mode as per all the instructions. The lights would flash indicating TFTP mode, but the base IP of 192.168.1.20 would be unreachable and the device couldn't be discovered with the Ubiquiti Discovery tool. So, through trial and error, this here below is my sequence of getting Picostations back from UniFi firmware to AirOS.

 

I used a Windows machine, with Putty as SSH client and Windows TFTP enabled under Windows features. While the later date code of my AP's meant I the 5.3.3 firmware as provided in the UniFi2AirOS.bin file is not supported on my AP's, the modified firmware string in the file allows for a base to work from where else the firmware upgrade would fail with any newer firmware. My guess is the UniFi firmware on the AP would not recognise the correct firmware due to differences between UniFi and AirOS. In preperation of the new firmware being easy to work with, I downloaded V6.0.1 and renamed the file firmware.bin and placed it in created folder c:\firmware

 

1. SSH into the device on the DHCP provided or IP address assigned in the coutroller. Use your Controller Username and Password to log in when requested.

2. Run the following command. "upgrade http://community.ubnt.com/attachments/ubnt/UniFi/41681/1/UniFi2AirOS.bin" The firmware upgrade will commence, AP will reboot and will be in an unreachable state as you are now running firmware 5.3.3.

3. Unplug the power to the AP, hold the reset button and plug power back in. The AP will boot and after 5-8 seconds, the signal LED's will light up one by one. Once all lights are on, release the reset button and the signal LED's will alternately flash indicating TFTP mode. You will now be able to ping the device on Base IP 192.168.1.20.

4. Open a Windows commmand prompt with Admin Rights. navigate to the folder where your latest firmware is, c:\firmware in my case. run the following command from the firmware folder "tftp -i 192.168.1.20 put firmware.bin"

 

The AP will now flash the latest firmware, reboot itself and thereafter will be reachable on the base IP as it would when it came out of the box.

 

My apologies for the long post, but I hope this will help someone coming into the same problems I did.

 

Highlighted
New Member
Posts: 6
Registered: ‎08-25-2016

Re: Reverse Picostation m2 from unifi to AirOs

Thanks to your procedure and information I solved my problem
Reply