Reply
Highlighted
New Member
Posts: 15
Registered: ‎12-06-2015
Kudos: 1
Accepted Solution

Setting a Management VLAN for UAP-AC-PRO

Hello,

 

I have two UAP-AC-PRO connected to a US-48. I am having trouble configuring the managment VLAN on the APs.

 

My management vlan is VLAN 2 and the subnet for that is 10.52.0.0/24

 

My WIFI network is 10.54.0.0/24 and has two SSIDs (both VLAN 4).

 

The Controller is in VLAN 7 in 10.55.0.0/24

 

Since the WAPs have to carry traffic for tree VLANs, I think I have to:

 

  • create a Switch Port Profile (call it WAP VLAN) include those three VLANs (I'll use VLAN 1 for the Native VLAN).
  • In the US-48 ports for the WAP, select WAP VLAN in the Switch Port Profile. I suppose I could use All

But this doesn't work.  The WAP never comes back to the controller.

 

Am I taking the wrong approach?

 

Thank you.


Accepted Solutions
Emerging Member
Posts: 549
Registered: ‎09-24-2017
Kudos: 94
Solutions: 43

Re: Setting a Management VLAN for UAP-AC-PRO

The UAP devices must have an untagged network to function properly. That is the network that will be used for management... so on your switch, make sure that VLAN 2 is set as the PVID (default/untagged) of the physical port that you're using for the UAP-AC-PRO. VLAN 4 should be configured as a tagged network (VID) on that port. Double check to make sure your router and switch have both VLAN 2 and VLAN 4 connected and configured on the relvant ports (likely a trunk port), and make sure your DHCP servers are working properly for both VLANs.

View solution in original post


All Replies
New Member
Posts: 15
Registered: ‎12-06-2015
Kudos: 1

Re: Setting a Management VLAN for UAP-AC-PRO

This morning I tried this approach:

 

  • Set the VLAN for the Wireless Network to 4
  • Set the Switch Port Profile for the switch port to VLAN 2 (maintenance)

I see the DHCPDISCOVER at the DHCP servers, and I see both the DHCPOFFER & DHCPACK for a 10.52.0.0/24 address, as expected.

 

However, the WAP was not connecting to the contoller.  I noticed that the DHCP server was missing the 'option ubnt.unifi-address delaration in the 'subnet 10.52.0.0 netmask 255.255.255.0' directive.  After adding that, restarting dhcpd, and power cycling the WAP, the WAP appeared in the controller for adoption.

 

After adopting, everything seems fine in the controller, however, clients cannot obtain a lease.

 

WIth some experimentation, I found a solution:

 

  • Under Controller | Profiles | Switch Ports, click on Add A New Profile.
  • Profile Name = For WAPs
  • Native VLAN = Maintenance
  • Under Tagged Networks, click on WIFI

Save

 

The port on the switch for this WAP needs to have 'Switch Port Profile' set to 'For WAPs'.

 

You might have to power cycle the WAP, but this got me started.

 

 

 

Emerging Member
Posts: 549
Registered: ‎09-24-2017
Kudos: 94
Solutions: 43

Re: Setting a Management VLAN for UAP-AC-PRO

The UAP devices must have an untagged network to function properly. That is the network that will be used for management... so on your switch, make sure that VLAN 2 is set as the PVID (default/untagged) of the physical port that you're using for the UAP-AC-PRO. VLAN 4 should be configured as a tagged network (VID) on that port. Double check to make sure your router and switch have both VLAN 2 and VLAN 4 connected and configured on the relvant ports (likely a trunk port), and make sure your DHCP servers are working properly for both VLANs.

New Member
Posts: 15
Registered: ‎12-06-2015
Kudos: 1

Re: Setting a Management VLAN for UAP-AC-PRO

Sounds good.

 

In my case, I'm using a Unifi switch, and was not correctly configuring the port.

 

Cheers.

Reply