Reply
Highlighted
New Member
Posts: 12
Registered: ‎09-17-2018
Accepted Solution

Slow Wifi Speeds on AP-AC Pro

Hi All, 

 

I've seen so many posts complaining regarding the wifi speed issue of AC Pro, but still dont have clarity over there.

 

So my config is as follows:

- USG-3 

- US-8 60W

- 1x nanoHD

- 1x AC Pro

- Cloud Key

 

All fw are up to date. 

 

Symptoms: I could get only around 200-300Mbit/s wifi speed from the APs. I have a fiber gigabit internet, my wired PC can get around 910-950Mbit/s (via the USG), but my Android phoned usually gets only 200-300 Mbit (maximum, the average of multiple tests is lower). 

I've played a lot of time with channel width (40 for 2,4 radio and vth80 for 5ghz), with TX power (medium for 2,4 and high for 5ghz), ATF on/off, but still no luck.

With my legacy Tplink archer 5400x I could get almost 500 Mbit with the same setup. 

I cant believe that such expensive kit (usg, us8, nanohd and as pro is mivh more expensive than my legacy archer) could get only that speed.

The APs are wall mounted, no disturbing/busy channels nearby (on 5GHz my device was the only one within 500 meters), I've measured all of my tests in 3m far from the AP.

 

That's all, what Unifi can give to me? Has anybody better experience with the same setup above? 

 

Any advice is greatly appreciated  

 


Accepted Solutions
Established Member
Posts: 1,930
Registered: ‎03-31-2017
Kudos: 703
Solutions: 209

Re: Slow Wifi Speeds on AP-AC Pro

The Galaxy S7 on a MU-MIMO AP (your nanoHD) will drop to using only ONE spatial stream (instead of two) in order to share with other MU-MIMO clients.

One spatial stream will NOT get you ~500Mb throughput, it will only get you a PHY rate of 433Mb@80MHz channel width. Of that PHY rate you can expect 50 to 70 percent throughput depending on way to many factors to list (google "PHY vs TCP throughput").

Make sure you put the 5GHz channel width to VHT80 (80MHz) the default is HT40 (40MHz).

My AP cluster consists of a nanoHD, AC-PRO, AC-M, AC-IW. All of the APs are capable of doing >500Mbps throughput to a 2x2 client (Galaxy S9 which does not have that stupid design decision of dropping to a single spatial stream) and on my nanoHD with VHT160 I can reach just over 800Mbps tcp throughput to an Intel NUC VR with an intel 9260 card.

@Jardin_Espanol has almost one of every gen2 and gen3 AP and actually does controlled throughput testing with them. You can see his setup here; https://community.ubnt.com/t5/UniFi-Stories/Making-of-a-WiFi-Testing-Tower/cns-p/2527638

His testing log is here; https://docs.google.com/spreadsheets/d/1Kk-D5TNcm_-olg0kklhbDVO7GhgIJUIH356rq9mVse8/edit#gid=4792462...

View solution in original post


All Replies
Senior Member
Posts: 2,770
Registered: ‎01-29-2015
Kudos: 449
Solutions: 116

Re: Slow Wifi Speeds on AP-AC Pro

[ Edited ]

Your 2.4 should only be on 20.

 

Do you have IDS/IPS turned on at the USG? Is SmartQueues on?

Senior Member
Posts: 21,521
Registered: ‎08-04-2017
Kudos: 4057
Solutions: 1044

Re: Slow Wifi Speeds on AP-AC Pro

[ Edited ]

Hello @schferenc,

 

Put 2.4GHz to VHT20

 

Could you share the results from a throughput test ( Inside the UniFi APP )

 

Coul you post your system config?

Settings > Maintenance > Support Info > Show System Config

 

 

Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation Scripts | UniFi-VoIP Installation Scripts
USG-XG-8 • USG-4-PRO • USG
US-XG-16 • US-48-500W • US-24-POE-250W 2x • US-16-POE-150W 3x • US-24 • US-8-150W • US-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD 2x • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M • UAP-AC-M-PRO 2x
UAS-XG • UCK-G2-PLUS • UCK-G2 • UCK
New Member
Posts: 12
Registered: ‎09-17-2018

Re: Slow Wifi Speeds on AP-AC Pro

Hi, 

 

I've tried the 20 on 2,4 same result. Also I've created a separated 5ghz ssid only, the result is the same. 

Advanced features (IDS/IPS) are off  

 

The big question that can the Unifi AP (nano or ac pro) provide better throughput than 300 Mbit, or this is the max. Even if I could see over 400Mbit/s as connection speed (checking on controller's interface/clients menu) the speedtest on Android shows max 250-300Mbit.

And the most disturbing fact is that the legacy consumer router performed much better. 

 

Senior Member
Posts: 2,770
Registered: ‎01-29-2015
Kudos: 449
Solutions: 116

Re: Slow Wifi Speeds on AP-AC Pro

[ Edited ]

Where are you doing the speed test? Speedtest.net or something?

 

The only true way to determine if it is the AP is to run a throughput test from the Android Unifi client/app. See what that says. Make sure you are close to the AP. Also post the device you are running it from so the specs can be checked out, unless you know what the wifi specs are.

 

https://dl.ubnt.com/datasheets/unifi/UniFi_AC_APs_DS.pdf

3x3 devices can get a theoretical 1300 mbps.

New Member
Posts: 12
Registered: ‎09-17-2018

Re: Slow Wifi Speeds on AP-AC Pro

Hi, 

I'm not at home at the moment, so cant provide practical test and screenshots from the setup.

Re speedtest: I've used speedtest.net android app, as I alwas did it. I don't really see your point RoobieH, regarding the app what I've used, as exactly the same app showed almost 500Mbit/s with the legacy router.

I'm using Samsung Galaxy S7, I dont know the specs, but even if it is 1x1 only the device is capable for ~500mbit.

Established Member
Posts: 1,930
Registered: ‎03-31-2017
Kudos: 703
Solutions: 209

Re: Slow Wifi Speeds on AP-AC Pro

The Galaxy S7 on a MU-MIMO AP (your nanoHD) will drop to using only ONE spatial stream (instead of two) in order to share with other MU-MIMO clients.

One spatial stream will NOT get you ~500Mb throughput, it will only get you a PHY rate of 433Mb@80MHz channel width. Of that PHY rate you can expect 50 to 70 percent throughput depending on way to many factors to list (google "PHY vs TCP throughput").

Make sure you put the 5GHz channel width to VHT80 (80MHz) the default is HT40 (40MHz).

My AP cluster consists of a nanoHD, AC-PRO, AC-M, AC-IW. All of the APs are capable of doing >500Mbps throughput to a 2x2 client (Galaxy S9 which does not have that stupid design decision of dropping to a single spatial stream) and on my nanoHD with VHT160 I can reach just over 800Mbps tcp throughput to an Intel NUC VR with an intel 9260 card.

@Jardin_Espanol has almost one of every gen2 and gen3 AP and actually does controlled throughput testing with them. You can see his setup here; https://community.ubnt.com/t5/UniFi-Stories/Making-of-a-WiFi-Testing-Tower/cns-p/2527638

His testing log is here; https://docs.google.com/spreadsheets/d/1Kk-D5TNcm_-olg0kklhbDVO7GhgIJUIH356rq9mVse8/edit#gid=4792462...

New Member
Posts: 12
Registered: ‎09-17-2018

Re: Slow Wifi Speeds on AP-AC Pro

Hi, 

That's a very detailed answer, I really appreciate it. 

So the trick is with MU-MIMO and the design of S7 wifi system? This means, that any MU-MIMO router will provide same result for me (because they/or mx S7 will use only one spatial stream)?

Btw, this means that S7 has 2x2 design? 

Reply