Reply
New Member
Posts: 23
Registered: ‎09-13-2018

Speed issues with AP AC Pro

Hi,

 

I just got my equipment last week and have had some speed issues.  On my Google Pixel 2 and Lenovo Yoga X1 I was only getting around 200Mbps down.  After switching channel width of 5GHz to VHT80 I can now get 300Mbps.

 

I don't remember what my AT&T equipment was getting, but I think it was a lot faster.  I may have to hook it up again and see.

 

What speeds should I be getting on my Google Pixel 2?

 

When I go into my WiFi analyzer I thought there was some interference becuase another network showed up using the same frequency.  So I changed my frequency of the 5GHz and another phantom network showed up, again overlapping it.

I have to think this is the UAP itself doing this.  Has anyone seen this before?  See screenshots.  You can see it followed me when I changed the frequency.

wifi1.png
wifi2.png
Established Member
Posts: 966
Registered: ‎02-01-2014
Kudos: 265
Solutions: 32

Re: Speed issues with AP AC Pro

Hey Welcome to the community!

I also have the Pixel 2, well the XL version but pretty much the same. The wifi card in the Pixel 2's are only 2x2 Mimo. This means you won't get more than 400mbps even at the best times. If you are looking for 1300mbps you will need to buy a macbook pro from Apple. There are limited amount of devices that have 3x3 or 4x4 Mimo cards.

I was very sad too when I realized the phone was much slower. iphones above iphone 7 also have been wifi cards.
Established Member
Posts: 923
Registered: ‎01-29-2015
Kudos: 125
Solutions: 39

Re: Speed issues with AP AC Pro

The ghost wifi is most likely a device on your network that uses a wifi remote. Rokus will do that, for example.

Established Member
Posts: 923
Registered: ‎01-29-2015
Kudos: 125
Solutions: 39

Re: Speed issues with AP AC Pro

Oh, forgot to ask...

 

Try the mobile Unifi app on your phone. Go to More, then throughput test. This will eliminate the network and only test the wifi.

 

Also, it would be good to post the Clients page on your controller.

Established Member
Posts: 1,616
Registered: ‎03-31-2017
Kudos: 542
Solutions: 179

Re: Speed issues with AP AC Pro

The phantom SSID could also be the wireless linking feature.

If you are not using that you can shut it off on the controller by unchecking "Uplink Connectivity Monitor" located under SITE.
Established Member
Posts: 923
Registered: ‎01-29-2015
Kudos: 125
Solutions: 39

Re: Speed issues with AP AC Pro

Good point, that will certainly cause the ghost too if something's wirelessly linking.

Established Member
Posts: 966
Registered: ‎02-01-2014
Kudos: 265
Solutions: 32

Re: Speed issues with AP AC Pro

[ Edited ]

Agreed with that since the AP's use the 5ghz channel band for wireless uplink.

Senior Member
Posts: 6,834
Registered: ‎08-04-2017
Kudos: 1105
Solutions: 330

Re: Speed issues with AP AC Pro

Hello @ericfrederich,

 

Welcome to the community!

 

Could you share your system config so we can get some more information about your network?

Settings > Maintenance > Support Info > Show System Config

 

Also could you share the results of the throughput test in the UniFi app?

 

 

Regards,

Glenn R.

Professional Services | Cloud Hosted Controllers | Glenn R. | UniFi Installation Scripts | UniFi Easy Update Script | UniFi-Video Installation Scripts
USG-4-PRO
USW-24-POE-250W • USW-24 • USW-8
UAP-HD • UAP-AC-PRO
New Member
Posts: 23
Registered: ‎09-13-2018

Re: Speed issues with AP AC Pro

Here is my System config

systemConfig (2).png

New Member
Posts: 23
Registered: ‎09-13-2018

Re: Speed issues with AP AC Pro

On the WiFi throughput test in the app I am only able to download 170Mbps and able to upload 240Mbps. This is weird because I am able to get higher rates from speedtest app (300Mbps) and fast.com in a web browser (200Mbps).
Senior Member
Posts: 6,834
Registered: ‎08-04-2017
Kudos: 1105
Solutions: 330

Re: Speed issues with AP AC Pro

[ Edited ]

Hello @ericfrederich,

 

How far away are you from the UAP?

 

You can disable the Uplink Connectivity Monitor

Settings > Site > Uplink Connectivity Monitor

 

I recommend the following radio settings

 

2.4 GHz

Channel width: HT20

Chanel: 1/6/11 | Choose one of these channels, a RF scan will help you choose the most clean one.

Transmit Power: Low/Medium

 

5GHz

Channel width: VHT40

Chanel: 36/44 | Optional (149/157) Choose one of these channels, a RF scan will help you choose the most clean one. Avoid using DFS Channels

Transmit Power: High

 

 

You could also modify your DTIM Periods if you have more modern devices on the network.

Settings > Wireless Network > SSID > 802.11 Rate And Beacon Controls

 

DITM 2G Period: 3

DITM 5G Period: 3

 

 

 

Regards,

Glenn R.

Professional Services | Cloud Hosted Controllers | Glenn R. | UniFi Installation Scripts | UniFi Easy Update Script | UniFi-Video Installation Scripts
USG-4-PRO
USW-24-POE-250W • USW-24 • USW-8
UAP-HD • UAP-AC-PRO
New Member
Posts: 23
Registered: ‎09-13-2018

Re: Speed issues with AP AC Pro

Glenn,

 

I am 5 feet away from UAP with line of sight.  I have already disabled the Uplink Connectivity Monitor.

 

What speeds should I be getting with my Pixel 2 or my Laptop?

 

I'm hesitent to go and hook up my AT&T router to see what I was getting before but I want to say it was faster.  Obviously not the 900+Mbps I get while wired, but still faster than 300 I think.

Established Member
Posts: 923
Registered: ‎01-29-2015
Kudos: 125
Solutions: 39

Re: Speed issues with AP AC Pro

Can you look up the specs for your devices and post them here? Are they 1x1, 2x2, etc?

New Member
Posts: 23
Registered: ‎09-13-2018

Re: Speed issues with AP AC Pro

Senior Member
Posts: 6,834
Registered: ‎08-04-2017
Kudos: 1105
Solutions: 330

Re: Speed issues with AP AC Pro

Hello @ericfrederich,

 

2x2 should give you a 867Mbps Rx/Tx rate.

 

 

Regards,

Glenn R.

Professional Services | Cloud Hosted Controllers | Glenn R. | UniFi Installation Scripts | UniFi Easy Update Script | UniFi-Video Installation Scripts
USG-4-PRO
USW-24-POE-250W • USW-24 • USW-8
UAP-HD • UAP-AC-PRO
Highlighted
Established Member
Posts: 966
Registered: ‎02-01-2014
Kudos: 265
Solutions: 32

Re: Speed issues with AP AC Pro

@AmazedMender16- I have always been told its 400mbps max for 2x2. Then I am now having the same problems with my AC-Pro's. Man Happy I have tried helping earlier but apparently I am not getting the best speeds possible.
Senior Member
Posts: 6,834
Registered: ‎08-04-2017
Kudos: 1105
Solutions: 330

Re: Speed issues with AP AC Pro

Hello @verisarioc,

 

Real-life performance is never the same as theoretical performance Man Tongue

 


Regards,

Glenn R.

Professional Services | Cloud Hosted Controllers | Glenn R. | UniFi Installation Scripts | UniFi Easy Update Script | UniFi-Video Installation Scripts
USG-4-PRO
USW-24-POE-250W • USW-24 • USW-8
UAP-HD • UAP-AC-PRO
Established Member
Posts: 966
Registered: ‎02-01-2014
Kudos: 265
Solutions: 32

Re: Speed issues with AP AC Pro

No I get that, but my Pixel 2 XL only connects at a maximum of 400mbps showing on the controller. I have 2 AP Pro's. So I know it can do more and I know my phone has the 2x2 MIMO in it. So now I want to know whats wrong with my setup. 

 

My config:

systemConfig.png

Senior Member
Posts: 6,834
Registered: ‎08-04-2017
Kudos: 1105
Solutions: 330

Re: Speed issues with AP AC Pro

[ Edited ]

Hello @verisarioc,

 

Thats because you're on VHT40, go to VHT80 to see 867 Man Happy

Also recommed using the following radio settings

 

2.4 GHz
Channel width: HT20
Chanel: 1/6/11 | Choose one of these channels, a RF scan will help you choose the most clean one.
Transmit Power: Low/Medium

5GHz
Channel width: VHT40 | Optional VHT80 might decrease wireless stability
Chanel: 36/44 | Optional (149/157) Choose one of these channels, a RF scan will help you choose the most clean one. Avoid using DFS Channels
Transmit Power: High

 

 


Regards,

Glenn R.

Professional Services | Cloud Hosted Controllers | Glenn R. | UniFi Installation Scripts | UniFi Easy Update Script | UniFi-Video Installation Scripts
USG-4-PRO
USW-24-POE-250W • USW-24 • USW-8
UAP-HD • UAP-AC-PRO
Established Member
Posts: 966
Registered: ‎02-01-2014
Kudos: 265
Solutions: 32

Re: Speed issues with AP AC Pro

@AmazedMender16,

I appreciate your help as usual. I might have been doing it all but setting the 2.4 band to HT20. My wifi devices always disconnected before and would never get an IP again. This time, its working perfectly. My Lenovo T460s is now at 780mbps and my iphone 7s for work is the same speeds. It took a couple tries to get one of my Pro's to actually apply the VHT80.

My Android is NOT however going past 400mbps still.
Reply