Reply
Highlighted
New Member
Posts: 13
Registered: ‎03-10-2019
Accepted Solution

Ubiquiti Access Point with Edge Router Lite Setup: AP showing as disconeccted

Hi all, 

 

I'm currently have a edgerouter lite set up and running beautifully for the fiber in my apartment, unfortunately trying to get the AP Lite running has been a different story.

 

Currently fiber is routing through eth0, my computer through eth1 and the AP through eth2. The AP does not show up in the "lease" section of LAN2. This led me to plugging the AP straight through the controller to my computer, disconnecting my computer from the internet and the edgerouter. At first I was able to see the AP appear on the devices but was listed as unable to adopt needs firmware update. So I went back online, cached the correct firmware, replugged my AP into my computer and then the AP showed disconnected, which is it's current status. I tried reseting the AP manually, but when plugged straight into the computer it still shows disconnected. 

 

Any help would be greatly appreciated, I have been trying to get this AP up and running for the past week.


Accepted Solutions
Senior Member
Posts: 23,503
Registered: ‎08-04-2017
Kudos: 4460
Solutions: 1155

Re: Ubiquiti Access Point with Edge Router Lite Setup: AP showing as disconeccted

Hello @jon5841,

 

Keep me posted, also feel free to tag me.

 

 

Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation Scripts | UniFi-VoIP Installation Scripts
USG-XG-8 • USG-4-PRO • USG
US-XG-16 • US-48-500W • US-24-POE-250W 2x • US-16-POE-150W 3x • US-24 • US-8-150W • US-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD 2x • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M • UAP-AC-M-PRO 2x
UAS-XG • UCK-G2-PLUS • UCK-G2 • UCK

View solution in original post


All Replies
New Member
Posts: 13
Registered: ‎03-10-2019

Re: Ubiquiti Access Point with Edge Router Lite Setup: AP showing as disconeccted

This is what my current LAN2 DHCP server looks like, https://imgur.com/RiZLVL2

Senior Member
Posts: 23,503
Registered: ‎08-04-2017
Kudos: 4460
Solutions: 1155

Re: Ubiquiti Access Point with Edge Router Lite Setup: AP showing as disconeccted

Hello @jon5841,

 

Welcome to the community!

 

It shows disconnected because it's looking at a different inform address.

Why do you plug the UAP straight into your laptop, don't you have a switch?

 

 

Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation Scripts | UniFi-VoIP Installation Scripts
USG-XG-8 • USG-4-PRO • USG
US-XG-16 • US-48-500W • US-24-POE-250W 2x • US-16-POE-150W 3x • US-24 • US-8-150W • US-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD 2x • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M • UAP-AC-M-PRO 2x
UAS-XG • UCK-G2-PLUS • UCK-G2 • UCK
New Member
Posts: 13
Registered: ‎03-10-2019

Re: Ubiquiti Access Point with Edge Router Lite Setup: AP showing as disconeccted

Hi @AmazedMender16 ,

 

Thanks for the welcome! I plugged the UAP straight into my laptop in hopes of getting it updated and adopted as it was not appearing when plugged into my Edgerouter, I do not have a switch going between the Edgerouter and the AP, do I need one? Just as an update from last night: I tried setting up my Edgerouter into briding the 2 LAN ports and portforwarding to the LAN that the AP is plugged into. This worked in that the AP was showing up on the "Leased" window of the LAN2 port but was still showing disconnected on the Unifi dashboard.

 

New Member
Posts: 13
Registered: ‎03-10-2019

Re: Ubiquiti Access Point with Edge Router Lite Setup: AP showing as disconeccted

Just to clarify my goal here is to be able to direct plug in my computer to the edgerouter while also having wifi via the AP coming from the same edgerouter, if I need a switch for this I'd be happy to get one.

Member
Posts: 141
Registered: ‎03-30-2016
Kudos: 16
Solutions: 2

Re: Ubiquiti Access Point with Edge Router Lite Setup: AP showing as disconeccted

It looks like you have 2 DHCP servers with 192.168.1.0/24.  This seems problematic to me.

Member
Posts: 141
Registered: ‎03-30-2016
Kudos: 16
Solutions: 2

Re: Ubiquiti Access Point with Edge Router Lite Setup: AP showing as disconeccted

Best practice for this sort of setup would have a switch between ETH1 on the Edgerouter and your computer and AP.

New Member
Posts: 13
Registered: ‎03-10-2019

Re: Ubiquiti Access Point with Edge Router Lite Setup: AP showing as disconeccted

Thanks @mshorey 

 

That's what I was fearing, if I put one more hot piece of equipment under my desk my desk may just spontaniously combust. I found this article https://medium.com/@raphnguyen/network-getting-started-with-ubiquiti-edgerouter-lite-unifi-ap-ac-pro... that implies that using the edgerouter for a wired and AP connection is possible that I will try when I get home.

Senior Member
Posts: 23,503
Registered: ‎08-04-2017
Kudos: 4460
Solutions: 1155

Re: Ubiquiti Access Point with Edge Router Lite Setup: AP showing as disconeccted

Hello @jon5841,

 

Are both the controller and UAP wired into the router on the same network?

Make sure port 8080/tcp is open in the firewall/AV.

 

Can you SSH into the UAP?

 

 

Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation Scripts | UniFi-VoIP Installation Scripts
USG-XG-8 • USG-4-PRO • USG
US-XG-16 • US-48-500W • US-24-POE-250W 2x • US-16-POE-150W 3x • US-24 • US-8-150W • US-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD 2x • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M • UAP-AC-M-PRO 2x
UAS-XG • UCK-G2-PLUS • UCK-G2 • UCK
Senior Member
Posts: 23,503
Registered: ‎08-04-2017
Kudos: 4460
Solutions: 1155

Re: Ubiquiti Access Point with Edge Router Lite Setup: AP showing as disconeccted

Hello @jon5841,

 

You can also adopt the UAP to your phone for a simple/easy setup.

 

 

Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation Scripts | UniFi-VoIP Installation Scripts
USG-XG-8 • USG-4-PRO • USG
US-XG-16 • US-48-500W • US-24-POE-250W 2x • US-16-POE-150W 3x • US-24 • US-8-150W • US-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD 2x • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M • UAP-AC-M-PRO 2x
UAS-XG • UCK-G2-PLUS • UCK-G2 • UCK
New Member
Posts: 13
Registered: ‎03-10-2019

Re: Ubiquiti Access Point with Edge Router Lite Setup: AP showing as disconeccted

@AmazedMender16 Yes the controller running off of my PC is wired into ETH1 and the UAP is wired via the PoE that comes with the UAP into ETH2. When you say "Make sure port 8080/tcp is open in the firewall/AV." are you talking about the firewall section in the Edgerouter? Or on the device that runs the controller? When I was doing set up I disabled all firewalls on my PC as I read it can be an issue. I tried to SSH into the UAP via the edgerouter but it said something along the lines of "no connection path availble", I will try again later today though.

Senior Member
Posts: 23,503
Registered: ‎08-04-2017
Kudos: 4460
Solutions: 1155

Re: Ubiquiti Access Point with Edge Router Lite Setup: AP showing as disconeccted

Hello @jon5841,

 

Did you bridge the ports by any chance?

The ports have to be open on the controller device.

 

 

Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation Scripts | UniFi-VoIP Installation Scripts
USG-XG-8 • USG-4-PRO • USG
US-XG-16 • US-48-500W • US-24-POE-250W 2x • US-16-POE-150W 3x • US-24 • US-8-150W • US-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD 2x • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M • UAP-AC-M-PRO 2x
UAS-XG • UCK-G2-PLUS • UCK-G2 • UCK
New Member
Posts: 13
Registered: ‎03-10-2019

Re: Ubiquiti Access Point with Edge Router Lite Setup: AP showing as disconeccted

So I was able to get the UAP adopted by the controller when plugging the UAP directly into my PC (running the controller) but when plugging it back into the edgerouter the UAP started to show disconnected, as if the controller did not know to look at ETH2 for the UAP.
Member
Posts: 141
Registered: ‎03-30-2016
Kudos: 16
Solutions: 2

Re: Ubiquiti Access Point with Edge Router Lite Setup: AP showing as disconeccted

Post the config of the edgerouter when you have a chance.

New Member
Posts: 13
Registered: ‎03-10-2019

Re: Ubiquiti Access Point with Edge Router Lite Setup: AP showing as disconeccted

I did try a set up where the LAN ports on the edgerouter are bridged, do they need to be 2 seperate LANS?
Senior Member
Posts: 23,503
Registered: ‎08-04-2017
Kudos: 4460
Solutions: 1155

Re: Ubiquiti Access Point with Edge Router Lite Setup: AP showing as disconeccted

Hello @jon5841,

 

Right, thats because the UAP can’t reach the controller via the inform address that it got when connected to your PC..

 

 

Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation Scripts | UniFi-VoIP Installation Scripts
USG-XG-8 • USG-4-PRO • USG
US-XG-16 • US-48-500W • US-24-POE-250W 2x • US-16-POE-150W 3x • US-24 • US-8-150W • US-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD 2x • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M • UAP-AC-M-PRO 2x
UAS-XG • UCK-G2-PLUS • UCK-G2 • UCK
Senior Member
Posts: 23,503
Registered: ‎08-04-2017
Kudos: 4460
Solutions: 1155

Re: Ubiquiti Access Point with Edge Router Lite Setup: AP showing as disconeccted

Hello @jon5841,

 

Keep them bridged....

Reset the UAP and forget the UAP in the controller, then SSH into the UAP and set-inform to the controller.

set-inform http://ip.of.the.controller:8080/inform

 

 

Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation Scripts | UniFi-VoIP Installation Scripts
USG-XG-8 • USG-4-PRO • USG
US-XG-16 • US-48-500W • US-24-POE-250W 2x • US-16-POE-150W 3x • US-24 • US-8-150W • US-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD 2x • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M • UAP-AC-M-PRO 2x
UAS-XG • UCK-G2-PLUS • UCK-G2 • UCK
New Member
Posts: 13
Registered: ‎03-10-2019

Re: Ubiquiti Access Point with Edge Router Lite Setup: AP showing as disconeccted

Makes sense, UAP is looking for a direct line to the controller from set up, which is no longer the case. Is there a way to have the UAP look at ETH1 (my pc/controller) for the controller?
New Member
Posts: 13
Registered: ‎03-10-2019

Re: Ubiquiti Access Point with Edge Router Lite Setup: AP showing as disconeccted

ip of the controller would be the static IP assigned to my PC in edgerouter correct?
Senior Member
Posts: 23,503
Registered: ‎08-04-2017
Kudos: 4460
Solutions: 1155

Re: Ubiquiti Access Point with Edge Router Lite Setup: AP showing as disconeccted

Hello @jon5841,

 

Yeah via the set-inform command mentioned in my previous post.

 

 

Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation Scripts | UniFi-VoIP Installation Scripts
USG-XG-8 • USG-4-PRO • USG
US-XG-16 • US-48-500W • US-24-POE-250W 2x • US-16-POE-150W 3x • US-24 • US-8-150W • US-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD 2x • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M • UAP-AC-M-PRO 2x
UAS-XG • UCK-G2-PLUS • UCK-G2 • UCK
Reply