Scheduled maintenance: Community will be offline Monday June 17th, 1:00 AM - 6:00 AM (PT)
Reply
New Member
Posts: 28
Registered: ‎12-10-2016
Accepted Solution

UniFi AP started to drop connections

I've had a UniFi AC AP connected to an ERX for months and it was working great. Then my home was under renovation for a while during which the ERX was powered off. Now after reconnecting them, the wifi connection of the AP keeps dropping. I haven't changed any piece of hardware and the setup is identical as far as I can tell. I'm now on a wired connection to the ERX since the wifi is dropping too often. Any clue what changed things?


Accepted Solutions
Established Member
Posts: 1,617
Registered: ‎01-29-2014
Kudos: 497
Solutions: 83

Re: UniFi AP started to drop connections

Cable damage would be my intial thought if you've had building work done.

View solution in original post


All Replies
Veteran Member
Posts: 4,703
Registered: ‎10-13-2012
Kudos: 1286
Solutions: 208

Re: UniFi AP started to drop connections

[ Edited ]

The renovation? That or your WiFi neighbourhood.

 

So you have a UAP-AC (v1) or UAP-AC (v2), the square model? It unfortunately does not receive attention anymore by UBNT with regard to bug fixing or firmware development.

 

EDIT: You could try to reduce the power settings for one or both radios a bit, and see if that helps.

New Member
Posts: 28
Registered: ‎12-10-2016

Re: UniFi AP started to drop connections

Can you explain how you think the renovation made my connection drop?

I have UAP AC LR. It's still supported, I get firmware updates.

I will try reducing the power. The AP is powered over ehternet. Do you think something could have happened to the cable to make it occasionally drop power?
Veteran Member
Posts: 4,703
Registered: ‎10-13-2012
Kudos: 1286
Solutions: 208

Re: UniFi AP started to drop connections

There are a million things the renovation can have done and caused, for example an eletrical spike that partially damaged the PoE injector. Or there is now a Microwave where there wasn't one before, or someone installed steel walls or components - I really cannot know.

 

Maybe you are just too close to the AP with too much power - set the AP to medium on 2.4 GHz.

 

Use the controller to watch the channel utilisation and the interference for further analysis, and/or check the log (syslog) of the AP.

New Member
Posts: 28
Registered: ‎12-10-2016

Re: UniFi AP started to drop connections

Everything was unplugged during the renovation and I don't use a PoE injector, I have an ERX that can supply PoE.

 

I tried 2.4GHz on medium power and it's not better. When I got disconnected from my 5GHz network, I could connect back. I couldn't connect at all on 2.4GHz.

 

I checked channel utilization and it's fairly low. Most channels are around 20% utilized. How do I check the log of the AP?

Veteran Member
Posts: 4,703
Registered: ‎10-13-2012
Kudos: 1286
Solutions: 208

Re: UniFi AP started to drop connections

[ Edited ]

Did you create a new SSID with a new password (or no password) to test?

So try if it helps to power the AP directly with its PoE injector.

Also, have you tried different WiFi clients and seen the same problem, not just one?

What exactly is the WiFi client you are having trouble with, have you checked for new drivers, or if windows (I assume you are using Windows) has recently upgraded that driver?

Log: You can either enable syslog in the controller and install a syslog server to receive the data, or ssh into the AP and look at /var/log/messages

What is the meaning of "keeps dropping": Every minute, every hour?

Established Member
Posts: 1,617
Registered: ‎01-29-2014
Kudos: 497
Solutions: 83

Re: UniFi AP started to drop connections

Cable damage would be my intial thought if you've had building work done.

New Member
Posts: 28
Registered: ‎12-10-2016

Re: UniFi AP started to drop connections

I created a new SSID with a new password in 2.4GHz for the test. The connection drops across clients, I've noticed it for Macbook Pro, iPad, Apple TV, all with the latest OSes. The connection drops from once an hour to maybe every 10 minutes. Sometimes I think it might just be dropping packets, because Plex flickers or Time Machine backups fail.

 

I will try powering it using the POE injector. I also tried to power the ERX from a UPS, hoping to get cleaner current, but it didn't help.

 

Since I don't have a controller that's always on, I will try the SSH approach.

 

Vestas, do you think the cable could be affected in a way that only sometimes drops the connection? I was thinking it's all or nothing.

New Member
Posts: 28
Registered: ‎12-10-2016

Re: UniFi AP started to drop connections

Okay, in the logs I found eth0: link down, and then, 2 seconds later, eth0: link up (1000Mbps/Full duplex). I'm starting to suspect cable damage more and more. I will try to find another cable to test.

Established Member
Posts: 1,617
Registered: ‎01-29-2014
Kudos: 497
Solutions: 83

Re: UniFi AP started to drop connections

[ Edited ]

I'm not familiar with the ERX management interface but there should be somewhere which shows you Tx & Rx errors.

 

More than a few of these (and any STP blocking) usually means dodgy cable/crimps somewhere but if your cable has got chafed/bent too much during the building work then that probably explains your issues. Its probably got enough PoE connections left to boot and then as the radios/etc take more power it falls over in a heap as it hasn't got enough current.

New Member
Posts: 28
Registered: ‎12-10-2016

Re: UniFi AP started to drop connections

I'm trying now with a different cable, fingers crossed. Another thing that points to the cable is that I found the link negociated to 100MB/s  rather than 1000.

New Member
Posts: 28
Registered: ‎12-10-2016

Re: UniFi AP started to drop connections

It works as intended with the new cable. Thanks for the suggestions!

Highlighted
Emerging Member
Posts: 52
Registered: ‎12-17-2018
Solutions: 1

Re: UniFi AP started to drop connections

Hi

having the same problem,

changed cable, no change

 

AP is dropping from 100 to 10 FDX.

 

After restarting it is working for some time.

 

Than back to 10 fx.

 

Any hints ?

 

Thomas

Senior Member
Posts: 25,956
Registered: ‎08-04-2017
Kudos: 4870
Solutions: 1288

Re: UniFi AP started to drop connections

Hello @riker1,

 

Did you crimp the cable yourself?

Have you tried another switchport?

 

 

Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation Scripts | UniFi-VoIP Installation Scripts
USG-XG-8 • USG-4-PRO • USG
US-XG-16 • US-48-500W • US-24-POE-250W 2x • US-16-POE-150W 3x • US-24 • US-8-150W • US-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD 2x • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M • UAP-AC-M-PRO 2x
UAS-XG • UCK-G2-PLUS • UCK-G2 • UCK
Reply