Reply
New Member
Posts: 2
Registered: ‎09-01-2015
Kudos: 1

Re: UniFi Cloud Access gets 'CONNECTION FAILED' after enabling local SSO login

Same problem. Have tried with Firefox, both PC's and routers Firewalls disdable, and with SSO login on / off: No joy. Credentials are accepted, then fails on '400 Bad Request'. Default demo site loads without errors. Any further updatea / suggestions? Thx.

Senior Member
Posts: 23,730
Registered: ‎08-04-2017
Kudos: 4494
Solutions: 1167

Re: UniFi Cloud Access gets 'CONNECTION FAILED' after enabling local SSO login

Hello @pczen,

 

So you’re seeing 400 errors when you connect to the controller?

Could you take a look at the controller logs?

 

 

Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation Scripts | UniFi-VoIP Installation Scripts
USG-XG-8 • USG-4-PRO • USG
US-XG-16 • US-48-500W • US-24-POE-250W 2x • US-16-POE-150W 3x • US-24 • US-8-150W • US-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD 2x • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M • UAP-AC-M-PRO 2x
UAS-XG • UCK-G2-PLUS • UCK-G2 • UCK
New Member
Posts: 11
Registered: ‎03-14-2017
Kudos: 1

Re: UniFi Cloud Access gets 'CONNECTION FAILED' after enabling local SSO login

Same problem here. I can login to unifi.ubnt.com via the computer "responsible" for the controller and it launches fine, but I cannot access it from any other PC.

New Member
Posts: 7
Registered: ‎04-05-2016
Kudos: 2

Re: UniFi Cloud Access gets 'CONNECTION FAILED' after enabling local SSO login

Please make sure you have updated java and launched the controller interactively using the desktop shortcut (do NOT start it as a Windows service)... whereafter you are prompted to accept updated windows firewall rules relating to java. Once these firewall rules are in palce you can shutdown the interactive controller and run it as a service again.

New Member
Posts: 11
Registered: ‎03-14-2017
Kudos: 1

Re: UniFi Cloud Access gets 'CONNECTION FAILED' after enabling local SSO login

Thank you for the reply. The local computer has the latest Java-version. I have actually shut the whole Windows-firewall off on the computer running the controller - but it still says "CONNECTION FAILED" and the "400 Bad Request" after trying to launch the site via unifi.ubnt.com...
New Member
Posts: 11
Registered: ‎03-14-2017
Kudos: 1

Re: UniFi Cloud Access gets 'CONNECTION FAILED' after enabling local SSO login

[ Edited ]

It was due to the latest Java-version. I downloaded the first Java-version (jre-8-windows-x64.exe) and cloud started working.

New Member
Posts: 11
Registered: ‎03-14-2017
Kudos: 1

Re: UniFi Cloud Access gets 'CONNECTION FAILED' after enabling local SSO login

[ Edited ]

Perhaps not... I have 8 PC's running 1 cloud-controller each. After allowing each PC through the firewall (even though the firewall was off) all of the 64-bit systems came online and are now accessible via the cloud. They were all running different Java-versions, so the actual version didn't matter.

However, the two systems which I performed the exact same steps on, which are 32-bit and installed with 32-bit Java, just does not wanna come online. I see them on the unifi.ubnt.com login as "Online", but when trying to access them I get "CONNECTION FAILED".

I have uninstalled and reinstalled Java at least 5-6 times, but to no avail... Any ideas? Could it be due to them being 32-bit? That's the only connection I can find between them, being that all of the other controllers are running fine and are running on 64-bit windows and 64-bit java.

Member
Posts: 200
Registered: ‎06-05-2017
Kudos: 82
Solutions: 2

Re: UniFi Cloud Access gets 'CONNECTION FAILED' after enabling local SSO login

Having the same issue here - i'm running the controller on my readynas at home and neither my NVR nor the unifi controller are reachable. The unifi controller is working from my android phone but not from the web. Not able to get to my NVR either remotely. Cloud says both are online but says connection failed just like everyone here...I'm able to confirm that my internet is working remotely... any ideas?

Member
Posts: 172
Registered: ‎11-28-2013
Kudos: 21

Re: UniFi Cloud Access gets 'CONNECTION FAILED' after enabling local SSO login

Have never had this issue prior to a couple of days ago. I have two sites. On each I could go to the controller directly, disable cloud access, re-enable it right away and all was good. Both iPhone Unifi app and either Chrome or Firefox on Win10/64 worked.

 

Since then it has reoccured (new cloud key on one site and update to 5.9.29 replacing Unbuntu/Azure controller). Now when I go to Ubnt/Unifi on Chrome, it works, but on FF it does not. Doesn't matter if I disable/enable any more. Mostly (but not 100%) the SDN Unifi app works fine, whether on the local network (direct access) or on cell (only cloud access).

 

Simply does not make any sense to me.

 

(Odd observation: FF *always* requires reCaptcha auth first on login, but Chrome does - mostly - not)

New Member
Posts: 2
Registered: ‎09-01-2015
Kudos: 1

Re: UniFi Cloud Access gets 'CONNECTION FAILED' after enabling local SSO login

[ Edited ]

This solved the problem for me:

 

On rempote PC I stoped the controller, uninstalled Java32bit / reinstalled 64bit, chanaged default browser from Firefox 32bit to Chrome 64bit, and restarted the controller.

 

My PC is and has been running Chrome & Java64bit, no changes were made here. Thx for all the above suggestions re this.

 

 

Senior Member
Posts: 23,730
Registered: ‎08-04-2017
Kudos: 4494
Solutions: 1167

Re: UniFi Cloud Access gets 'CONNECTION FAILED' after enabling local SSO login

Hello @pczen,

 

Thanks for reporting back.

Glad it's all working now!

 

 

Regards,

Glenn R.

 

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation Scripts | UniFi-VoIP Installation Scripts
USG-XG-8 • USG-4-PRO • USG
US-XG-16 • US-48-500W • US-24-POE-250W 2x • US-16-POE-150W 3x • US-24 • US-8-150W • US-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD 2x • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M • UAP-AC-M-PRO 2x
UAS-XG • UCK-G2-PLUS • UCK-G2 • UCK
New Member
Posts: 1
Registered: ‎12-15-2018
Kudos: 1

Re: UniFi Cloud Access gets 'CONNECTION FAILED' after enabling local SSO login

This was the same issues for me. I was using Java 32bit. Installed 64bit and removed 32bit. Using Chrome for the browser. All is well again!

New Member
Posts: 8
Registered: ‎01-28-2017
Kudos: 3

Re: UniFi Cloud Access gets 'CONNECTION FAILED' after enabling local SSO login

I have a cloudkey and I am still having this issue. Seems to have started after the last update. Is there a fix coming for this?

New Member
Posts: 1
Registered: ‎01-26-2014

Re: UniFi Cloud Access gets 'CONNECTION FAILED' after enabling local SSO login

[ Edited ]

The same problem. I have a cloudkey.

Another system runs on the windows server.
The java is 64 bit. FF is also CH. But there is no login. There was reinstallation.

the firewall settings have not changed.

 

Sorry, the problem is only with FF 64 bits.
After restarting chromium, both are already running

New Member
Posts: 12
Registered: ‎01-16-2018
Kudos: 1

Re: UniFi Cloud Access gets 'CONNECTION FAILED' after enabling local SSO login

I have exactly the same symptoms as iminet in so far as this functionality stopped working on a CloudKey based controller.  The workaround for me is to use Chrome.  Looks like Firefox (at least the 64bit) version 64.0 has broken something.

Member
Posts: 172
Registered: ‎11-28-2013
Kudos: 21

Re: UniFi Cloud Access gets 'CONNECTION FAILED' after enabling local SSO login


@FlamingBadger wrote:

I have exactly the same symptoms as iminet in so far as this functionality stopped working on a CloudKey based controller.  The workaround for me is to use Chrome.  Looks like Firefox (at least the 64bit) version 64.0 has broken something.


This. Seems to be a Firefox issue. Chrome works fine.

New Member
Posts: 6
Registered: ‎02-13-2018

Re: UniFi Cloud Access gets 'CONNECTION FAILED' after enabling local SSO login

Why are you running the controller on Windows?

Member
Posts: 172
Registered: ‎11-28-2013
Kudos: 21

Re: UniFi Cloud Access gets 'CONNECTION FAILED' after enabling local SSO login


@ctullis wrote:

Why are you running the controller on Windows?


Why not?

 

CK is running in a Microsoft shop (Accounting and Tax in my case - just try to find software for Linux that does real accounting work). PCs are all Windows-based either W10 or Server2016. The controller doesn't care where it runs. It's just a portal to the CK's infrastructure and data. I run it on my iPhone too.

 

In my case I used to have a cloud-based Ubuntu VM running the controller software. Painful to update and access though. CK/Windows/iPhone is a lot easier and faster.

New Member
Posts: 5
Registered: ‎10-11-2016

Re: UniFi Cloud Access gets 'CONNECTION FAILED' after enabling local SSO login

As a Cloud Key user, I'm still having this issue myself. I manage this site remotely and have not been able to get into the cloud access since the update to 5.9.29. What can I do to correct this the next time I get local access to this cloud key?

Senior Member
Posts: 23,730
Registered: ‎08-04-2017
Kudos: 4494
Solutions: 1167

Re: UniFi Cloud Access gets 'CONNECTION FAILED' after enabling local SSO login

Hello @HubCityChurch,

 

Make sure the cloud access ports aren’t blocked.. also check the controller logs of the UCK.

 

 

Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation Scripts | UniFi-VoIP Installation Scripts
USG-XG-8 • USG-4-PRO • USG
US-XG-16 • US-48-500W • US-24-POE-250W 2x • US-16-POE-150W 3x • US-24 • US-8-150W • US-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD 2x • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M • UAP-AC-M-PRO 2x
UAS-XG • UCK-G2-PLUS • UCK-G2 • UCK
Reply