Reply
Emerging Member
Posts: 54
Registered: ‎01-13-2014
Kudos: 53
Solutions: 1

UniFi EDU Problems

Having some issues getting features of UniFi EDU working in a test environment. I can login from the app, Volume Test works, can schedule default sounds and schedule recordings from phone's microphone but I cannot do the following:

 

  • Live Broadcast to an online UAP-AC-EDU does not work. App will start stream (indicated by loading circle finishing and Microphone button symbol becoming a red Stop buttom symbol) but there is no audio on the UAP-AC-EDU. Upon "stopping" the broadcast, the error "There are some problems with your network. The broadcasting may not work properly." is displayed.
    Insights in the UniFi WebUI also shows that an AC-EDU stream is in progress during the duration of the broadcast (Ready: Yes, Streaming: Yes, Connected: Yes).
    Can login to UniFi from the UniFi EDU app and Volume Tests and triggering pre-existed Recordings work as expected.

    server.log
    <webapi-165> DEBUG api - /api/s/default/cmd/system finished (0 handling, 0 rendering)
    <webapi-154> DEBUG api - /api/s/default/rest/mediafile finished (0 handling, 0 rendering)
    <webapi-152> DEBUG api - /api/s/default/stat/device finished (0 handling, 0 rendering)
    <webapi-180> DEBUG api - /api/s/default/rest/broadcastgroup finished (0 handling, 0 rendering)
    <webapi-155> DEBUG api - /api/s/default/stat/stream finished (0 handling, 0 rendering)
    <webapi-148> DEBUG api - /api/s/default/stat/stream finished (0 handling, 0 rendering)
    <webapi-116> DEBUG api - /api/s/default/rest/mediafile finished (0 handling, 0 rendering)
    <webapi-99> DEBUG api - /api/s/default/get/setting finished (0 handling, 0 rendering)
    <webapi-14> DEBUG api - /api/s/default/cmd/streammgr/list-samples finished (0 handling, 0 rendering)
    <webapi-193> DEBUG api - /wss/s/default/events finished (0 handling, 0 rendering)
    <webapi-166> INFO stream - stream 00000000-0000-0000-0000-000000000123 created
    <webapi-166> DEBUG api - /api/s/default/cmd/streammgr/create-stream finished (0 handling, 0 rendering)
    <inform_stat-10> INFO stream - dev[80:2a:a8:00:00:00] joined stream 00000000-0000-0000-0000-000000000123
    <webapi-168> INFO stream - Starting stream: 00000000-0000-0000-0000-000000000123
    <webapi-168> DEBUG api - /api/s/default/cmd/streammgr/start-stream finished (0 handling, 0 rendering)
    <webapi-126> DEBUG api - /api/s/default/stat/stream finished (0 handling, 0 rendering)
    <webapi-167> INFO stream - Stopping stream: 00000000-0000-0000-0000-000000000123
    <webapi-189> DEBUG api - /api/s/default/stat/stream finished (0 handling, 0 rendering)
    <webapi-167> DEBUG api - /api/s/default/cmd/streammgr/stop-stream finished (16 handling, 0 rendering)
    <webapi-195> DEBUG api - /api/s/default/get/setting finished (16 handling, 0 rendering)
    <webapi-187> DEBUG api - /api/s/default/stat/device finished (16 handling, 0 rendering)
    <webapi-16> DEBUG api - /api/s/default/rest/mediafile finished (0 handling, 0 rendering)
    <webapi-34> DEBUG api - /api/s/default/cmd/streammgr/list-samples finished (0 handling, 0 rendering)
    <webapi-191> DEBUG api - /api/s/default/stat/stream finished (0 handling, 0 rendering)
  • Cannot play OGG file when adding a Recording from phone filesystem nor can you upload it. When you press play the symbol blinks to Stop then back again with no audio. When attempting to upload it displays the error "Wooops! Communication with controller failed", there are no relevant entries in server.log.
    Can record, play and upload audio that's recorded from the phone's microphone.
  • Cannot schedule OGG file from phone filesystem when Scheduling Stream, select of the file works but when attempting to save the Scheduled Stream it displays the error "Select audio file", there are no relevant entries in server.log.
    Can schedule any of the default sounds or record a new recording from phone's microphone but not previously uploaded audio recording from phone's microphone (and I'm assuming any other recordings that would have been successfully uploaded if one was able).
  • Cannot set Sounds before or after broadcast in app Settings, no combination (Sample or Media file, enabling before or after) works, displays the error "Wooops! Communication with controller failed"

    server.log
    <webapi-33> DEBUG api    - /api/s/default/cmd/system finished (0 handling, 0 rendering)
    <webapi-194> DEBUG api    - /api/s/default/cmd/streammgr/list-samples finished (0 handling, 0 rendering)
    <webapi-176> DEBUG api    - /api/s/default/rest/mediafile finished (0 handling, 16 rendering)
    <webapi-200> DEBUG api    - /api/s/default/get/setting finished (0 handling, 0 rendering)

 

Configuration

  • Firewalls allow traffic from phone running UniFi EDU app to controller on ports TCP:8443 and UDP:5655-5699
  • Firewalls allow traffic from UAP-AC-EDU to controller on ports TCP:8080, TCP:8443: TCP:3478 and UDP:5655-5699
  • UAP-AC-EDU is adopted by controller over layer-3
  • Android version 6.0.1
  • App version 1.1.3 (10103000)
  • UniFi Controller version 5.3.8 on Windows Server
  • UAP-AC-EDU version 3.7.29.5446

Other Notes:

  • I'm assuming the uploading of recordings from phone filesystem is a client side error of some sort but I couldn't guess what, I try selecting the phone using multiple apps that have registered Intents.
  • Volume Tests would have >1 minute delay unless STUN was allowed on controller.
Emerging Member
Posts: 54
Registered: ‎01-13-2014
Kudos: 53
Solutions: 1

Re: UniFi EDU Problems

Does anyone have this working, and if so, what differs in your configuration to mine?

Veteran Member
Posts: 5,787
Registered: ‎01-04-2017
Kudos: 831
Solutions: 295

Re: UniFi EDU Problems

Emerging Member
Posts: 54
Registered: ‎01-13-2014
Kudos: 53
Solutions: 1

Re: UniFi EDU Problems

[ Edited ]

The EDU won't even show up in the broadcast list of the app if it's using the beta firmware.

Veteran Member
Posts: 5,787
Registered: ‎01-04-2017
Kudos: 831
Solutions: 295

Re: UniFi EDU Problems

thats not beta
Veteran Member
Posts: 5,787
Registered: ‎01-04-2017
Kudos: 831
Solutions: 295

Re: UniFi EDU Problems

It's the latest release, I believe its been out for a week or two
Emerging Member
Posts: 54
Registered: ‎01-13-2014
Kudos: 53
Solutions: 1

Re: UniFi EDU Problems

Hasn't been published via public downloads yet it seems (https://www.ubnt.com/download/unifi/unifi-ap-ac-edu/uap-ac-edu) so I assumed it was beta because of the relevant thread in the beta forums of the same version, regardless, I have even less functionality using it than I do using 3.7.29.5446.

New Member
Posts: 6
Registered: ‎11-06-2015
Kudos: 5

Re: UniFi EDU Problems

[ Edited ]

Have 2 devices with latest firmware 3.7.55.6308, have UniFi controller 5.4.15. App 1.2.1 (10201000).

Try apply new settings and get "Wooops! Communication with controller failed" , trying change volume i get "InvalidDevicesFound".

Reinstall, downgrade, reset etc - Uni AC EDU streaming/audio/mic dont work with app...

Personal Blog: weblance.com.ua
0Eqq_UNVEno.jpg
BgFym1U6Mlk.jpg
TfTyBZtAbn8.jpg
uQYCtPMrxLM.jpg
V95n4Lxcx9Q.jpg
Ubiquiti Employee
Posts: 571
Registered: ‎01-29-2016
Kudos: 282
Solutions: 34

Re: UniFi EDU Problems

[ Edited ]

Hey @Dmitryavet,

 

Sorry to hear that. I believe this is a problem with the 3.7.55 firmware combined with controller 5.4.15.

 

Could you please try downgrading the EDU firmware to 3.7.51? In the web controller, open the EDU device detail screen, go to Configure > Manage Device > Custom Upgrade, and enter the URL:

http://dl.ubnt.com/unifi/firmware/U7PG2/3.7.51.6230/BZ.qca956x.v3.7.51.6230.170322.1515.bin

 

Thanks.

 

David

New Member
Posts: 6
Registered: ‎11-06-2015
Kudos: 5

Re: UniFi EDU Problems

Controller automatic downgrade FW to 3.7.51, broadcast working. But if change settings - still get error message "Wooops!...failed"
Personal Blog: weblance.com.ua
Member
Posts: 143
Registered: ‎02-09-2016
Kudos: 22
Solutions: 1

Re: UniFi EDU Problems

Finally cracked it!

- pre-record your ogg file

- copy it to your device

- open app

- select Recordings

- click +

- click "Pick file from phone"

- browse to your pre-recorded file

- select file

- click tick

 

file will be copied/converted to be stored and is then available to select as a scheduled broadcast etc

 

Member
Posts: 142
Registered: ‎12-02-2011
Kudos: 26
Solutions: 2

Re: UniFi EDU Problems

[ Edited ]

Hello,

 

My resseler lent me an UAP-AC-EDU for testing purpose

My company plan to buy like 10 of those

 

Unfortunately the app doesn't work and I fell like a fool in front of my boss

 

i have upgraded the controller to the lastest version. With this firmware, the device cannot be found at all on the app.

 

So I downgraded the firmware on the device, following instructions here from UBNT-Jonge

 

app version : 1.2.3
controller version : 5.7.23 (remoter server / L3)
firmware version : 3.7.51.6230

 

 Now the app finds the device, but I can't event play the demo test sound on it

 

see the screenshots

 

honestly this EDU thing looks like the  VOIP line or the mFi

good devices well designed but very bad software. fells like it's untested

I mean, the basic functions doesn't work out of the box

 

10 of these would be 5000$CAD (canadian $) + tax !

 

even if it get to work now, what about the future ? will the support continues even in 10 years for android version 144164 ?

why do we need a smartphone App to use this ? i would prefer an app on PC or web browser

 

Screenshot_20180503-171428.jpgScreenshot_20180503-171403.jpgScreenshot_20180503-171246.jpgScreenshot_20180503-171229.jpg

 

Member
Posts: 143
Registered: ‎02-09-2016
Kudos: 22
Solutions: 1

Re: UniFi EDU Problems

 you adopt, as with any access point, on the Unifi Controller NOT the app. First and foremost the EDU is an access point!

 

the app works perfectly, scheduled broadcasts, live announcements, everything!

 

 sorry mate but you can't blame unifi for this one

Ubiquiti Employee
Posts: 767
Registered: ‎07-04-2017
Kudos: 180
Solutions: 47

Re: UniFi EDU Problems

@joras33  Let's circle back around for a moment... so the controller is in a remote location from where you're testing it?

 

Are the EDU Broadcast ports open on the remote firewall?  

 

The remote UniFi controller is it a CloudKey? Windows base Controller?  How much bandwidth does it have?  

 

Thanks,

Jeff

 

UBNT_Alternate_Logo.png
Ubiquiti Networks Enterprise Team
"I cannot teach anybody anything. I can only make them think." - Socrates

Highlighted
New Member
Posts: 5
Registered: ‎03-29-2016

Re: UniFi EDU Problems

another question i depoyed these in a hospital and i am hearing mic feedback in the phone anyway to disable this so it can be used for just paging?

Reply