Reply
New Member
Posts: 3
Registered: ‎12-29-2018

Re: UniFi Installation Scripts | UniFi Easy Update Scripts | Ubuntu 18.04 and 16.04 | Debian 8 and 9

Thanks @AmazedMender16 

 

The script will be used in a samba domain controller, webserver (nginx), postgres server, mysql server. Do you think I'll break anything? If yes you can advise me how to recover?

 

Thanks.

Senior Member
Posts: 16,020
Registered: ‎08-04-2017
Kudos: 2913
Solutions: 791

Re: UniFi Installation Scripts | UniFi Easy Update Scripts | Ubuntu 18.04 and 16.04 | Debian 8 and 9

Hello @xgonc,

 

Doubt it will break anything, but to be safe take a backup.

 

 

Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-VoIP Installation Scripts
USG-4-PRO • USG
USW-48-500W • USW-24-POE-250W 2x • USW-16-POE-150W 3x • USW-24 • USW-8-150W • USW-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M
UCK-G2-PLUS • UCK-G2 • UCK
New Member
Posts: 22
Registered: ‎12-01-2018
Kudos: 3

Re: UniFi Installation Scripts | UniFi Easy Update Scripts | Ubuntu 18.04 and 16.04 | Debian 8 and 9

Again thanks for your great work.

Just updated my AWS controller from 5.9.x to 5.10.x and it worked great.  I thought it hung on "checking update availability" as it sat on that screen for several minutes, but then it all went through.  

 

Ubiquiti added a nice "here's whats new" tutorial on the update which is nice.

Senior Member
Posts: 16,020
Registered: ‎08-04-2017
Kudos: 2913
Solutions: 791

Re: UniFi Installation Scripts | UniFi Easy Update Scripts | Ubuntu 18.04 and 16.04 | Debian 8 and 9

Hello @apostolakisl,

 

You’re welcome!

I will add a message the check on how long the check can take!

 

The splash screen is indeed a nice thing for starters.

 

 

Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-VoIP Installation Scripts
USG-4-PRO • USG
USW-48-500W • USW-24-POE-250W 2x • USW-16-POE-150W 3x • USW-24 • USW-8-150W • USW-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M
UCK-G2-PLUS • UCK-G2 • UCK
New Member
Posts: 2
Registered: ‎09-06-2018

Re: UniFi Installation Scripts | UniFi Easy Update Scripts | Ubuntu 18.04 and 16.04 | Debian 8 and 9

Hello, I was just trying to install the unifi script 5.10.12 on my Pi with Debian 9. the Following error allways accours (i tryed serval times)

########################################################
# #
# 32 bit system detected! #
# Skipping MongoDB installation! #
# #
########################################################
########################################################
# #
# MongoDB has been installed successfully! #
# Installing OpenJDK 8! #
# #
########################################################


Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Vorgeschlagene Pakete:
fonts-dejavu-extra fonts-ipafont-gothic fonts-ipafont-mincho
fonts-wqy-microhei fonts-wqy-zenhei fonts-indic
Die folgenden NEUEN Pakete werden installiert:
ca-certificates-java openjdk-8-jre-headless
0 aktualisiert, 2 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
Es müssen 25,5 MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 91,8 MB Plattenplatz zusätzlich benutzt.
Holen:1 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian stretch/main armhf o penjdk-8-jre-headless armhf 8u181-b13-2~deb9u1 [25,5 MB]
Holen:2 http://ftp.halifax.rwth-aachen.de/raspbian/raspbian stretch/main armhf c a-certificates-java all 20170531+nmu1 [14,7 kB]
Es wurden 25,5 MB in 4 s geholt (5.281 kB/s).
Vormals nicht ausgewähltes Paket openjdk-8-jre-headless:armhf wird gewählt.
(Lese Datenbank ... 80957 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../openjdk-8-jre-headless_8u181-b13-2~deb9u1_arm hf.deb ...
Entpacken von openjdk-8-jre-headless:armhf (8u181-b13-2~deb9u1) ...
Vormals nicht ausgewähltes Paket ca-certificates-java wird gewählt.
Vorbereitung zum Entpacken von .../ca-certificates-java_20170531+nmu1_all.deb .. .
Entpacken von ca-certificates-java (20170531+nmu1) ...
ca-certificates-java (20170531+nmu1) wird eingerichtet ...
Error: missing `server' JVM at `/usr/lib/jvm/java-8-openjdk-armhf/jre/lib/arm/se rver/libjvm.so'.
Please install or use the JRE or JDK that contains these missing components.
dpkg: Fehler beim Bearbeiten des Paketes ca-certificates-java (--configure):
Unterprozess installiertes post-installation-Skript gab den Fehlerwert 4 zurück
Trigger für ca-certificates (20161130+nmu1+deb9u1) werden verarbeitet ...
Updating certificates in /etc/ssl/certs...
0 added, 0 removed; done.
Running hooks in /etc/ca-certificates/update.d...

Error: missing `server' JVM at `/usr/lib/jvm/java-8-openjdk-armhf/jre/lib/arm/se rver/libjvm.so'.
Please install or use the JRE or JDK that contains these missing components.
E: /etc/ca-certificates/update.d/jks-keystore exited with code 1.
done.
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von openjdk-8-jre-headless: armhf:
openjdk-8-jre-headless:armhf hängt ab von ca-certificates-java; aber:
Paket ca-certificates-java ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes openjdk-8-jre-headless:armhf (--configu re):
Abhängigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
ca-certificates-java
openjdk-8-jre-headless:armhf
E: Sub-process /usr/bin/dpkg returned an error code (1)
OK:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease
OK:2 http://archive.raspberrypi.org/debian stretch InRelease
Ign:3 http://ftp.nl.debian.org/debian stretch InRelease
Holen:4 http://ftp.nl.debian.org/debian stretch Release [118 kB]
Holen:5 http://ftp.nl.debian.org/debian stretch Release.gpg [2.434 B]
Ign:5 http://ftp.nl.debian.org/debian stretch Release.gpg
Holen:6 http://ftp.nl.debian.org/debian stretch/main armhf Packages [6.918 kB]
Holen:7 http://ftp.nl.debian.org/debian stretch/main Translation-en [5.388 kB]
Holen:8 http://ftp.nl.debian.org/debian stretch/main Translation-de_DE [830 B]
Holen:9 http://ftp.nl.debian.org/debian stretch/main Translation-de [1.620 kB]
Es wurden 14,0 MB in 14 s geholt (993 kB/s).
Paketlisten werden gelesen... Fertig
W: GPG-Fehler: http://ftp.nl.debian.org/debian stretch Release: Die folgenden Si gnaturen konnten nicht überprüft werden, weil ihr öffentlicher Schlüssel nicht v erfügbar ist: NO_PUBKEY 8B48AD6246925553 NO_PUBKEY 7638D0442B90D010 NO_PUBKEY EF 0F382A1A7B6500
W: The repository 'http://ftp.nl.debian.org/debian stretch Release' is not signe d.
N: Data from such a repository can't be authenticated and is therefore potential ly dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration deta ils.
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
ca-certificates-java ist schon die neueste Version (20170531+nmu1).
openjdk-8-jre-headless ist schon die neueste Version (8u181-b13-2~deb9u1).
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 138 nicht aktualisiert.
2 nicht vollständig installiert oder entfernt.
Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt.
ca-certificates-java (20170531+nmu1) wird eingerichtet ...
Error: missing `server' JVM at `/usr/lib/jvm/java-8-openjdk-armhf/jre/lib/arm/se rver/libjvm.so'.
Please install or use the JRE or JDK that contains these missing components.
dpkg: Fehler beim Bearbeiten des Paketes ca-certificates-java (--configure):
Unterprozess installiertes post-installation-Skript gab den Fehlerwert 4 zurück
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von openjdk-8-jre-headless: armhf:
openjdk-8-jre-headless:armhf hängt ab von ca-certificates-java; aber:
Paket ca-certificates-java ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes openjdk-8-jre-headless:armhf (--configu re):
Abhängigkeitsprobleme - verbleibt unkonfiguriert
Trigger für ca-certificates (20161130+nmu1+deb9u1) werden verarbeitet ...
Updating certificates in /etc/ssl/certs...
0 added, 0 removed; done.
Running hooks in /etc/ca-certificates/update.d...

Error: missing `server' JVM at `/usr/lib/jvm/java-8-openjdk-armhf/jre/lib/arm/se rver/libjvm.so'.
Please install or use the JRE or JDK that contains these missing components.
E: /etc/ca-certificates/update.d/jks-keystore exited with code 1.
done.
Fehler traten auf beim Bearbeiten von:
ca-certificates-java
openjdk-8-jre-headless:armhf
E: Sub-process /usr/bin/dpkg returned an error code (1)

###############################################################

An error occurred. Aborting script..
Please contact Glenn R. (AmazedMender16) on the Community Forums!


root@raspberrypi:/home/pi#

 

How could i solve this problem

thank you in advance, Peter

Senior Member
Posts: 16,020
Registered: ‎08-04-2017
Kudos: 2913
Solutions: 791

Re: UniFi Installation Scripts | UniFi Easy Update Scripts | Ubuntu 18.04 and 16.04 | Debian 8 and 9

[ Edited ]

Hello @moontrap,


Run the following command and try again.

apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv 8B48AD6246925553
apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv 7638D0442B90D010
apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv EF0F382A1A7B6500

 

I will reach out to you via a PM.

 

 

Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-VoIP Installation Scripts
USG-4-PRO • USG
USW-48-500W • USW-24-POE-250W 2x • USW-16-POE-150W 3x • USW-24 • USW-8-150W • USW-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M
UCK-G2-PLUS • UCK-G2 • UCK
New Member
Posts: 2
Registered: ‎10-23-2016

Re: UniFi Installation Scripts | UniFi Easy Update Scripts | Ubuntu 18.04 and 16.04 | Debian 8 and 9

Hello Glenn,
thanks again for your great support!

many greetings Isostar
Senior Member
Posts: 16,020
Registered: ‎08-04-2017
Kudos: 2913
Solutions: 791

Re: UniFi Installation Scripts | UniFi Easy Update Scripts | Ubuntu 18.04 and 16.04 | Debian 8 and 9

Hello @isostar1101,

 

You're welcome!

Wish you the best with your new controller!

 


Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-VoIP Installation Scripts
USG-4-PRO • USG
USW-48-500W • USW-24-POE-250W 2x • USW-16-POE-150W 3x • USW-24 • USW-8-150W • USW-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M
UCK-G2-PLUS • UCK-G2 • UCK
Member
Posts: 105
Registered: ‎12-19-2009
Kudos: 6

Re: UniFi Installation Scripts | UniFi Easy Update Scripts | Ubuntu 18.04 and 16.04 | Debian 8 and 9

[ Edited ]

I had a problem w/ my old controller.  I created a new one.  Ran the script "unifi-5.10.12.sh" and it all installed correctly.  

 

I then restored my backup... but it isn't accepting my username/password on the web interface.

 

I'd like to clear it and try a different backup.  How do I do reset the controller installation from the command line?

 

Edit:  Ubuntu 16.04 x86_64

 

Thanks!

 

 

Nevermind.  Solved Man Happy

  - apt purge unifi

 

Then run the script again.

New Member
Posts: 1
Registered: ‎04-26-2018

Re: UniFi Installation Scripts | UniFi Easy Update Scripts | Ubuntu 18.04 and 16.04 | Debian 8 and 9

[ Edited ]

Hello All,

 

Ubuntu 18.04 LTS

Controller 5.10.12

Used the install script.

 

I get the following error when starting the unifi service.

 

UniFi SDN Controller 5.10.12 has been installed successfully
# Your controller address: https://192.168.1.3:8443


# UniFi failed to start... Please contact Glenn R. (AmazedMender16) on the Community Forums!
# CTRL + C to exit UniFi Status


# Author | Glenn R.
# Email | glennrietveld8@hotmail.nl
# Website | https://GlennR.nl

 

● unifi.service - unifi
Loaded: loaded (/lib/systemd/system/unifi.service; enabled; vendor preset: enabled)
Active: failed (Result: start-limit-hit) since Mon 2019-02-11 15:22:21 EST; 29s ago
Process: 5885 ExecStop=/usr/lib/unifi/bin/unifi.init stop (code=exited, status=0/SUCCESS)
Process: 5772 ExecStart=/usr/lib/unifi/bin/unifi.init start (code=exited, status=0/SUCCESS)

Feb 11 15:22:21 UtilityMachine systemd[1]: unifi.service: Service hold-off time over, scheduling restart.
Feb 11 15:22:21 UtilityMachine systemd[1]: unifi.service: Scheduled restart job, restart counter is at 16.
Feb 11 15:22:21 UtilityMachine systemd[1]: Stopped unifi.
Feb 11 15:22:21 UtilityMachine systemd[1]: unifi.service: Start request repeated too quickly.
Feb 11 15:22:21 UtilityMachine systemd[1]: unifi.service: Failed with result 'start-limit-hit'.
Feb 11 15:22:21 UtilityMachine systemd[1]: Failed to start unifi.

 

I already restart the machine.

 

Any ideas?

 

Thank you Community! 

Senior Member
Posts: 16,020
Registered: ‎08-04-2017
Kudos: 2913
Solutions: 791

Re: UniFi Installation Scripts | UniFi Easy Update Scripts | Ubuntu 18.04 and 16.04 | Debian 8 and 9

Hello @brianktx,

 

Sorry for the late reply, glad you already found a way out!

 

 

Regards,
Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-VoIP Installation Scripts
USG-4-PRO • USG
USW-48-500W • USW-24-POE-250W 2x • USW-16-POE-150W 3x • USW-24 • USW-8-150W • USW-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M
UCK-G2-PLUS • UCK-G2 • UCK
Senior Member
Posts: 16,020
Registered: ‎08-04-2017
Kudos: 2913
Solutions: 791

Re: UniFi Installation Scripts | UniFi Easy Update Scripts | Ubuntu 18.04 and 16.04 | Debian 8 and 9

Hello @mgori50,

 

I will reach out to you!

 


Regards,
Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-VoIP Installation Scripts
USG-4-PRO • USG
USW-48-500W • USW-24-POE-250W 2x • USW-16-POE-150W 3x • USW-24 • USW-8-150W • USW-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M
UCK-G2-PLUS • UCK-G2 • UCK
Senior Member
Posts: 16,020
Registered: ‎08-04-2017
Kudos: 2913
Solutions: 791

Re: UniFi Installation Scripts | UniFi Easy Update Scripts | Ubuntu 18.04 and 16.04 | Debian 8 and 9

Hello @moontrap,

 

Thanks for letting me remote into the PI!

The controller is up and running, goodluck with your controller!

 

 

Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-VoIP Installation Scripts
USG-4-PRO • USG
USW-48-500W • USW-24-POE-250W 2x • USW-16-POE-150W 3x • USW-24 • USW-8-150W • USW-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M
UCK-G2-PLUS • UCK-G2 • UCK
New Member
Posts: 2
Registered: ‎08-17-2017

Re: UniFi Installation Scripts | UniFi Easy Update Scripts | Ubuntu 18.04 and 16.04 | Debian 8 and 9

Hi,

 

I got this fails

 

unifi.service - unifi
Loaded: loaded (/lib/systemd/system/unifi.service; enabled; vendor preset: enabled)
Active: active (running) since Mon 2019-02-11 23:20:06 CET; 3min 41s ago
Process: 925 ExecStart=/usr/lib/unifi/bin/unifi.init start (code=exited, status=0/SUCCESS)
Main PID: 1013 (jsvc)
Tasks: 103 (limit: 2361)
Memory: 428.0M
CGroup: /system.slice/unifi.service
├─1013 unifi -cwd /usr/lib/unifi -home /usr/lib/jvm/java-8-openjdk-amd64/jre/ -cp /usr/share/java/commons-daemon.jar:/usr/lib/unifi/lib/ace.jar -pidfile /var
├─1015 unifi -cwd /usr/lib/unifi -home /usr/lib/jvm/java-8-openjdk-amd64/jre/ -cp /usr/share/java/commons-daemon.jar:/usr/lib/unifi/lib/ace.jar -pidfile /var
├─1016 unifi -cwd /usr/lib/unifi -home /usr/lib/jvm/java-8-openjdk-amd64/jre/ -cp /usr/share/java/commons-daemon.jar:/usr/lib/unifi/lib/ace.jar -pidfile /var
├─1121 /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java -Dfile.encoding=UTF-8 -Djava.awt.headless=true -Dapple.awt.UIElement=true -Xmx1024M -XX:+ExitOnOutOfMem
└─1322 bin/mongod --dbpath /usr/lib/unifi/data/db --port 27117 --unixSocketPrefix /usr/lib/unifi/run --logappend --logpath /usr/lib/unifi/logs/mongod.log --b

Feb 11 23:18:15 unifi systemd[1]: Starting unifi...
Feb 11 23:18:16 unifi unifi.init[925]: * Starting Ubiquiti UniFi Controller unifi
Feb 11 23:18:21 unifi unifi[1015]: Feb 11, 2019 11:18:21 PM org.apache.commons.httpclient.HttpMethodDirector executeWithRetry
INFO: I/O exception (java.net.ConnectException) caught when processing request: Connection refused (Connection refused)
Feb 11 23:18:21 unifi unifi[1015]: Feb 11, 2019 11:18:21 PM org.apache.commons.httpclient.HttpMethodDirector executeWithRetry
INFO: Retrying request
Feb 11 23:18:21 unifi unifi[1015]: Feb 11, 2019 11:18:21 PM org.apache.commons.httpclient.HttpMethodDirector executeWithRetry
INFO: I/O exception (java.net.ConnectException) caught when processing request: Connection refused (Connection refused)
Feb 11 23:18:21 unifi unifi[1015]: Feb 11, 2019 11:18:21 PM org.apache.commons.httpclient.HttpMethodDirector executeWithRetry
INFO: Retrying request
Feb 11 23:18:21 unifi unifi[1015]: Feb 11, 2019 11:18:21 PM org.apache.commons.httpclient.HttpMethodDirector executeWithRetry
INFO: I/O exception (java.net.ConnectException) caught when processing request: Connection refused (Connection refused)
Feb 11 23:18:21 unifi unifi[1015]: Feb 11, 2019 11:18:21 PM org.apache.commons.httpclient.HttpMethodDirector executeWithRetry
INFO: Retrying request
Feb 11 23:20:06 unifi unifi.init[925]: ...done.
Feb 11 23:20:06 unifi systemd[1]: Started unifi.

Senior Member
Posts: 16,020
Registered: ‎08-04-2017
Kudos: 2913
Solutions: 791

Re: UniFi Installation Scripts | UniFi Easy Update Scripts | Ubuntu 18.04 and 16.04 | Debian 8 and 9

Hello @mlhdk,

 

Your controller started succesfully!

Those errors are cosmetic and don't have an impact on the controller startup, Ubiquiti is already working on a fix!

 

 

Regards,
Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-VoIP Installation Scripts
USG-4-PRO • USG
USW-48-500W • USW-24-POE-250W 2x • USW-16-POE-150W 3x • USW-24 • USW-8-150W • USW-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M
UCK-G2-PLUS • UCK-G2 • UCK
New Member
Posts: 2
Registered: ‎08-17-2017

Re: UniFi Installation Scripts | UniFi Easy Update Scripts | Ubuntu 18.04 and 16.04 | Debian 8 and 9

Senior Member
Posts: 16,020
Registered: ‎08-04-2017
Kudos: 2913
Solutions: 791

Re: UniFi Installation Scripts | UniFi Easy Update Scripts | Ubuntu 18.04 and 16.04 | Debian 8 and 9

Hello @mlhdk,


You're welcome!

Goodluck with your new controller!

 

 

Regards,
Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-VoIP Installation Scripts
USG-4-PRO • USG
USW-48-500W • USW-24-POE-250W 2x • USW-16-POE-150W 3x • USW-24 • USW-8-150W • USW-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M
UCK-G2-PLUS • UCK-G2 • UCK
New Member
Posts: 6
Registered: ‎01-18-2017
Kudos: 1

Re: UniFi Installation Scripts | UniFi Easy Update Scripts | Ubuntu 18.04 and 16.04 | Debian 8 and 9

[ Edited ]
# Do you want to proceed with upgrading the devices? (Y/n) Y
#########################################################################

# Checking if the firmware is available

Stuck here upgrading from current unifi-5.9.29 (ubuntu 18.04) to current 5.10.

Nothing happens after this step. Thoughts?

New Member
Posts: 3
Registered: ‎09-28-2018
Kudos: 1

Re: UniFi Installation Scripts | UniFi Easy Update Scripts | Ubuntu 18.04 and 16.04 | Debian 8 and 9

 

 


@3fghkr8qbeopz07 wrote:
# Do you want to proceed with upgrading the devices? (Y/n) Y
#########################################################################

# Checking if the firmware is available

Stuck here upgrading from current unifi-5.9.29 (ubuntu 18.04) to current 5.10.

Nothing happens after this step. Thoughts?


I am also getting stuck there on an Azure VM with the Same 5.9.29 Controller and Ubuntu 18.04.


Also when i Selected to first make a backup it froze while checking if the backup was made.

 

 

New Member
Posts: 4
Registered: ‎02-09-2017

Re: UniFi Installation Scripts | UniFi Easy Update Scripts | Ubuntu 18.04 and 16.04 | Debian 8 and 9

@brianktx If you are like me, I got confused by having to SSH into my host with one set of credentials and then backup and upgrade the Unifi controller with another set of credentials (the Unifi controller login). Password managers are great for this kind of thing.  

 

PS.

@AmazedMender16 Thank you so much for this script, you saved me a ton of time and anxiety. Just went from 5.8.30 --> 5.10.12 flawlessly. 

Reply