Reply
Emerging Member
Posts: 76
Registered: ‎08-16-2015
Kudos: 2
Accepted Solution

UniFis and Google Home

Hi everyone:

I have two first generation UniFi access points with zero handoff (no 24/7 controller). I also have a ERX SFP router acting as a switch as well. I recently received a Google Home as a gift and am experiencing issues with connectivity. For example, I have to sometimes reboot the Home in order for it to properly connect to our downstairs AP. I tried upgrading the firmware on our APs but am still experiencing the same issue. Also, a family member's tablet was not properly connecting to our upstairs AP today. I had to reboot the router via SSH to fix it.

Does anyone have tips for fixing these issues? Could zero handoff be causing these issues?

Any advice would be greatly appreciated.

Accepted Solutions
SuperUser
Posts: 41,684
Registered: ‎06-23-2009
Kudos: 8501
Solutions: 1407

Re: UniFis and Google Home

Before you toy with settings, have you made the changes

I suggested? Turn off ZH, put the two radio on different

channels between 1, 6 and 11, and set the rf output to

medium or low. Let us know the results.   Dave

 


> HQ in Seacoast region New Hampshire U.S.A.
> Ubiquiti Certified Trainer [UCT] for:
     UBWA [AirMax] / UEWA [UniFi] / UBRSS [routers]
UBNT.NH@gmail.com

View solution in original post


All Replies
Emerging Member
Posts: 76
Registered: ‎08-16-2015
Kudos: 2

Re: UniFis and Google Home

I should also mention that I haven't upgraded our router's firmware in a long time. I believe it runs 1.7.0. Could that be the issue?
SuperUser
Posts: 41,684
Registered: ‎06-23-2009
Kudos: 8501
Solutions: 1407

Re: UniFis and Google Home

Avoid ZH unless there's a crucial reason to use it;

new models do not support it.

 

Update your controller to the latest release; that will

also provide new firmware for the radios. There have

been several patches and improvements.   Dave


> HQ in Seacoast region New Hampshire U.S.A.
> Ubiquiti Certified Trainer [UCT] for:
     UBWA [AirMax] / UEWA [UniFi] / UBRSS [routers]
UBNT.NH@gmail.com
Emerging Member
Posts: 76
Registered: ‎08-16-2015
Kudos: 2

Re: UniFis and Google Home

Thank you for your reply! If I were to turn off ZH, I'd need to have both APs use different channels and adjust the power levels manually, correct?

Yesterday I updated the controller on my PC and both APs updated. Could updating the firmware on the ERX SFP help as well? It is a bit of a pain because I'd prefer to hardwire into an empty port on the router for the upgrade.
SuperUser
Posts: 20,401
Registered: ‎09-17-2013
Kudos: 5133
Solutions: 1458

Re: UniFis and Google Home

Of course.

But then again, you have to adjust the power levels of the APs in ZHO-mode as well.

 

Updating the ER-X won't really help with wifi issues ...

Emerging Member
Posts: 76
Registered: ‎08-16-2015
Kudos: 2

Re: UniFis and Google Home


@dpurgert wrote:

Of course.

But then again, you have to adjust the power levels of the APs in ZHO-mode as well.

 

Updating the ER-X won't really help with wifi issues ...


Thanks! I found this: https://productforums.google.com/forum/#!starred/googlehome/rBSy3z-Tu1o

 

I can't find that I have UPnP enabled. Could that be it? Below is my config.

 

firewall {
    all-ping enable
    broadcast-ping disable
    ipv6-name WAN_IN_IPv6 {
        default-action drop
        enable-default-log
        rule 1 {
            action accept
            description "Allow established connections"
            state {
                established enable
                related enable
            }
        }
        rule 2 {
            action drop
            description "Drop invalid packets"
            state {
                invalid enable
            }
        }
    }
    ipv6-name WAN_LOCAL_IPv6 {
        default-action drop
        enable-default-log
        rule 1 {
            action accept
            description "Allow established connections"
            state {
                established enable
                related enable
            }
        }
        rule 2 {
            action drop
            description "Drop invalid packets"
            state {
                invalid enable
            }
        }
        rule 500 {
            action drop
            description "Block IPv6-ICMP ping from the Internet"
            icmpv6 {
                type ping
            }
            protocol ipv6-icmp
        }
        rule 510 {
            action accept
            description "Allow IPv6-ICMP"
        }
        rule 700 {
            action accept
            description "Allow DHCPv6 responses from ISP"
            destination {
                port dhcpv6-client
            }
            protocol udp
            source {
                port dhcpv6-server
            }
        }
    }
    ipv6-receive-redirects disable
    ipv6-src-route disable
    ip-src-route disable
    log-martians enable
    name WAN_IN {
        default-action drop
        description "WAN to internal"
        rule 10 {
            action accept
            description "Allow established/related"
            state {
                established enable
                related enable
            }
        }
        rule 20 {
            action drop
            description "Drop invalid state"
            state {
                invalid enable
            }
        }
    }
    name WAN_LOCAL {
        default-action drop
        description "WAN to router"
        rule 10 {
            action accept
            description "Allow established/related"
            state {
                established enable
                related enable
            }
        }
        rule 20 {
            action drop
            description "Drop invalid state"
            state {
                invalid enable
            }
        }
    }
    receive-redirects disable
    send-redirects enable
    source-validation disable
    syn-cookies enable
}
interfaces {
    ethernet eth0 {
        address dhcp
        description Internet
        dhcp-options {
            default-route update
            default-route-distance 210
            name-server no-update
        }
        dhcpv6-options {
        }
        dhcpv6-pd {
            pd 0 {
                interface switch0 {
                    host-address ::1
                    prefix-id :0
                    service slaac
                }
                prefix-length 60
            }
            rapid-commit enable
        }
        duplex auto
        firewall {
            in {
                ipv6-name WAN_IN_IPv6
                name WAN_IN
            }
            local {
                ipv6-name WAN_LOCAL_IPv6
                name WAN_LOCAL
            }
        }
        speed auto
    }
    ethernet eth1 {
        description Local
        duplex auto
        poe {
            output 24v
        }
        speed auto
    }
    ethernet eth2 {
        description Local
        duplex auto
        poe {
            output 24v
        }
        speed auto
    }
    ethernet eth3 {
        description Local
        duplex auto
        poe {
            output off
        }
        speed auto
    }
    ethernet eth4 {
        description Local
        duplex auto
        poe {
            output off
        }
        speed auto
    }
    ethernet eth5 {
        duplex auto
        speed auto
    }
    loopback lo {
    }
    switch switch0 {
        address 192.168.1.1/24
        description Local
        mtu 1500
        switch-port {
            interface eth1
            interface eth2
            interface eth3
            interface eth4
        }
    }
}
service {
    dhcp-server {
        disabled false
        hostfile-update disable
        shared-network-name LAN {
            authoritative disable
            subnet 192.168.1.0/24 {
                default-router 192.168.1.1
                dns-server 192.168.1.1
                lease 86400
                start 192.168.1.38 {
                    stop 192.168.1.243
                }
            }
        }
    }
    dns {
        forwarding {
            cache-size 150
            listen-on switch0
        }
    }
    gui {
        https-port 443
    }
    nat {
        rule 5010 {
            outbound-interface eth0
            type masquerade
        }
    }
    ssh {
        port 22
        protocol-version v2
    }
}
system {
    host-name ubnt
    login {
        user {
            authentication {
                encrypted-password
                plaintext-password
            }
            level admin
        }
    }
    ntp {
        server 0.ubnt.pool.ntp.org {
        }
        server 1.ubnt.pool.ntp.org {
        }
        server 2.ubnt.pool.ntp.org {
        }
        server 3.ubnt.pool.ntp.org {
        }
    }
    syslog {
        global {
            facility all {
                level notice
            }
            facility protocols {
                level debug
            }
        }
    }
    time-zone UTC
}
SuperUser
Posts: 20,401
Registered: ‎09-17-2013
Kudos: 5133
Solutions: 1458

Re: UniFis and Google Home

I wouldn't consider "not" having UPnP enabled as a problem ... but then again, I don't like devices punching holes in my firewalls for their own nefarious reasons.

Emerging Member
Posts: 76
Registered: ‎08-16-2015
Kudos: 2

Re: UniFis and Google Home

[ Edited ]

@dpurgert wrote:

I wouldn't consider "not" having UPnP enabled as a problem ... but then again, I don't like devices punching holes in my firewalls for their own nefarious reasons.


Same. It is also hard to determine whether or not the bulk of the problems I am experiencing have to do with our network or the device itself.

 

Thanks again!

SuperUser
Posts: 20,401
Registered: ‎09-17-2013
Kudos: 5133
Solutions: 1458

Re: UniFis and Google Home

Honestly, I'm not an expert with any of those kinds of devices.  If Google wants them to use upnp, it's probably because they need some ports forwarded or something from google's servers.  You might be able to poke around and find what ports they need opened, and just do it yourself ...

Emerging Member
Posts: 76
Registered: ‎08-16-2015
Kudos: 2

Re: UniFis and Google Home


@dpurgert wrote:

Honestly, I'm not an expert with any of those kinds of devices.  If Google wants them to use upnp, it's probably because they need some ports forwarded or something from google's servers.  You might be able to poke around and find what ports they need opened, and just do it yourself ...


Oh. I wonder if upnp is the issue. I would assume the whole thing wouldn't work at all if that was the issue though. Should I just enable it for the heck of it? Would these be the commands?

 

configure
set service upnp2 listen-on switch0
set service upnp2 nat-pmp enable
set service upnp2 secure-mode enable
set service upnp2 wan eth0
commit
save
SuperUser
Posts: 41,684
Registered: ‎06-23-2009
Kudos: 8501
Solutions: 1407

Re: UniFis and Google Home

Before you toy with settings, have you made the changes

I suggested? Turn off ZH, put the two radio on different

channels between 1, 6 and 11, and set the rf output to

medium or low. Let us know the results.   Dave

 


> HQ in Seacoast region New Hampshire U.S.A.
> Ubiquiti Certified Trainer [UCT] for:
     UBWA [AirMax] / UEWA [UniFi] / UBRSS [routers]
UBNT.NH@gmail.com
Emerging Member
Posts: 76
Registered: ‎08-16-2015
Kudos: 2

Re: UniFis and Google Home


@Dave-D wrote:

Before you toy with settings, have you made the changes

I suggested? Turn off ZH, put the two radio on different

channels between 1, 6 and 11, and set the rf output to

medium or low. Let us know the results.   Dave

 


I just made the changes. I changed both APs over to the default WLAN Group, switched the downstairs AP to channel 1, upstairs to channel 6, and both to transmit at medium power.

 

I think ZH could have definitely been causing problems. The Google Home is buggy but perhaps this will solve the connectivity issues.

 

Thanks again! I'll keep you updated.

Regular Member
Posts: 347
Registered: ‎04-10-2014
Kudos: 152
Solutions: 20

Re: UniFis and Google Home

I've had zero issues with my Google Home with AC-LR and an AC-Lite and I do not have uPNP enabled.

Emerging Member
Posts: 76
Registered: ‎08-16-2015
Kudos: 2

Re: UniFis and Google Home


@thesohoguy wrote:

I've had zero issues with my Google Home with AC-LR and an AC-Lite and I do not have uPNP enabled.


Thanks! Good to know. Do you use Spotify on it as well? For me, songs randomly stop playing or I have to repeat what I want to hear.

Regular Member
Posts: 347
Registered: ‎04-10-2014
Kudos: 152
Solutions: 20

Re: UniFis and Google Home

I use Google Play Music and I've had no issues with playback. I have 5 Chromcast audios on 4 different UAPs and I can stream to those and the Google Home at the same time with no stops or stutters. 

Established Member
Posts: 1,733
Registered: ‎08-27-2010
Kudos: 1084
Solutions: 51

Re: UniFis and Google Home

I have google home running on a 1st Gen UAP with controller 4.3.11 and UAP firmware 3.7.39.6065

I can't teach you anything, I can only make you think
Don't forget to mark your thread as solved and to give kudos
Emerging Member
Posts: 76
Registered: ‎08-16-2015
Kudos: 2

Re: UniFis and Google Home


@thesohoguy wrote:

I use Google Play Music and I've had no issues with playback. I have 5 Chromcast audios on 4 different UAPs and I can stream to those and the Google Home at the same time with no stops or stutters. 


Thanks! Everything seems to be working a lot better after adjusting the settings. Spotify is still a bit buggy but that seems pretty common. I also hooked up another Chromcast Audio.

Emerging Member
Posts: 76
Registered: ‎08-16-2015
Kudos: 2

Re: UniFis and Google Home


@KimchiGUN wrote:

I have google home running on a 1st Gen UAP with controller 4.3.11 and UAP firmware 3.7.39.6065


Thanks! Seems to be working a lot better now.

Emerging Member
Posts: 76
Registered: ‎08-16-2015
Kudos: 2

Re: UniFis and Google Home


@Dave-D wrote:

Before you toy with settings, have you made the changes

I suggested? Turn off ZH, put the two radio on different

channels between 1, 6 and 11, and set the rf output to

medium or low. Let us know the results.   Dave

 


The Google Home connection appears to be very stable now. I think ZH was confusing it. Thank you so much! I should have never used ZH. Smiley Happy

SuperUser
Posts: 41,684
Registered: ‎06-23-2009
Kudos: 8501
Solutions: 1407

Re: UniFis and Google Home

Welcome--enjoy!   Dave


> HQ in Seacoast region New Hampshire U.S.A.
> Ubiquiti Certified Trainer [UCT] for:
     UBWA [AirMax] / UEWA [UniFi] / UBRSS [routers]
UBNT.NH@gmail.com
Reply