Reply
Emerging Member
Posts: 41
Registered: ‎09-24-2015
Kudos: 7
Solutions: 1
Accepted Solution

Unifi Controller - All devices Disconnected/Adopting

I just had a customer contact me this morning and told me that when he loaded the controller everything was showing as disconnected and was stuck on adopting.  At the same time, everything was still working properly on the network.  This seems to be just a controller issue.  I was able to log onto his local computer running the controller and verify the issue.  I did this through the internet so obviously the computer running the controller has a connection to the rest of the network.  Does anyone have any ideas of whats going on?  Reboots have not solved the problem.  Everything seems to have gone down within a few minutes of each other.  

 

 

Screen Shot 2016-10-27 at 12.05.04 PM.png

Accepted Solutions
Emerging Member
Posts: 41
Registered: ‎09-24-2015
Kudos: 7
Solutions: 1

Re: Unifi Controller - All devices Disconnected/Adopting

As of this morning everything fixed itself.  Since its hard to troubleshoot something that works I'll close this out for the time being.  

View solution in original post


All Replies
Emerging Member
Posts: 41
Registered: ‎09-24-2015
Kudos: 7
Solutions: 1

Re: Unifi Controller - All devices Disconnected/Adopting

Some pictures didnt upload, trying again.Screen Shot 2016-10-27 at 12.06.09 PM.pngScreen Shot 2016-10-27 at 12.03.18 PM.png

Ubiquiti Employee
Posts: 7,521
Registered: ‎03-17-2015
Kudos: 4836
Solutions: 197

Re: Unifi Controller - All devices Disconnected/Adopting

What is the controller running on?  Can you email me your support file?  brandon dot gilles at ubnt dot com.

 

Thanks,

Brandon

Want to try out new features or fixes before they're released as Stable? Sign up for Beta here: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Signup-for-Beta-Access
Ubiquiti Employee
Posts: 9,081
Registered: ‎01-28-2013
Kudos: 15486
Solutions: 600
Contributions: 20

Re: Unifi Controller - All devices Disconnected/Adopting

[ Edited ]

This may seem like a silly question, but does the system with the controller software on it have a static or sticky IP? If it's dynamic, then that may explain why they wanted to adopt when the controller started up again. Although they should have adopted if the controller discovered them. 

 

Are you able to SSH into any of the devices and check the status shown with 'info'?

 

Cheers,

Mike

 

EDIT: removed redundant question about the support file. 

Emerging Member
Posts: 41
Registered: ‎09-24-2015
Kudos: 7
Solutions: 1

Re: Unifi Controller - All devices Disconnected/Adopting

As of this morning everything fixed itself.  Since its hard to troubleshoot something that works I'll close this out for the time being.  

Ubiquiti Employee
Posts: 7,521
Registered: ‎03-17-2015
Kudos: 4836
Solutions: 197

Re: Unifi Controller - All devices Disconnected/Adopting


@joshlaymon wrote:

As of this morning everything fixed itself.  Since its hard to troubleshoot something that works I'll close this out for the time being.  


OK.  Weird.  Keep us posted.

Want to try out new features or fixes before they're released as Stable? Sign up for Beta here: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Signup-for-Beta-Access
New Member
Posts: 2
Registered: ‎09-20-2016
Kudos: 1

Re: Unifi Controller - All devices Disconnected/Adopting

I noticed I was having this exact same issue today. I have no idea how long it has been going on since everything was still working fine and I don't login to the controller that often to look at things. I have an AP AC Pro and 24 Port PoE switch constantly switching between Adopting and Disconnected every minute or so but everything on the network is still working perfectly fine.

New Member
Posts: 1
Registered: ‎04-19-2017

Re: Unifi Controller - All devices Disconnected/Adopting

I have the same problem. And the controller software is running on a machine with dynamic IP address. Is this a problem?

New Member
Posts: 3
Registered: ‎12-15-2016

Re: Unifi Controller - All devices Disconnected/Adopting

I am currently experiencing the same problem. i noticed yesterday and i'm suspecting it was as a result of the upgrade i did on all my devices from 3.7.17.5220 to 3.7.21.5389. the controller is on a windows machine with a static IP address. Find attached the screenshot.  

screenshot of controller.png
New Member
Posts: 3
Registered: ‎12-15-2016

Re: Unifi Controller - All devices Disconnected/Adopting

But then everything is working fine on the network execpt i am not able to manage my device but then when i ping the devices IP address, they all respond well. Please can anyone help. 

 

Thank you.

New Member
Posts: 9
Registered: ‎04-09-2016
Kudos: 2

Re: Unifi Controller - All devices Disconnected/Adopting

Same problem here, everything is disconnected in Red.

Site still works though but is not managble since all the devices are disconnected.

Ubiquiti Employee
Posts: 7,521
Registered: ‎03-17-2015
Kudos: 4836
Solutions: 197

Re: Unifi Controller - All devices Disconnected/Adopting

Anyone having this problem could you please email your support files to yhlee at ubnt?
Want to try out new features or fixes before they're released as Stable? Sign up for Beta here: https://help.ubnt.com/hc/en-us/articles/204908664-How-To-Signup-for-Beta-Access
New Member
Posts: 1
Registered: ‎02-04-2018

Re: Unifi Controller - All devices Disconnected/Adopting

@UBNT-Brandon I have seen this now for days. It goes away if I stop the controller and start again.

If I SSH into a given AP, Switch or USG i can se that the inform adresse have changed on them all

 

It is a matter of half day this it will be back, is the option still there to send you support files?

 

Running 5.7.20 on controller, 3.9.21 on ap and 4.4.18 on USG

New Member
Posts: 3
Registered: ‎04-24-2018

Re: Unifi Controller - All devices Disconnected/Adopting

We are having this issue as well. I have our controller on the customer laptop. We are running the 5.6.37 for windows version. I have 4 UAP-AC-M-Pros and 1 UAP-AM-M connected to it. I had them originally on my controller. I forgot them on my controller and adopted on the windows computer. They all adopted and everything was running great. The windows computer controller was shut down when customer shut the computer down. Upon turning the controller back on the devices just went from adop to disconnect.

If I have my computer on and my controller up I can see the devices and they say "managed by other". So it's like they are connected to that controller but for some reason the status just goes from adopting to disconnected. Any ideas?

Senior Member
Posts: 2,934
Registered: ‎04-26-2016
Kudos: 1119
Solutions: 303

Re: Unifi Controller - All devices Disconnected/Adopting

Does the customer laptop have a fixed IP address? If it doesn’t have a fixed IP the devices won’t be able to find it if the IP changes after a computer restart.

 

Also, don’t use a wireless connection.

New Member
Posts: 3
Registered: ‎04-24-2018

Re: Unifi Controller - All devices Disconnected/Adopting

I didn't restart the computer. I just restarted the controller and the adopt disconnect kept coming up. Computer would have had the same IP address.

New Member
Posts: 39
Registered: ‎06-23-2018
Kudos: 9

Re: Unifi Controller - All devices Disconnected/Adopting

I'm having this same issue after a failed controller upgrade. Controller is working fine. Network is working fine. But all devices show as Disconnected in the controller.

New Member
Posts: 1
Registered: ‎06-06-2016
Kudos: 1

Re: Unifi Controller - All devices Disconnected/Adopting

I have experienced this same issue this morning. All AP devices were appearing as Disconnected. After trying everything (forgetting the APs, informing, adopting), the devices kept on Informing/Adopting status and disconnecting from time to time. I had no issues communicating with them through SSH.

 

After spending hours trying to figure out what was happening, I remembed I updated the system Java Platform yesterday and it changed the java path in system ambient variables (the controller is on a Windows system). As soon as I corrected the new java path there in the variables, the controller was immediatly able to make the provisioning and all the devices were up and running again.

 

I'm not completely sure if it was the true solution and can be used to help you guys out, but that's what happened here. So I hope it can help you out too.

 

Regards.

New Member
Posts: 2
Registered: ‎11-08-2018

Re: Unifi Controller - All devices Disconnected/Adopting

Hello!

 

I've had a similar issue as the first post in this thread on a Windows Server Controller.

I've had it on several versions, latest now was 5.8.28 (upgrading now to 5.9.29).

 

For me it's like the APs and the Controller at some point looses connection and I get a lot of "adopting"->"disconnected"->"adopting" in an ever lasting loop -- until I SSH into each and every AP and do "reboot".

Then they come online again with no issues at all.

Even STUN is working so no firewall issues -- and it has happened on at least two versions of the controller. Let's hope the 5.9.29 might help ... But any ideas why it is like this is appriciated.

As said -- rebooting the APs is solving the issue. Rebooting the controller has no effect.

New Member
Posts: 15
Registered: ‎07-05-2011

Re: Unifi Controller - All devices Disconnected/Adopting

Same problem here. I've lost count how many times I've manually set the inform url via ssh, which usually fixes the problem for a week or so. Very interested in finding a solution.

 

This is on latest release firmware and cloud key gen2+ hardware

 

Thank you

Reply