Reply
New Member
Posts: 5
Registered: ‎03-17-2018
Kudos: 1

Unifi SNMPv3 authorization error

I have enabled SNMPv3 via the Unifi controller (via Settings -> Services -> SNMP). When I try to connect to one of the APs I get the following error:

 

    Error in packet.
    Reason: authorizationError (access denied to that object)

 

Using the command line:

 

    snmpwalk -v3 -u MyUser -a SHA -A MyPassword -l authNoPriv <AP_IP_ADDRESS>

 

A similar issue was reported here: https://community.ubnt.com/t5/UniFi-Wireless/UniFi-5-7-20-Stable-has-been-released/m-p/2284927/highl... by @dagb.

 

Does anybody know what other settings I would have to configure / apply to make SNMPv3 work?

New Member
Posts: 1
Registered: ‎09-24-2018
Kudos: 1

Re: Unifi SNMPv3 authorization error

[ Edited ]
mybkexpxerience kroger feedback

@pvandervelde wrote:

I have enabled SNMPv3 via the Unifi controller (via Settings -> Services -> SNMP). When I try to connect to one of the APs I get the following error:

 

    Error in packet.
    Reason: authorizationError (access denied to that object)

 

Using the command line:

 

    snmpwalk -v3 -u MyUser -a SHA -A MyPassword -l authNoPriv <AP_IP_ADDRESS>

 

A similar issue was reported here: https://community.ubnt.com/t5/UniFi-Wireless/UniFi-5-7-20-Stable-has-been-released/m-p/2284927/highl... by @dagb.

 

Does anybody know what other settings I would have to configure / apply to make SNMPv3 work?


Did you get any good solution?

New Member
Posts: 5
Registered: ‎03-17-2018
Kudos: 1

Re: Unifi SNMPv3 authorization error

Not so far unfortunately. Was hoping for somebody from UBNT would have some ideas. Maybe @UBNT-MikeD knows something?

New Member
Posts: 27
Registered: ‎06-27-2017
Kudos: 3

Re: Unifi SNMPv3 authorization error

[ Edited ]

Bumped into this issue as well when trying to snmpwalk the devices...

 

Command:

snmpwalk -v3 -l authNoPriv -u username -a SHA -A "passphrase" 0.0.0.0

 

Error:

Error in packet.

Reason: authorizationError (access denied to that object)

 

 

What I've found though, this is only applicable to the USG and UAP, when trying to snmpwalk the USW's I'm getting no issues and able to see all the OID's. 

 

New Member
Posts: 5
Registered: ‎03-17-2018
Kudos: 1

Re: Unifi SNMPv3 authorization error

Huh ok I should try it against the switch then. If that works then it sounds like a bug in the AP software maybe? @UBNT-MikeD is there anybody who could have a look at this?

Emerging Member
Posts: 96
Registered: ‎12-28-2016
Kudos: 33
Solutions: 3

Re: Unifi SNMPv3 authorization error

I’m having the exact same problem with my UAP-AC-Pro’s and UAP-AC-M-Pro on firmware 4.0.10.9653. 

Switches are all working okay, only my AP’s are failing...

Controller: CloudKey Gen1
Gateway: USG-3P, USG-4P
Switch’s: US-8-150W, US-8-60W
AP’s: UAP-AC-Pro, UAP-AC-M-Pro, UAP-nanoHD
New Member
Posts: 1
Registered: ‎11-04-2017
Kudos: 3

Re: Unifi SNMPv3 authorization error

This is what I use with my UAP-AC-HD with 4.0.10.9653 and works fine.

 

snmpwalk -v3 -l 'authPriv' -a 'SHA' -A 'PASSWORD' -u 'USERNAME' -x 'AES' -X 'PASSWORD' IP_ADDRESS .

It also works the same with USG-4P (4.4.36.5146617), USW-24 (4.0.10.9653) and USW-16POE (4.0.10.9653)

Emerging Member
Posts: 96
Registered: ‎12-28-2016
Kudos: 33
Solutions: 3

Re: Unifi SNMPv3 authorization error

[ Edited ]

It must be related to the model I guess. 

 

I have 2x UAP-AC-Pro-Gen2’s and a UAP-AC-Mesh-Pro and I have the SNMP error on all of them. 

 

All my switches work ok. 

 

Edit:

 

Actually, I found the issue. 

Switches etc are all okay with authNoPriv, but the UAP’s all need to use authPriv

Controller: CloudKey Gen1
Gateway: USG-3P, USG-4P
Switch’s: US-8-150W, US-8-60W
AP’s: UAP-AC-Pro, UAP-AC-M-Pro, UAP-nanoHD
New Member
Posts: 5
Registered: ‎03-17-2018
Kudos: 1

Re: Unifi SNMPv3 authorization error

Witht the current versions (4.0.10.9653 for the UAP and the switches and 4.4.36.5146617 for the USG) I can get data via smnpwalk if I use the 'authPriv' setting, using the same password for the auth side and the priv side. So it seems that's all working in my case.

 

Now I just need to get Telegraf to collect the data.

New Member
Posts: 1
Registered: ‎01-17-2019

Re: Unifi SNMPv3 authorization error


@William947 wrote:
dqfansurvey kroger Survey Feedback

@pvandervelde wrote:

I have enabled SNMPv3 via the Unifi controller (via Settings -> Services -> SNMP). When I try to connect to one of the APs I get the following error:

 

    Error in packet.
    Reason: authorizationError (access denied to that object)

 

Using the command line:

 

    snmpwalk -v3 -u MyUser -a SHA -A MyPassword -l authNoPriv <AP_IP_ADDRESS>

 

A similar issue was reported here: https://community.ubnt.com/t5/UniFi-Wireless/UniFi-5-7-20-Stable-has-been-released/m-p/2284927/highl... by @dagb.

 

Does anybody know what other settings I would have to configure / apply to make SNMPv3 work?


Did you get any good solution?


I think there is a mistake in the command line. Have you double checked it?

New Member
Posts: 5
Registered: ‎03-17-2018
Kudos: 1

Re: Unifi SNMPv3 authorization error

It turns out you need to use 'authPriv' and specify the password for both the authorization and the encryption parts as @jacabreragt did, even if you haven't configured it as such. Then it works just fine against all my devices

New Member
Posts: 3
Registered: ‎07-29-2014
Kudos: 1

Re: Unifi SNMPv3 authorization error

Yes, they do not give you an option for the Auth or encryption.  It's just SHA1/AES  so whatever you set for the username and password will be common to both Auth and Priv.  I know that not including the ability to choose the authentication or Encryption protocols, it would seem that it would be a noAuthNoPriv  but it's not.

 

snmpwalk v3 -l 'authPriv' -a 'SHA' -A 'PASSWORD' -u 'USERNAME' -x 'AES' -X  'PASSWORD' IP_ADDRESS  OID   

 

Highlighted
New Member
Posts: 1
Registered: Wednesday

Re: Unifi SNMPv3 authorization error

I wanted to add monitoring of my Unifi network devices, so this guide investigate using SNMPV3 which supports password authentication krogerfeedback.

Reply