Reply
New Member
Posts: 23
Registered: ‎12-20-2016
Kudos: 1
Solutions: 1

unable to update UAP since 4.0.14.9736 automatically , apparently ssl/cipher issue...

...since doing a manual upgrade using an http URL works fine.

Manual using https or a manual curl on the commandline of the AP also fail.

curl fails without a comment.

 

Obviously nobody even updated attempted to update a UAP in the lab. Probably none hanging around anymore.

Senior Member
Posts: 21,801
Registered: ‎08-04-2017
Kudos: 4113
Solutions: 1057

Re: unable to update UAP since 4.0.14.9736 automatically , apparently ssl/cipher issue...

Hello @DagoFrFu,

 

Try a HTTP upgrade, you could also CACHE the firmware and then upgrade.

 


Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation Scripts | UniFi-VoIP Installation Scripts
USG-XG-8 • USG-4-PRO • USG
US-XG-16 • US-48-500W • US-24-POE-250W 2x • US-16-POE-150W 3x • US-24 • US-8-150W • US-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD 2x • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M • UAP-AC-M-PRO 2x
UAS-XG • UCK-G2-PLUS • UCK-G2 • UCK
New Member
Posts: 23
Registered: ‎12-20-2016
Kudos: 1
Solutions: 1

Re: unable to update UAP since 4.0.14.9736 automatically , apparently ssl/cipher issue...

"...since doing a manual upgrade using an http URL works fine." >>did this already which lead to my hypothesis we deal with a cipher change somewhere.
Senior Member
Posts: 21,801
Registered: ‎08-04-2017
Kudos: 4113
Solutions: 1057

Re: unable to update UAP since 4.0.14.9736 automatically , apparently ssl/cipher issue...

Hello @DagoFrFu,

 

Did you UAP upgrade?

 

 

Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation Scripts | UniFi-VoIP Installation Scripts
USG-XG-8 • USG-4-PRO • USG
US-XG-16 • US-48-500W • US-24-POE-250W 2x • US-16-POE-150W 3x • US-24 • US-8-150W • US-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD 2x • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M • UAP-AC-M-PRO 2x
UAS-XG • UCK-G2-PLUS • UCK-G2 • UCK
New Member
Posts: 3
Registered: ‎06-20-2017
Kudos: 1

Re: unable to update UAP since 4.0.14.9736 automatically , apparently ssl/cipher issue...

I had the same issue with an AP-SHD I just purchased.  Came with 3.8.x and would not auto-update. Had to manually specify a 4.0.10 release URL first.  After that upgrade it was able to get to the latest release via the "update" button.

Senior Member
Posts: 21,801
Registered: ‎08-04-2017
Kudos: 4113
Solutions: 1057

Re: unable to update UAP since 4.0.14.9736 automatically , apparently ssl/cipher issue...

Hello @msy,

 

Did you use a HTTP or HTTPS link?

What controller version are you on?

 

 

Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation Scripts | UniFi-VoIP Installation Scripts
USG-XG-8 • USG-4-PRO • USG
US-XG-16 • US-48-500W • US-24-POE-250W 2x • US-16-POE-150W 3x • US-24 • US-8-150W • US-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD 2x • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M • UAP-AC-M-PRO 2x
UAS-XG • UCK-G2-PLUS • UCK-G2 • UCK
New Member
Posts: 3
Registered: ‎06-20-2017
Kudos: 1

Re: unable to update UAP since 4.0.14.9736 automatically , apparently ssl/cipher issue...

[ Edited ]

Cloudkey 0.12 w/ 5.9.29.  Connected locally, same VLAN/L2 broadcast domain, not via cloud access.

 

  1. Upgraded manually from "3.8.6.6650" to "4.0.10.9653" via http://dl.ubnt.com/unifi/firmware/U7HD/4.0.10.9653/BZ.ipq806x.v4.0.10.9653.181205.1309.bin
  2. then upgraded from "4.0.10.9653" to "4.0.14.9736" via the "update firmware" button
  3. then upgraded from "4.0.14.9736" to "4.0.15.9872" via the update firmware" button

Luckily I only had two new SHD's to put in otherwise this would have been a massive headache rolling out a few dozen of these right out of the box.  

 

Looking at version numbers I'm seeing that this might be a different issue than the OP. I might have mis-read the original report as not being able to upgrade TO 4.0.14.9736, which was the latest version as of late last week.

Senior Member
Posts: 21,801
Registered: ‎08-04-2017
Kudos: 4113
Solutions: 1057

Re: unable to update UAP since 4.0.14.9736 automatically , apparently ssl/cipher issue...

Hello @msy,

 

The UAPs should support HTTPS upgrade from firmware version 3.7.51 and above.

I personally always use HTTP upgrades on UAPs with older firmware versions.

 

 

Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation Scripts | UniFi-VoIP Installation Scripts
USG-XG-8 • USG-4-PRO • USG
US-XG-16 • US-48-500W • US-24-POE-250W 2x • US-16-POE-150W 3x • US-24 • US-8-150W • US-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD 2x • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M • UAP-AC-M-PRO 2x
UAS-XG • UCK-G2-PLUS • UCK-G2 • UCK
New Member
Posts: 23
Registered: ‎12-20-2016
Kudos: 1
Solutions: 1

Re: unable to update UAP since 4.0.14.9736 automatically , apparently ssl/cipher issue...

as I wrote I tried manual http upgrade with success and it was only about two APs, so I had no issue not automating this.
But of course your idea may be feasible when an automated upgrade should succeed.
New Member
Posts: 23
Registered: ‎12-20-2016
Kudos: 1
Solutions: 1

Re: unable to update UAP since 4.0.14.9736 automatically , apparently ssl/cipher issue...

[ Edited ]

Since I got them a year back and I talk about plain old UAP 2.4GHz only (no AC, no HD, no nothing), button update succeeded. They idled in a box until recently and it worked until 4.0.14... but then it failed.

My attempt with curl in a shell on the AP failed while it was working on the ERL-3 the AP was attached to.
So we should not mix issues unless it is proven @msy 's issue is the same.

My intention was to create awareness and to have this root caused. Could be a server issue of course - recently security fixes on the server ?

Established Member
Posts: 969
Registered: ‎02-12-2013
Kudos: 251
Solutions: 90

Re: unable to update UAP since 4.0.14.9736 automatically , apparently ssl/cipher issue...

@DagoFrFu

The old UAP (Generation 1) has some problems with 4.0.14 - that's what I can see in the Beta forum - a lot of people are having to manually upgrade them to get past that version.
Beta version 4.0.17 will change the base image of the firmware, so they follow the same base as all other generations - and this should help with upgrade issues (among other things). I don't know when we will see 4.0.17+ released, but my guess would be next month, since it's a big release.

I'm not saying that it couldn't be a cipher change, since ubnt.com is now pointing to ui.com - and that happened only a couple of days ago - and it's giving my browser a headache, because all my links gets redirected multiple times.

Usually when I see TLS problems, it normally stems from the AP's date/time is skewed (the NTP is not working correctly) - just like if you input a wrong date on your computer, then you almost cannot access any websites, because how the date/time is verified to create the secure connection.
Have you tried to login to the AP and run the command "info" and verify the date/time is correct?
New Member
Posts: 3
Registered: ‎02-27-2018

Re: unable to update UAP since 4.0.14.9736 automatically , apparently ssl/cipher issue...

[ Edited ]

I'm having the same issue trying HTTP upgrade now. 

 

 

Update:

Manually upgrading with HTTP worked. 

Senior Member
Posts: 21,801
Registered: ‎08-04-2017
Kudos: 4113
Solutions: 1057

Re: unable to update UAP since 4.0.14.9736 automatically , apparently ssl/cipher issue...

Hello @DagoFrFu,

 

There are comming changes to the Gen1 UAPs, this is not common to happen..

Next firmware versions will most likely have fixes for it Man Happy

 

 

Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation Scripts | UniFi-VoIP Installation Scripts
USG-XG-8 • USG-4-PRO • USG
US-XG-16 • US-48-500W • US-24-POE-250W 2x • US-16-POE-150W 3x • US-24 • US-8-150W • US-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD 2x • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M • UAP-AC-M-PRO 2x
UAS-XG • UCK-G2-PLUS • UCK-G2 • UCK
New Member
Posts: 23
Registered: ‎12-20-2016
Kudos: 1
Solutions: 1

Re: unable to update UAP since 4.0.14.9736 automatically , apparently ssl/cipher issue...

All times were ok. I checked the ones I updated. The sites are all independent and with identical config so either they have it all or it is just an independent coincidence.
New Member
Posts: 23
Registered: ‎12-20-2016
Kudos: 1
Solutions: 1

Re: unable to update UAP since 4.0.14.9736 automatically , apparently ssl/cipher issue...

I will keep this pending for next release notes...

Senior Member
Posts: 21,801
Registered: ‎08-04-2017
Kudos: 4113
Solutions: 1057

Re: unable to update UAP since 4.0.14.9736 automatically , apparently ssl/cipher issue...

Hello @DagoFrFu,

 

Have you already tried 4.0.21?

Make sure you read the special information Man Happy

 

 

Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation Scripts | UniFi-VoIP Installation Scripts
USG-XG-8 • USG-4-PRO • USG
US-XG-16 • US-48-500W • US-24-POE-250W 2x • US-16-POE-150W 3x • US-24 • US-8-150W • US-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD 2x • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M • UAP-AC-M-PRO 2x
UAS-XG • UCK-G2-PLUS • UCK-G2 • UCK
New Member
Posts: 23
Registered: ‎12-20-2016
Kudos: 1
Solutions: 1

Re: unable to update UAP since 4.0.14.9736 automatically , apparently ssl/cipher issue...

[ Edited ]

Thx for the hint, unifi did not tell me so far about upgrading options.
What do you consider special information ?
I read all on the page and it had nothing related to upgrade issues where not even downloading can take place.

 

(nonetheless nice to see still fixes for the old UAP but the ones mentioned did not hit me on the site where I use those. This is actually affected by ERL 2.0 fw issues it seems... but this is another thread's story)

Senior Member
Posts: 21,801
Registered: ‎08-04-2017
Kudos: 4113
Solutions: 1057

Re: unable to update UAP since 4.0.14.9736 automatically , apparently ssl/cipher issue...

Hello @DagoFrFu,

 

It's a Stable Candidate, those don't get pushed to the controllers.

Read the messages in RED on the firmware release page.

 

 

Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation Scripts | UniFi-VoIP Installation Scripts
USG-XG-8 • USG-4-PRO • USG
US-XG-16 • US-48-500W • US-24-POE-250W 2x • US-16-POE-150W 3x • US-24 • US-8-150W • US-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD 2x • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M • UAP-AC-M-PRO 2x
UAS-XG • UCK-G2-PLUS • UCK-G2 • UCK
Highlighted
New Member
Posts: 23
Registered: ‎12-20-2016
Kudos: 1
Solutions: 1

Re: unable to update UAP since 4.0.14.9736 automatically , apparently ssl/cipher issue...

Yeah I red the message in red, though this is unrelated.

When I can fix my problem by using an http URL rather than https than this can be hardly considered a version dependency.

And I think those were on 4.0.10* anyway.

Reply