Reply
Highlighted
Established Member
Posts: 1,259
Registered: ‎07-17-2013
Kudos: 848
Solutions: 84
Contributions: 1

weird config that cannot be saved on 5.10.20

[ Edited ]

I was trying to enable remote syslog on some of my UniFi sites, and hit a interesting configuration that cannot be saved through the controller without some tweaking ...

 

initial config on remote logging is everything disabled, like: (pic1)

 

pic1.png

 

so i make it the way i want to (pic2)

 

pic2.png

 

and with this config, hitting 'APPLY CHANGES' button does absolutely nothing. No error and no saving the configs. I simply cannot have this configuration saved starting from a completly disabled config.

 

So i tried something like informing the remote IP, which saves and get applied correctly, as expected (pic3)

 

pic3.png

 

And then, after having pic3 state saved, i can click 'log and netconsole to this controller', just like on pic2, and everything is now saved and works as expected.

 

Anyway, it seems a bug that a valid configuration is not accepted and not saved, specially not even giving an error on what's happening.

 

 

Solutti Tecnologia Ltda - Goiânia/Goiás/Brazil
www.solutti.com.br / www.wifiquefunciona.com.br
Ubiquiti Enterprise Wireless Admin (UEWA) certified
did my answer helped you ? if yes, i would love your kudos on it Man Happy
Senior Member
Posts: 19,200
Registered: ‎08-04-2017
Kudos: 3598
Solutions: 934

Re: weird config that cannot be saved on 5.10.20

Hello @leonardogyn,

 

Take a look at the controller logs.

 

 

Regards,

Glenn R.

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation Scripts | UniFi-VoIP Installation Scripts
USG-XG-8 • USG-4-PRO • USG
USW-XG-16 • USW-48-500W • USW-24-POE-250W 2x • USW-16-POE-150W 3x • USW-24 • USW-8-150W • USW-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD 2x • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M • UAP-AC-M-PRO 2x
UAS-XG • UCK-G2-PLUS • UCK-G2 • UCK
Established Member
Posts: 1,259
Registered: ‎07-17-2013
Kudos: 848
Solutions: 84
Contributions: 1

Re: weird config that cannot be saved on 5.10.20


@AmazedMender16 wrote:

Hello @leonardogyn,

 

Take a look at the controller logs.

 


No log at all is generated on logs/server.log when i hit 'APPLY CHANGES' several times. It simply don't save the settings nor give any error on the Web UI interface. I have even raised 'mgmt' log level to debug on maintenance. With that, i got some calls logging while browsing the WebUI, but no error nor anything interesting.

Solutti Tecnologia Ltda - Goiânia/Goiás/Brazil
www.solutti.com.br / www.wifiquefunciona.com.br
Ubiquiti Enterprise Wireless Admin (UEWA) certified
did my answer helped you ? if yes, i would love your kudos on it Man Happy
Senior Member
Posts: 19,200
Registered: ‎08-04-2017
Kudos: 3598
Solutions: 934

Re: weird config that cannot be saved on 5.10.20

Hello @leonardogyn,

 

I can replicate your issue when I leave Remote IP or Hostname blank before selecting Log and Netconsole to this controller.

 

 

Regards,

Glenn R.

 

CC @UBNT-Maciej @UBNT-MikeD 

Cloud Hosted Controllers | Glenn R. | UniFi Installation/Easy Update Scripts | UniFi-Video Installation Scripts | UniFi-VoIP Installation Scripts
USG-XG-8 • USG-4-PRO • USG
USW-XG-16 • USW-48-500W • USW-24-POE-250W 2x • USW-16-POE-150W 3x • USW-24 • USW-8-150W • USW-8
UAP XG • UAP-SHD • UAP-HD • UAP-NanoHD 2x • UAP-AC-PRO 2x • UAP-AC-LITE • UAP-AC-IW • UAP-AC-M • UAP-AC-M-PRO 2x
UAS-XG • UCK-G2-PLUS • UCK-G2 • UCK
Established Member
Posts: 1,259
Registered: ‎07-17-2013
Kudos: 848
Solutions: 84
Contributions: 1

Re: weird config that cannot be saved on 5.10.20


@AmazedMender16 wrote:

Hello @leonardogyn,

 

I can replicate your issue when I leave Remote IP or Hostname blank before selecting Log and Netconsole to this controller.

 


Yeah, that seems to be the case. As i described, if i make an intermediate config filling remote IP, then checking 'log to this controller' is accepted. Seems it's requiring that field, but checking 'log to this controller' makes the field dissapears thus we cannot see it showing the red flag as required field... a simply to fix bug.

Solutti Tecnologia Ltda - Goiânia/Goiás/Brazil
www.solutti.com.br / www.wifiquefunciona.com.br
Ubiquiti Enterprise Wireless Admin (UEWA) certified
did my answer helped you ? if yes, i would love your kudos on it Man Happy
Reply