Reply
Veteran Member
Posts: 4,526
Registered: ‎05-19-2009
Kudos: 781
Solutions: 23

Beta2 UNMS features not working properly

New UNMS issues with AC2

 

1: When adding UNMS key it asks for uri, not wss key this is confusing

 

2: After adding UNMS wss key it reboots the device why? there is no need for that in the new firmware

 

3: if the device is already in UNMS it disconnects the device from UNMS and you have to delete the device from UNMS and re-auth the device there needs to be some sort of cross-check to see if the device is already in UNMS

 

4:  only finding how to add the UNMS status Tab in the WEB client can't find in the Desktop Client

 

5: UNMS Status shows as unknown for all devices (360 out of 570 are in UNMS already)

Ubiquiti Employee
Posts: 766
Registered: ‎05-28-2012
Kudos: 391
Solutions: 79

Re: Beta2 UNMS features not working properly

Hi @900mhzdude,

 

> 1: When adding UNMS key it asks for uri, not wss key this is confusing

 

Agree. Will rename to UNMS key.

 

> 2: After adding UNMS wss key it reboots the device why? there is no need for that in the new firmware

 

The procedure does not explicitly reboots a device. It is the same as applying configuration. I'll try to figure out what is going on here.

 

> 3: if the device is already in UNMS it disconnects the device from UNMS and you have to delete the device from UNMS and re-auth the device there needs to be some sort of cross-check to see if the device is already in UNMS

 

Should not happen, will check this.

 

> 4: Only finding how to add the UNMS status Tab in the WEB client can't find in the Desktop Client

 

For Desktop Client it is in user settings.

 

> 5: UNMS Status shows as unknown for all devices (360 out of 570 are in UNMS already)

 

What this does is simply checks if current device configuration (in AC2) contains UNMS key. There might be cases when AC2 does not have device configuration.

Regular Member
Posts: 685
Registered: ‎03-11-2013
Kudos: 344
Solutions: 13

Re: Beta2 UNMS features not working properly

@UBNT-Karolis 

On 3:

When UNMS receives a connection from a new device, the device is using a generic key.  The first thing UNMS does is replace the generic key with a device specific key.  When you test for the existence of a key, you should only compare from the wss: through the first + to see if the key is to a different UNMS server.  If that first portion of the key is the same you should not update the key. (At least when updating multiple radios.  You might make an exception to this when updating a single radio.)

 

Add 6:

When adding to UNMS on XM and XW series radios where UNMS was disabled, somehow the wss:// is being replaced with wss:\/\/ as if some code mistakenly is trying to escape the slashes.  If I then try to apply the same key to the same radio(s), it updates the key(s) correctly and the radio(s) appear(s) in UNMS.

Found I had 1 XC radio that was not UNMS enabled.  It enabled and applied the key correctly the first time.

 

Running AC2.1.1beta3

Dreams never hurt. It's when they turn into expectations that you get problems.
Ubiquiti Employee
Posts: 766
Registered: ‎05-28-2012
Kudos: 391
Solutions: 79

Re: Beta2 UNMS features not working properly

@RavenWing71  thanks for the report. will fix these.

Reply