Reply
Veteran Member
Posts: 16,722
Registered: ‎06-23-2010
Kudos: 5284
Solutions: 78

Stuck on Requesting authentication credentials

So - new AC2 install.  I discovered devices and it's just sitting on "

Requesting authentication credentials" after finding them all...
 
What would cause this and how do I fix it?
Veteran Member
Posts: 16,722
Registered: ‎06-23-2010
Kudos: 5284
Solutions: 78

Re: Stuck on Requesting authentication credentials

I finally canceled it and get:

"KEY_DISCOVER_OPERATION_CANCELED_ERROR"
New Member
Posts: 5
Registered: ‎03-31-2017
Kudos: 1

Re: Stuck on Requesting authentication credentials

I'm also getting this message after upgrade from 2.1 final to  2.1.1 beta

Veteran Member
Posts: 4,829
Registered: ‎03-02-2015
Kudos: 938
Solutions: 219

Re: Stuck on Requesting authentication credentials

[ Edited ]

@mhoppes

credentials request bug was fixed in AC2.1 beta9 or even earlier.
do you use custom ssh ports ?

===================================================
We all work for KUDOs here.
Thx
Veteran Member
Posts: 16,722
Registered: ‎06-23-2010
Kudos: 5284
Solutions: 78

Re: Stuck on Requesting authentication credentials

No custom ports. And I’m running the most recent version of the software. 

New Member
Posts: 5
Registered: ‎03-31-2017
Kudos: 1

Re: Stuck on Requesting authentication credentials

[ Edited ]

on some devices, but the devices added after upgrade use the standard port 22. Discovery worked fine right before upgrade was done.

 

 I actuallly never get asked for credentials for the discovered devices

New Member
Posts: 5
Registered: ‎03-31-2017
Kudos: 1

Re: Stuck on Requesting authentication credentials

[ Edited ]

Found a workaround thats works for now.

 

Run discovery, when all devices have been found  -> cancel the discovery task.

Aircontrol puts them in its device list anyway. Sort devices by "not minitored" and mark all devices. Now i get asked for credentials when i choose "start monitoring"

Aircontrol connects and starts to monitor them without any problems appearing. Also the devices with custom ssh ports.

 

The issue seems to be that the popup for credentials and ssh port dont show up in the discover task window.

Veteran Member
Posts: 4,829
Registered: ‎03-02-2015
Kudos: 938
Solutions: 219

Re: Stuck on Requesting authentication credentials

@mhoppes

So this error after discovery cancel is from Webclient?
===================================================
We all work for KUDOs here.
Thx
Veteran Member
Posts: 16,722
Registered: ‎06-23-2010
Kudos: 5284
Solutions: 78

Re: Stuck on Requesting authentication credentials

Correct
Veteran Member
Posts: 4,829
Registered: ‎03-02-2015
Kudos: 938
Solutions: 219

Re: Stuck on Requesting authentication credentials

[ Edited ]

@mhoppes

I would first check AC2 server logs. Usually they show more than webclient.

 

@UBNT-Karolis

@UBNT-Mindaugas

===================================================
We all work for KUDOs here.
Thx
Veteran Member
Posts: 16,722
Registered: ‎06-23-2010
Kudos: 5284
Solutions: 78

Re: Stuck on Requesting authentication credentials

Can a developer chime in on this?

Ubiquiti Employee
Posts: 766
Registered: ‎05-28-2012
Kudos: 392
Solutions: 80

Re: Stuck on Requesting authentication credentials

Hi @mhoppes,

 

send me server logs for inspection to aircontrol@ubnt.com

Which airControl version and what browser you are using?

New Member
Posts: 17
Registered: ‎12-06-2013
Kudos: 9
Solutions: 1

Re: Stuck on Requesting authentication credentials

Can confirm that on AirControl 2.1.1-beta with the latest Chrome, the prompt for credentials never appears in the browser during or after discovery. There's just a spinner spinning next to "Requesting authentication credentials". The workaround posted above worked for me (monitoring from the devices list *does* prompt for credentials.)

Veteran Member
Posts: 4,533
Registered: ‎05-19-2009
Kudos: 784
Solutions: 23

Re: Stuck on Requesting authentication credentials

having the same issue after upgrade AC2 stopped discovering so i tried web client and it just spins on Requesting authentication credentials

Member
Posts: 289
Registered: ‎04-24-2013
Kudos: 83
Solutions: 2

Re: Stuck on Requesting authentication credentials

I can confirm same behaviour - no popup appearing in chrome.

Veteran Member
Posts: 16,722
Registered: ‎06-23-2010
Kudos: 5284
Solutions: 78

Re: Stuck on Requesting authentication credentials

Anyone? We are at a work stoppage.
Veteran Member
Posts: 4,533
Registered: ‎05-19-2009
Kudos: 784
Solutions: 23

Re: Stuck on Requesting authentication credentials

installing all system updates then shutting the server off and turning it back on seemed to have solved the issue for us,

Established Member
Posts: 1,266
Registered: ‎08-17-2010
Kudos: 244
Solutions: 19

Re: Stuck on Requesting authentication credentials

We still have this issue as well. Fully updated Ubuntu 16.04.5 LTS.

Veteran Member
Posts: 16,722
Registered: ‎06-23-2010
Kudos: 5284
Solutions: 78

Re: Stuck on Requesting authentication credentials

Anyone? Is AC2 dead?
Ubiquiti Employee
Posts: 766
Registered: ‎05-28-2012
Kudos: 392
Solutions: 80

Re: Stuck on Requesting authentication credentials

This issue will be fixed in upcoming release.

Reply