New Member
Posts: 4
Registered: ‎05-05-2018
Kudos: 3

Aircube wireless performance on 2.4.0 firmware

So my friend bought a new house and his existing wireless would not cover the new square footage. 3 stories, over 6000 sqft and long/skinny floor plan with half the bottom floor built into the side of the hill. Great house.

 

At my recommendation, we bought a Ubiquiti solution around the Edgerouter 6p, Edgeswitch 8 and 4 of the AirCube AC units. The reason we chose the Aircubes is for added switch port functionality and no need to hang APs on the wall or ceiling. 

 

He has Comcast Xfinity Gig internet. We turned put the Xfinity in Bridge Mode, hooked up the router and switch and setup a basic wizard setup. We hooked up all the APs and were getting good speeds. All 6 devices are managed through a UNMS 0.12.2 instance running on a small headless Ubuntu Server. One of the last things that we did was upgrade the firmware from the 1.0.2 that the Cubes shipped with to the latest 2.4. Thats when everything went to hell.

 

I tried proper AP/Router/Bridge mode combinations, proper channel and signal strength settings and even removed all but 1 AP from the mix. Hardwired speed test were getting 800-1gb consistently, but all wireless speed tests, regardless of device, were anywhere from 20 to about 100 (3-4 different vendor phones, Mac book, chromebook and MSI laptops). 

 

I looked through the release notes of the 2.4 firmware and noticed a new driver set for the wireless radios. So we tried 2.3.1 and 2.3.0 via the TFTP flash. Same slow performance. It wasnt until we flashed back down to 2.0.1 where we're now getting 400+ speeds. I'm chalking the difference between lack of full 1gb wireless cards in most of the devices and the hops between the AP through 2 switches to the router.

 

I know that the AirCubes were not "designed' for this, but all the functionality is there for the setup. Even with the 1 AP and getting speeds, the firmware seemed to be the culprit. 

 

Things are great now on the 2.0.1 firmware, I just wanted to post on here to see if anyone else had any issues or similar results.

New Member
Posts: 2
Registered: ‎10-12-2018

Re: Aircube wireless performance on 2.4.0 firmware

Similar experience with wifi performance on 2.4.0 - I actually decided to try disabling the 2.4GHz radio and I'm back to blistering fast speeds
Ubiquiti Employee
Posts: 11,367
Registered: ‎04-14-2017
Kudos: 2107
Solutions: 327

Re: Aircube wireless performance on 2.4.0 firmware

Perhaps you have devices which prefer 2.4 GHz, accompanied with 2.4 GHz interference in the local area.
New Member
Posts: 2
Registered: ‎10-12-2018

Re: Aircube wireless performance on 2.4.0 firmware

In total there were only ~8 devices on my network, and we're rather spread out here, so I only see a handful of SSIDs - is it possible that auto channel selection was failing to select the right channel to use for 2.4GHz?

 

Moving to 5GHz only shouldn't have made it this drastically different - but it is

Ubiquiti Employee
Posts: 11,367
Registered: ‎04-14-2017
Kudos: 2107
Solutions: 327

Re: Aircube wireless performance on 2.4.0 firmware

Possible, I'd have to see what the spectrum looks like.