Reply
Highlighted
New Member
Posts: 5
Registered: ‎07-30-2014

Problems upgrade 8.5.1

After upgrade of stations and AP, the stations dont come back...

Problem with EAP:

 

 

Mar  7 12:35:54 wireless: ath0     Received auth from 80:2a:a8:3c:70:89. Status: Successful (0).
Mar  7 12:35:54 wireless: ath0     Authenticated Station 80:2a:a8:3c:70:89 (Successful)
Mar  7 12:35:54 wireless: ath0     Sending auth to 80:2a:a8:3c:70:89. Status: Successful (0).
Mar  7 12:35:54 hostapd: ath0: STA 80:2a:a8:3c:70:89 IEEE 802.11: associated
Mar  7 12:35:54 wireless: ath0     Received assoc_req from 80:2a:a8:3c:70:89.
Mar  7 12:35:54 wireless: ath0     Sending assoc_resp to 80:2a:a8:3c:70:89. Status: Successful (0).
Mar  7 12:35:54 wireless: ath0     Registered node:80:2A:A8:3C:70:89
Mar  7 12:35:55 hostapd: ath0: STA 80:2a:a8:3c:70:89 IEEE 802.1X: authentication failed - EAP type: 21 (TTLS)
Mar  7 12:35:55 wireless: ath0     Sending disassoc to 80:2a:a8:3c:70:89. Reason: 802.1X authentication failure (23).
Mar  7 12:35:55 wireless: ath0     Expired node:80:2A:A8:3C:70:89
Mar  7 12:35:55 hostapd: ath0: STA 80:2a:a8:3c:70:89 IEEE 802.11: disassociated

 What is this problem? Where came from this data and time? 

AP with firmware 8.5.1 and station with 8.5.0, this problem dont happens 

Ubiquiti Employee
Posts: 8,271
Registered: ‎04-14-2017
Kudos: 1583
Solutions: 229

Re: Problems upgrade 8.5.1

Can you clarify your setup – is this using 8.5.1 on the AP and the stations, and when you downgrade the stations it goes away? What is your AP configuration?
Ubiquiti Employee
Posts: 564
Registered: ‎08-20-2007
Kudos: 123
Solutions: 22

Re: Problems upgrade 8.5.1

[ Edited ]

@raphaeljk,

one more thing which is worth to check is if the system time is within the rage of the date attribute of the certificate used for the EAP-TTLS  (valid from .. to). This is due to the fact that system startup date changes after firmware upgrade. We have an option in the system settings for system startup date which can be used as workaround (in case it is required).

 

 

New Member
Posts: 10
Registered: ‎09-06-2017

Re: Problems upgrade 8.5.1

Regards!

I also have problems updating to version 8.5.1.

What happens is the following:

In the station I performed the update of the antenna but I do not return again.
then in the AP I made the update and I noticed that when the connection is restored, it asks for User, password, country code again and accept the terms and license agreements, this is a problem because the antenna apparently does not start until filling this information, I think that's what happened to my station, how can this be solved?

in the M5 radios this problem does not happen, it does the upgrade without requesting some information again.

Another thing is that in the previous versions this does not happen either. You can upgrade without problems like this.

 

 

before_upgrade.jpg
Upgrading.jpg
Ubiquiti Employee
Posts: 8,271
Registered: ‎04-14-2017
Kudos: 1583
Solutions: 229

Re: Problems upgrade 8.5.1

Were you using licensed firmware before?
New Member
Posts: 10
Registered: ‎09-06-2017

Re: Problems upgrade 8.5.1


We are using the Firmware that has the factory antenna or the firmware that we downloaded earlier in the ubiquiti page

Ubiquiti Employee
Posts: 8,271
Registered: ‎04-14-2017
Kudos: 1583
Solutions: 229

Re: Problems upgrade 8.5.1

Did you download it from ubnt.com?
New Member
Posts: 10
Registered: ‎09-06-2017

Re: Problems upgrade 8.5.1

Yes, all our firmwares are from ubnt.com, at this time I did another test with another antenna and the result is the same. I do not want to update clients for fear of losing connection with them again

 

 

UPGRADE.jpg
Upgrade2.jpg
Ubiquiti Employee
Posts: 8,271
Registered: ‎04-14-2017
Kudos: 1583
Solutions: 229

Re: Problems upgrade 8.5.1

Ah, ok. What version are you upgrading from?
New Member
Posts: 10
Registered: ‎09-06-2017

Re: Problems upgrade 8.5.1

we have all the devices in 8.4.3.36160.171117 (XC) we want to upgrade to 8.5.1.37185.180307

Ubiquiti Employee
Posts: 137
Registered: ‎03-21-2017
Kudos: 124
Solutions: 15

Re: Problems upgrade 8.5.1


@paezdaniel100 wrote:

Upgrade2.jpg

...this is a problem because the antenna apparently does not start until filling this information...


Hi @paezdaniel100,

 

If you could download /tmp/system.cfg via SSH when your device is showing the above screen after fw update, that would be great! If you can, please share it via a personal message. Thanks!

 

When you see the above screen after fw update, the radio is still working with your previous configuration. If you select the correct country on the page listed above then everything should work as before. Just make sure all other devices on this wireless link are showing the same country as you select here.

 

I also concede that v8.5.1 has slightly different countrycode handling in system config and we are going to improve it for the next beta.

New Member
Posts: 21
Registered: ‎02-25-2014
Kudos: 2
Solutions: 1

Re: Problems upgrade 8.5.1

I have the same problem if i update to 8.5.1 or 8.5.4 , all AC cpe show license agreement and re-enter user/pass etc
Ubiquiti Employee
Posts: 8,271
Registered: ‎04-14-2017
Kudos: 1583
Solutions: 229

Re: Problems upgrade 8.5.1

What are you updating from?
New Member
Posts: 21
Registered: ‎02-25-2014
Kudos: 2
Solutions: 1

Re: Problems upgrade 8.5.1

From 8.3.2 , 8.4.2 ,8.4.3, when update is finished , i need re-enter user / pass / country  and license agreement

Ubiquiti Employee
Posts: 8,271
Registered: ‎04-14-2017
Kudos: 1583
Solutions: 229

Re: Problems upgrade 8.5.1

@UBNT-AL can you comment on this one please?
Ubiquiti Employee
Posts: 137
Registered: ‎03-21-2017
Kudos: 124
Solutions: 15

Re: Problems upgrade 8.5.1

[ Edited ]

@UBNT-SNK, it's the same issue as I have described in the comment above:

https://community.ubnt.com/t5/airMAX-AC/Problems-upgrade-8-5-1/m-p/2377689#M31893

When first setup was last completed using a very old fw version, after upgrade to v8.5.1/v8.5.4 the user might need to re-select radio country and agree with the terms of use. All other device settings are kept as they were before the upgrade. A fix is already in the pipeline for the next beta.

Ubiquiti Employee
Posts: 8,271
Registered: ‎04-14-2017
Kudos: 1583
Solutions: 229

Re: Problems upgrade 8.5.1

Great, thanks @UBNT-AL.
Reply