New Member
Posts: 35
Registered: ‎06-17-2016
Kudos: 3
Solutions: 3

Ping Request Timeout

I'm connecting to the internet using an NSM2 with a static IP. Seems that everyday the connection gets progressively worse until I finally reboot the NMS2 and it returns to "normal", as seen by these screen shots of Pingview. I'm pinging the first hop after the router but it does the same thing if I ping the Google IP. I'm running the latest firmware. Any ideas as to why this does this?

Before.pngafter.png

 

Established Member
Posts: 2,024
Registered: ‎08-16-2010
Kudos: 567
Solutions: 150

Re: Ping Request Timeout

Please provide details of your link.

A screenshot of the station's main page for a start.

 

New Member
Posts: 35
Registered: ‎06-17-2016
Kudos: 3
Solutions: 3

Re: Ping Request Timeout

 
NMS2.png
New Member
Posts: 35
Registered: ‎06-17-2016
Kudos: 3
Solutions: 3

Re: Ping Request Timeout

[ Edited ]

This morning the RX number was bouncing around from 52 to 78 to 104 but never hits 130. TX is at 130 steady.

Rebooted the station and now a ping timeout here and there but not mulptiple fails in a row. RX numbers still bouncing around. All other numbers same as yesterday. Pingview before reboot:

morning.png

 

Established Member
Posts: 2,024
Registered: ‎08-16-2010
Kudos: 567
Solutions: 150

Re: Ping Request Timeout

[ Edited ]

The link being in the 2.4ghz band, I assume that the band will be congested.

Do a site survey and select a least used channel.

Lower the power so your signal lies in the -45~50 dbm region.

You may also try the "Alternative" mode in the "Data Rate Module" option (Wireless tab)

Edit-

I forgot to mention, turn "Airmax" on the AP side.

New Member
Posts: 35
Registered: ‎06-17-2016
Kudos: 3
Solutions: 3

Re: Ping Request Timeout

The AP is  a friend's ISP provided router. We've tried different settings on the signal strength and it didn't make any difference. Don't see why rebooting would "fix" it. I'll change the Data Rate Module and see if that makes a difference.

Established Member
Posts: 2,024
Registered: ‎08-16-2010
Kudos: 567
Solutions: 150

Re: Ping Request Timeout

Rebooting the NS doesn't necessarily mean that the problem is on the station side.

I was under the impression that your link consisted on a pair of nanostations, and so the advice.

The AP being an indoor wireless router, perhaps the problem is related to its sensitivity or the low gain of the antennas used.

In other words, your NS can "see" the wireless router, but the router not too well.

 

New Member
Posts: 35
Registered: ‎06-17-2016
Kudos: 3
Solutions: 3

Re: Ping Request Timeout

If that were the case wouldn't adjusting the power level of the NS correct that? The NS is maybe 20 ft away from the router. I have the TX power at 12 now but can go up to 28. Is it possible the power level is actually too high? I don't think I can tell what the signal strength of the NS is on the router side. Oh, and changing to to Alternative on the Data Rate doesn't seem to make a difference.

Established Member
Posts: 2,024
Registered: ‎08-16-2010
Kudos: 567
Solutions: 150

Re: Ping Request Timeout

Can you try using some previous version of AirOs ?
I would try V5.6.15 first

New Member
Posts: 35
Registered: ‎06-17-2016
Kudos: 3
Solutions: 3

Re: Ping Request Timeout

I'll try that. Thanks.
New Member
Posts: 35
Registered: ‎06-17-2016
Kudos: 3
Solutions: 3

Re: Ping Request Timeout

Wouldn't you expect the Transmit CCQ to be fairly poor if there was an issue with the router and station talking. Mine holds steady at 99% or better.

New Member
Posts: 35
Registered: ‎06-17-2016
Kudos: 3
Solutions: 3

Re: Ping Request Timeout

Doesn't seem to have made any difference. Fail rate around 50%. This time I made an insignifigant change to one of the values and saved it and the fail rate dropped back to "normal", about 3%. Does changing a value and saving it force the radio through the same process as rebooting?

630 before.png630 after.png

Ubiquiti Employee
Posts: 11,657
Registered: ‎04-14-2017
Kudos: 2166
Solutions: 334

Re: Ping Request Timeout

@UBNT-JoshMcGee can you take a look at this one please?
Ubiquiti Employee
Posts: 1,270
Registered: ‎09-24-2018
Kudos: 260
Solutions: 69

Re: Ping Request Timeout

This is probably the fault of the AP, being a consumer grade indoor modem/router. You can increase the nanostation tx power, but that won't make the router any stronger so it doesn't help.

Get a second Nanostation and create a proper point-to-point link between them in bridge mode with WDS on.

UBNT_Alternate_Logo.png
Ubiquiti Networks airMAX Support Team

Check out our ever-evolving Help Center for answers to many common questions!

FREE UBWA Student Guide-Great RF Primer!

New Member
Posts: 35
Registered: ‎06-17-2016
Kudos: 3
Solutions: 3

Re: Ping Request Timeout

[ Edited ]

Not sure what you mean by making the router "stronger". The signal strength from the router is very good, about -30dBm.  I can ping the router all day and get a failure rate of about 0.3%. I did see a period of 1 minute today with a continuous string of request timeouts but other than that only one here and there.

Ubiquiti Employee
Posts: 1,270
Registered: ‎09-24-2018
Kudos: 260
Solutions: 69

Re: Ping Request Timeout

grab a packet dump and analyze the conversation in wireshark. You're at least filtering for these two elements.
tcp.analysis.lost_segment
tcp.analysis.retransmission

This should tell you where and why the pings are dropped, I believe, and lead to better debugging results.

UBNT_Alternate_Logo.png
Ubiquiti Networks airMAX Support Team

Check out our ever-evolving Help Center for answers to many common questions!

FREE UBWA Student Guide-Great RF Primer!

New Member
Posts: 35
Registered: ‎06-17-2016
Kudos: 3
Solutions: 3

Re: Ping Request Timeout

[ Edited ]

Thanks,@UBNT-JoshMcGee. I was getting about a 25% fail rate on the pings this morning. Did a capture with wireshark and saved two files. I rebooted the NSM2 station and now the fail rate is about 4%. I have no idea what all this shark data means so I've attached the two files. Can you see where the problem is? 

Attachment
Attachment