New Member
Posts: 5
Registered: ‎03-26-2018

connecting Nanostation M2 to AP requires username and password

I have searched the forum with no luck, I am not competent at networking so hoping someone will be kind enough to give me some guidance. I use a Nanostation M2 as a wireless station connected to my router to connect to various AP while i travel. Lately more and more AP require a username but there is no input in the wireless control panel to input a username. SO i am obvioulsy missing something, not understanding something or just doing it wrong. SO if someone could advise me and keep it Barney simple it would be much appreciated
Ubiquiti Employee
Posts: 11,367
Registered: ‎04-14-2017
Kudos: 2105
Solutions: 326

Re: connecting Nanostation M2 to AP requires username and password

When you say username, what do you mean? Do you mean that when you connect to the network, you are asked to enter a password, or do you see a screen displayed that is asking for a login?
New Member
Posts: 5
Registered: ‎03-26-2018

Re: connecting Nanostation M2 to AP requires username and password

The AP is an AireBeam public access node.  Standard login is a username and then password.  However, when i try to connect with the Nanostation to boost signal there is no username input in the station mode for wireless connecting. only password.  To be clear what i am trying to do is connect to the AP which from where i am is a weak signal with my Nanostation.  My nano station is connected to a router with its own SSID.  I then connect to my router with a laptop, phone etc. I have a feeling that i should not be using station mode ?

Ubiquiti Employee
Posts: 11,367
Registered: ‎04-14-2017
Kudos: 2105
Solutions: 326

Re: connecting Nanostation M2 to AP requires username and password

Okay I think I see what you're getting at now. For this login with the username and password, does the login page look like the one on your own radio?
New Member
Posts: 5
Registered: ‎03-26-2018

Re: connecting Nanostation M2 to AP requires username and password

I have attached two screen captures,  the first is the AP log in and the second is my nanostation setting.  Nano station setting does not include a place for user name just password.

 

 

airebean.JPG
ubiquiti.JPG
Ubiquiti Employee
Posts: 11,367
Registered: ‎04-14-2017
Kudos: 2105
Solutions: 326

Re: connecting Nanostation M2 to AP requires username and password

Ok. I think you should be in station mode with the NanoStation configured in router mode. The Wi-Fi service is probably locked to the MAC address of your NanoStation once you connect.
New Member
Posts: 17
Registered: ‎06-18-2018
Kudos: 1

Re: connecting Nanostation M2 to AP requires username and password

Hello, I saw the last post on your case because I have the same problem. Does your problem is resolved because I’m not sure I understand what to do. 

New Member
Posts: 5
Registered: ‎03-26-2018

Re: connecting Nanostation M2 to AP requires username and password

Nope,  Never did get a solution.  I agree the response was somewhat contradictory

Ubiquiti Employee
Posts: 11,367
Registered: ‎04-14-2017
Kudos: 2105
Solutions: 326

Re: connecting Nanostation M2 to AP requires username and password

Which response?
New Member
Posts: 17
Registered: ‎06-18-2018
Kudos: 1

Re: connecting Nanostation M2 to AP requires username and password

Oup I’m not wrong....the response just befor my post......I don”t see the solution.
New Member
Posts: 17
Registered: ‎06-18-2018
Kudos: 1

Re: connecting Nanostation M2 to AP requires username and password

Hello, a long response......

At the beginning, I just did my installation (Nanostation M2 and AirGateway LR) in my RV and I connected it to my home network and work fine. My network is a WPA/WPA2-PSK security set up. I saw you selected "station" for wireless mode, in my case I use Router. I did my configuration base on the following video

But yesterday I had a nightmare, what to do when the site provide a user and a password to connect to the network (like this most of the time) and of course there is no place specify a user like you found.

 

So I seach on that and found your post and the responses that I wasnt sure to understand and you confirmed, it still not working for you.

 

I found the site from the guy who did the video and he wrote this ...

 

"Dealing with Captive Portal or “Agree” Pages: Some parks require you to “agree” or login with a user name and password before you have access. So once you connect to the park with the NanoStation, while on your Wi-Fi network, the first time you open your web browser the “captive portal” page will come up asking you to agree or log in. Once you do, the portal will note the MAC address of the NanoStation and then allow access to anything on your local Wi-Fi network."    (Text and more info).

 

Ta dam, It look too good.

 

So, if you or other one can confirm this . It will be perfect. If not, my installation will be useless......

 

I don't know when will my next escapade and of course I don't want to be stuck with this because till now I spent a lot of time on it.

 

New Member
Posts: 17
Registered: ‎06-18-2018
Kudos: 1

Re: connecting Nanostation M2 to AP requires username and password

Sorry, rectification.

 

For my setting , I specified Router for networking mode and Station for wireless mode.

Ubiquiti Employee
Posts: 11,367
Registered: ‎04-14-2017
Kudos: 2105
Solutions: 326

Re: connecting Nanostation M2 to AP requires username and password

@UBNT-Nick can you take a look at this one?
New Member
Posts: 17
Registered: ‎06-18-2018
Kudos: 1

Re: connecting Nanostation M2 to AP requires username and password

Sorry, may be I'm missing something, but to be more specific, you want me to look to witch subject, because you worked on many base on your list you point out to me !

 

New Member
Posts: 17
Registered: ‎06-18-2018
Kudos: 1

Re: connecting Nanostation M2 to AP requires username and password

Hi, did you see the video and the web site in my post, hope it is usefull. Anyway, give me feedback.

New Member
Posts: 5
Registered: ‎03-26-2018

Re: connecting Nanostation M2 to AP requires username and password

Thanks,. That looks like a solution.  I will try it my next opportunity

Ubiquiti Employee
Posts: 1,986
Registered: ‎02-13-2017
Kudos: 543
Solutions: 174

Re: connecting Nanostation M2 to AP requires username and password

I'm assuming the network you are connecting to has a captive portal. In some cases, this set up may not work when the wifi has a captive portal. You may need to have the network manager whitelist the MAC address of the NanoStation. Otherwise, you may need to try bridge mode on the NanaStation and airGateway to get the Captive Portal up.

UBNT_Alternate_Logo.png
Ubiquiti Networks

Check out our ever-evolving Help Center for answers to many common questions!

FREE UBWA Student Guide-Great RF Primer!

New Member
Posts: 17
Registered: ‎06-18-2018
Kudos: 1

Re: connecting Nanostation M2 to AP requires username and password

Good, I'm suppose to go camping in a week, so I hope it will work.

New Member
Posts: 17
Registered: ‎04-27-2013
Kudos: 1

Re: connecting Nanostation M2 to AP requires username and password

In most situations with a Captive portal, the following setup would work:

Put the nanostation M2 in station + router mode and setup NAT on the nanostation to create your own internal network range.
This should be a range not commonly used by the locations that you try to connect to. (172.31.100.1/24 would do nicely i think) 

Setup your internal router just as a wifi bride.

Then connect the nanostation to the location's wifi.

With your mobile device try to surf to a non https website 

The catch page of the location will pop up.
Fill in your login details. 

The gateway router will then bind your nanostation MAC to the login details and allow you to surf. 

Depending on the settings of the hotspot, you might need to login on the Catch page when the "inactivity" counter runs out. 
Setup ntp on your routers or use dydns etc, this might help with the inactivity counter. 
Some hotspots only check on http traffic, but some will see ntp traffic and keep the inactivity counter active.

 

Greetings

Steven

New Member
Posts: 17
Registered: ‎06-18-2018
Kudos: 1

Re: connecting Nanostation M2 to AP requires username and password

Hi Steven, 

can you confirm my undanstanding. In my nanostation I set the wireless mode to station and the network mode to router. But on my AirGeteway, the network mode is SOHO router and wireless mode is access point. Those settings on AirGateway are the default not change as the site I point out did. 

 

What do you mean about setup your internal router just as a wifi bridge ?

 

About the login process , it's like I understand refered to the web site I point out in earlier post. 

About inactivity counter runs out, not sure to setup, you talked about ntp an dydns but not found that.  Of course it would better to avoid to enter user and password every inactivity runs out.

 

  Philippe